aboutsummaryrefslogtreecommitdiffstats
path: root/audio/chordpack/Makefile
diff options
context:
space:
mode:
authordanfe <danfe@FreeBSD.org>2018-01-11 19:56:44 +0800
committerdanfe <danfe@FreeBSD.org>2018-01-11 19:56:44 +0800
commita5d23aea7e48146cf287532245d70aa2ceb1ab8b (patch)
tree6f09cecd3695a7c9b5b518c265dc571341916c2d /audio/chordpack/Makefile
parent9dd36302246b453e80d0520a3bea59423e88f7b2 (diff)
downloadfreebsd-ports-gnome-a5d23aea7e48146cf287532245d70aa2ceb1ab8b.tar.gz
freebsd-ports-gnome-a5d23aea7e48146cf287532245d70aa2ceb1ab8b.tar.zst
freebsd-ports-gnome-a5d23aea7e48146cf287532245d70aa2ceb1ab8b.zip
Convert to option helpers, fix minor style issues, use INSTALL_DATA for
installing documentation files instead of abusing INSTALL_MAN.
Diffstat (limited to 'audio/chordpack/Makefile')
-rw-r--r--audio/chordpack/Makefile10
1 files changed, 6 insertions, 4 deletions
diff --git a/audio/chordpack/Makefile b/audio/chordpack/Makefile
index a76240495cf0..0bb5fce03235 100644
--- a/audio/chordpack/Makefile
+++ b/audio/chordpack/Makefile
@@ -13,18 +13,20 @@ COMMENT= Script to convert ChordPro files to HTML, ASCII, and TeX
USES= shebangfix perl5 tar:tgz
SHEBANG_FILES= chordpack
USE_PERL5= run
-NO_WRKSUBDIR= true
-NO_BUILD= true
+NO_WRKSUBDIR= yes
+NO_BUILD= yes
OPTIONS_DEFINE= DOCS
do-install:
${INSTALL_SCRIPT} ${WRKSRC}/chordpack ${STAGEDIR}${PREFIX}/bin
@${MKDIR} ${STAGEDIR}${PREFIX}/share/emacs/site-lisp
- ${INSTALL_DATA} ${WRKSRC}/chordpro-mode.el \
+ ${INSTALL_DATA} ${WRKSRC}/chordpro-mode.el \
${STAGEDIR}${PREFIX}/share/emacs/site-lisp
+
+do-install-DOCS-on:
@${MKDIR} ${STAGEDIR}${DOCSDIR}
- ${INSTALL_MAN} ${WRKSRC}/chordpack-documentation.html \
+ ${INSTALL_DATA} ${WRKSRC}/chordpack-documentation.html \
${STAGEDIR}${DOCSDIR}
.include <bsd.port.mk>