aboutsummaryrefslogtreecommitdiffstats
path: root/audio/cueplayer
diff options
context:
space:
mode:
authortijl <tijl@FreeBSD.org>2014-08-11 03:50:23 +0800
committertijl <tijl@FreeBSD.org>2014-08-11 03:50:23 +0800
commita4d6c8291df773152db305fb1b6fb73ff46ce5d0 (patch)
treec05d182f965de6bace293ed87ece71bd45e7c422 /audio/cueplayer
parentfe632b08e93ba1c874edd2ac8a8dd74b2a8db908 (diff)
downloadfreebsd-ports-gnome-a4d6c8291df773152db305fb1b6fb73ff46ce5d0.tar.gz
freebsd-ports-gnome-a4d6c8291df773152db305fb1b6fb73ff46ce5d0.tar.zst
freebsd-ports-gnome-a4d6c8291df773152db305fb1b6fb73ff46ce5d0.zip
Fix problems with missing libs when the linker enforces explicit linking
(a* to d* categories) PR: 192062
Diffstat (limited to 'audio/cueplayer')
-rw-r--r--audio/cueplayer/Makefile8
1 files changed, 5 insertions, 3 deletions
diff --git a/audio/cueplayer/Makefile b/audio/cueplayer/Makefile
index 74d57f6140c4..de96eacb28ba 100644
--- a/audio/cueplayer/Makefile
+++ b/audio/cueplayer/Makefile
@@ -15,6 +15,7 @@ LIB_DEPENDS= libnotify.so:${PORTSDIR}/devel/libnotify
USES= pkgconfig qmake
USE_QT4= gui xml uic_build moc_build rcc_build network
USE_GSTREAMER= flac good dvd lame ugly ffmpeg taglib ogg vorbis soup libmms wavpack
+USE_XORG= x11
LICENSE= GPLv3
@@ -23,10 +24,11 @@ DESKTOP_ENTRIES="Cueplayer" "Lightweight media player based on Qt and Gstreamer"
"AudioVideo;Audio;Video;" true
post-patch:
- cd ${WRKSRC} && ${REINPLACE_CMD} -e 's,/usr/share/cueplayer/,${DATADIR}/,g' \
- main.cpp ${PORTNAME}.pro
- ${REINPLACE_CMD} -e 's,/usr/share,${PREFIX},g' \
+ @${REINPLACE_CMD} -e 's,/usr/share/cueplayer/,${DATADIR}/,g' \
+ ${WRKSRC}/main.cpp ${WRKSRC}/${PORTNAME}.pro
+ @${REINPLACE_CMD} -e 's,/usr/share,${PREFIX},g' \
${WRKSRC}/${PORTNAME}.pro
+ @${ECHO_CMD} 'PKGCONFIG += x11' >> ${WRKSRC}/${PORTNAME}.pro
post-install:
${INSTALL_DATA} ${WRKSRC}/images/${PORTNAME}.png ${STAGEDIR}${DATADIR}