aboutsummaryrefslogtreecommitdiffstats
path: root/audio/espeak
diff options
context:
space:
mode:
authornivit <nivit@FreeBSD.org>2011-03-18 17:41:25 +0800
committernivit <nivit@FreeBSD.org>2011-03-18 17:41:25 +0800
commitf1f10960c57b3992412a7df4416805218be925d0 (patch)
tree0cd8aa25ee3675a9ced7d126cb90bb3c5fa3740e /audio/espeak
parent3b521e97226dfaa9aa8b0e8c2b9168595dc12062 (diff)
downloadfreebsd-ports-gnome-f1f10960c57b3992412a7df4416805218be925d0.tar.gz
freebsd-ports-gnome-f1f10960c57b3992412a7df4416805218be925d0.tar.zst
freebsd-ports-gnome-f1f10960c57b3992412a7df4416805218be925d0.zip
- Update to 1.45.02
- Remove MD5 checksum from distinfo
Diffstat (limited to 'audio/espeak')
-rw-r--r--audio/espeak/Makefile2
-rw-r--r--audio/espeak/distinfo5
-rw-r--r--audio/espeak/files/patch-src__Makefile (renamed from audio/espeak/files/patch-src-Makefile)43
-rw-r--r--audio/espeak/files/patch-src__speech.h (renamed from audio/espeak/files/patch-src-speech.h)6
-rw-r--r--audio/espeak/pkg-plist7
5 files changed, 25 insertions, 38 deletions
diff --git a/audio/espeak/Makefile b/audio/espeak/Makefile
index 64d96b918c2b..58e9379b7bb4 100644
--- a/audio/espeak/Makefile
+++ b/audio/espeak/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= espeak
-PORTVERSION= 1.44.05
+PORTVERSION= 1.45.02
PORTREVISION= 0
CATEGORIES= audio
MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/${PORTNAME}-${PORTVERSION:R}
diff --git a/audio/espeak/distinfo b/audio/espeak/distinfo
index 28016f213fba..20c3f04bba7f 100644
--- a/audio/espeak/distinfo
+++ b/audio/espeak/distinfo
@@ -1,3 +1,2 @@
-MD5 (espeak-1.44.05-source.zip) = 603b3e5fc8510a82b76f51a94cb3c7a1
-SHA256 (espeak-1.44.05-source.zip) = 89c37e69a7348d638c859ea492958145a790d0d57a057b29f2f5d913541f8ef9
-SIZE (espeak-1.44.05-source.zip) = 2000381
+SHA256 (espeak-1.45.02-source.zip) = 1a259c62ff4d21ec525d5e4ea0980af223ec7bba916ab319c9421a32cbfc085a
+SIZE (espeak-1.45.02-source.zip) = 1891603
diff --git a/audio/espeak/files/patch-src-Makefile b/audio/espeak/files/patch-src__Makefile
index 0fa32cc221a1..4973c73db9f6 100644
--- a/audio/espeak/files/patch-src-Makefile
+++ b/audio/espeak/files/patch-src__Makefile
@@ -1,32 +1,17 @@
---- src/Makefile 2008-12-22 23:37:41.000000000 +0100
-+++ src/Makefile.port 2009-01-13 15:24:01.000000000 +0100
-@@ -1,10 +1,10 @@
+--- ./src/Makefile.orig 2011-03-14 20:43:23.000000000 +0100
++++ ./src/Makefile 2011-03-18 10:11:08.000000000 +0100
+@@ -1,8 +1,8 @@
# remove -fno-exceptions if it causes problems with stdio library on some platforms (ARM)
+-DATADIR=/usr/share/espeak-data
++DATADIR=%%DATADIR%%/espeak-data
+
-PREFIX=/usr
+PREFIX?=/usr
BINDIR=$(PREFIX)/bin
INCDIR=$(PREFIX)/include/espeak
LIBDIR=$(PREFIX)/lib
--DATADIR=$(PREFIX)/share/espeak-data
-+DATADIR=%%DATADIR%%/espeak-data
-
- RELEASE = 1.40
- BIN_NAME = speak
-@@ -24,18 +24,18 @@
- LN_SF = /bin/ln -sf
- MKDIR = mkdir -p
-
--AUDIO = portaudio
-+AUDIO ?= portaudio
- #AUDIO = pulseaudio
- #AUDIO = sada
-
- ifeq ($(AUDIO),pulseaudio)
- WAVE=wave_pulse.cpp
--LIB_AUDIO=-lpulse
-+LIB_AUDIO=-L$(LOCALBASE)/lib -lpulse
- USE_AUDIO=-DUSE_PULSEAUDIO
+@@ -36,7 +36,7 @@
else
ifeq ($(AUDIO),portaudio)
WAVE=wave.cpp
@@ -35,7 +20,7 @@
USE_AUDIO=-DUSE_PORTAUDIO
else
ifeq ($(AUDIO),sada)
-@@ -60,24 +60,24 @@
+@@ -61,24 +61,24 @@
SRCS1=$(speak_SOURCES)
OBJS1=$(patsubst %.cpp,%.o,$(SRCS1))
@@ -64,17 +49,17 @@
+ $(CXX) $(CXXFLAGS) $(PTHREAD_CFLAGS) $(USE_AUDIO) -D PATH_ESPEAK_DATA=\"$(DATADIR)\" -Wall -pedantic -I. -c -fno-exceptions $<
$(BIN_NAME): $(OBJS1)
- $(CXX) -o $@ $(OBJS1) $(LIBS1)
-@@ -88,7 +88,7 @@
+ $(CXX) $(LDFLAGS) -o $@ $(OBJS1) $(LIBS1)
+@@ -89,7 +89,7 @@
x_%.o: %.cpp
-- $(CXX) $(CXXFLAGS) $(USE_AUDIO) -Wall -fpic -fvisibility=hidden -pedantic \
-+ $(CXX) $(CXXFLAGS) $(PTHREAD_CFLAGS) $(USE_AUDIO) -Wall -fpic -fvisibility=hidden -pedantic \
+- $(CXX) $(CXXFLAGS) $(USE_AUDIO) -D PATH_ESPEAK_DATA=\"$(DATADIR)\" -Wall -fpic -fvisibility=hidden -pedantic \
++ $(CXX) $(CXXFLAGS) $(PTHREAD_CFLAGS) $(USE_AUDIO) -D PATH_ESPEAK_DATA=\"$(DATADIR)\" -Wall -fpic -fvisibility=hidden -pedantic \
-I. -D LIBRARY -c -fno-exceptions $< -o x_$*.o
$(LIB_NAME): $(OBJS2)
-@@ -107,7 +107,7 @@
+@@ -109,7 +109,7 @@
install: all
# Create directories
@@ -83,7 +68,7 @@
$(MKDIR) $(DESTDIR)$(BINDIR)
$(MKDIR) $(DESTDIR)$(LIBDIR)
$(MKDIR) $(DESTDIR)$(INCDIR)
-@@ -123,5 +123,5 @@
+@@ -125,5 +125,5 @@
# Install development headers
$(INSTALL) -pm 644 speak_lib.h $(DESTDIR)$(INCDIR)
# Install data files
diff --git a/audio/espeak/files/patch-src-speech.h b/audio/espeak/files/patch-src__speech.h
index 0e20f71a5185..8949bfc66fef 100644
--- a/audio/espeak/files/patch-src-speech.h
+++ b/audio/espeak/files/patch-src__speech.h
@@ -1,6 +1,6 @@
---- src/speech.h Fri Jan 26 10:11:59 2007
-+++ src/speech.h.port Sat Jan 27 00:46:28 2007
-@@ -34,7 +34,7 @@
+--- ./src/speech.h.orig 2011-03-15 15:01:33.000000000 +0100
++++ ./src/speech.h 2011-03-18 10:12:28.000000000 +0100
+@@ -57,7 +57,7 @@
// will look for espeak_data directory here, and also in user's home directory
#ifndef PATH_ESPEAK_DATA
diff --git a/audio/espeak/pkg-plist b/audio/espeak/pkg-plist
index 8bdbb000b737..c05b6ae9e53d 100644
--- a/audio/espeak/pkg-plist
+++ b/audio/espeak/pkg-plist
@@ -4,7 +4,7 @@ include/espeak/speak_lib.h
lib/libespeak.a
lib/libespeak.so
lib/libespeak.so.1
-lib/libespeak.so.1.1.44
+lib/libespeak.so.1.1.45
%%PORTDOCS%%%%DOCSDIR%%/add_language.html
%%PORTDOCS%%%%DOCSDIR%%/analyse.html
%%PORTDOCS%%%%DOCSDIR%%/commands.html
@@ -46,6 +46,8 @@ lib/libespeak.so.1.1.44
%%DATADIR%%/espeak-data/is_dict
%%DATADIR%%/espeak-data/it_dict
%%DATADIR%%/espeak-data/jbo_dict
+%%DATADIR%%/espeak-data/ka_dict
+%%DATADIR%%/espeak-data/kn_dict
%%DATADIR%%/espeak-data/ku_dict
%%DATADIR%%/espeak-data/la_dict
%%DATADIR%%/espeak-data/lv_dict
@@ -104,7 +106,6 @@ lib/libespeak.so.1.1.44
%%DATADIR%%/espeak-data/voices/!v/f3
%%DATADIR%%/espeak-data/voices/!v/f4
%%DATADIR%%/espeak-data/voices/!v/f5
-%%DATADIR%%/espeak-data/voices/!v/fast
%%DATADIR%%/espeak-data/voices/!v/klatt
%%DATADIR%%/espeak-data/voices/!v/klatt2
%%DATADIR%%/espeak-data/voices/!v/klatt3
@@ -147,6 +148,8 @@ lib/libespeak.so.1.1.44
%%DATADIR%%/espeak-data/voices/id
%%DATADIR%%/espeak-data/voices/is
%%DATADIR%%/espeak-data/voices/it
+%%DATADIR%%/espeak-data/voices/ka
+%%DATADIR%%/espeak-data/voices/kn
%%DATADIR%%/espeak-data/voices/ku
%%DATADIR%%/espeak-data/voices/la
%%DATADIR%%/espeak-data/voices/lv