aboutsummaryrefslogtreecommitdiffstats
path: root/audio/festival-freebsoft-utils
diff options
context:
space:
mode:
authordanfe <danfe@FreeBSD.org>2018-01-11 20:39:22 +0800
committerdanfe <danfe@FreeBSD.org>2018-01-11 20:39:22 +0800
commit3967fc7da3cb2ec917c749e7cbf8e7a4cfec690e (patch)
tree8c3b36fee530a00bfc9365878d3571a4219575cb /audio/festival-freebsoft-utils
parent781dcea859103e3868ba7c4a9ccd39400bd50fc5 (diff)
downloadfreebsd-ports-gnome-3967fc7da3cb2ec917c749e7cbf8e7a4cfec690e.tar.gz
freebsd-ports-gnome-3967fc7da3cb2ec917c749e7cbf8e7a4cfec690e.tar.zst
freebsd-ports-gnome-3967fc7da3cb2ec917c749e7cbf8e7a4cfec690e.zip
- Move some knobs to their standard locations within the Makefile
- Use option helper target, deobfuscate installation commands, mute MKDIR's, wrap overly long lines, use INSTAL_DATA when appropriate instead of INSTALL_MAN
Diffstat (limited to 'audio/festival-freebsoft-utils')
-rw-r--r--audio/festival-freebsoft-utils/Makefile20
1 files changed, 10 insertions, 10 deletions
diff --git a/audio/festival-freebsoft-utils/Makefile b/audio/festival-freebsoft-utils/Makefile
index 3aa47459de49..b956c42b347c 100644
--- a/audio/festival-freebsoft-utils/Makefile
+++ b/audio/festival-freebsoft-utils/Makefile
@@ -9,25 +9,25 @@ MASTER_SITES= http://www.freebsoft.org/pub/projects/${PORTNAME}/
MAINTAINER= avilla@FreeBSD.org
COMMENT= Festival utilities focused on interaction with Speech Dispatcher
-OPTIONS_DEFINE= DOCS
-
RUN_DEPENDS= festival:audio/festival \
sox:audio/sox
NO_BUILD= yes
USES= iconv
+INFO= ${PORTNAME}
PORTDOCS= ANNOUNCE NEWS README
-INFO= ${PORTNAME}
+OPTIONS_DEFINE= DOCS
do-install:
- ${MKDIR} ${STAGEDIR}${PREFIX}/share/festival/lib
- cd ${WRKSRC} && ${INSTALL_DATA} *.scm ${STAGEDIR}${PREFIX}/share/festival/lib
- cd ${WRKSRC}/doc && ${INSTALL_MAN} ${PORTNAME}.info ${STAGEDIR}${PREFIX}/${INFO_PATH}
- ${MKDIR} ${STAGEDIR}${DOCSDIR}
-.for f in ${PORTDOCS}
- ${INSTALL_MAN} ${WRKSRC}/${f} ${STAGEDIR}${DOCSDIR}
-.endfor
+ @${MKDIR} ${STAGEDIR}${PREFIX}/share/festival/lib
+ ${INSTALL_DATA} ${WRKSRC}/*.scm ${STAGEDIR}${PREFIX}/share/festival/lib
+ ${INSTALL_DATA} ${WRKSRC}/doc/${PORTNAME}.info \
+ ${STAGEDIR}${PREFIX}/${INFO_PATH}
+
+do-install-DOCS-on:
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_DATA} ${PORTDOCS:S,^,${WRKSRC}/,} ${STAGEDIR}${DOCSDIR}
.include <bsd.port.mk>