aboutsummaryrefslogtreecommitdiffstats
path: root/audio/festlex-oald/Makefile
diff options
context:
space:
mode:
authorwill <will@FreeBSD.org>2000-09-16 16:39:50 +0800
committerwill <will@FreeBSD.org>2000-09-16 16:39:50 +0800
commit480c50e661271cc658583065cffd6e16cc4da6be (patch)
treeff026921dcfc02f9b6bb563671d72af3ee0be411 /audio/festlex-oald/Makefile
parent795b77ca79ef39f3b62a3ea9139cc70969e34eb1 (diff)
downloadfreebsd-ports-gnome-480c50e661271cc658583065cffd6e16cc4da6be.tar.gz
freebsd-ports-gnome-480c50e661271cc658583065cffd6e16cc4da6be.tar.zst
freebsd-ports-gnome-480c50e661271cc658583065cffd6e16cc4da6be.zip
Add festival 1.4.1, a multi-lingual text-to-speech system for Unix. This
commit includes the various ports festival can work with. Big thanks to Trevor for putting in all the time to port these! PR: 21182, 21183, 21184, 21185, 21186, 21187, 21188, 21189 21190, 21191, 21192, 21193, 21194, 21195, 21196, 21197 21198, 21199, 21200, 21201 Submitted by: Trevor Johnson <trevor@jpj.net> Obtained from: NetBSD pkgsrc
Diffstat (limited to 'audio/festlex-oald/Makefile')
-rw-r--r--audio/festlex-oald/Makefile38
1 files changed, 38 insertions, 0 deletions
diff --git a/audio/festlex-oald/Makefile b/audio/festlex-oald/Makefile
new file mode 100644
index 000000000000..181f7409bf60
--- /dev/null
+++ b/audio/festlex-oald/Makefile
@@ -0,0 +1,38 @@
+# New ports collection makefile for: festlex-oald
+# Date created: 2000-06-12
+# Whom: Trevor Johnson <trevor@jpj.net>
+# based on the NetBSD port
+#
+# $NetBSD: Makefile,v 1.7 1999/12/28 04:19:58 wiz Exp $
+# $FreeBSD$
+#
+
+PORTNAME= festlex-oald
+PORTVERSION= 1.4.1
+CATEGORIES= audio
+MASTER_SITES= http://www.speech.cs.cmu.edu/festival/cstr/festival/1.4.1/ \
+ ftp://ftp.cstr.ed.ac.uk/pub/festival/1.4.1/
+DISTNAME= festlex_OALD
+DIST_SUBDIR= festival
+
+MAINTAINER= trevor@jpj.net
+
+RUN_DEPENDS= festival:../festival
+
+RESTRICTED= no-commercial-use
+
+WRKSRC= ${WRKDIR}/festival
+
+NO_BUILD= yes
+
+FHOME= ${PREFIX}/share/festival
+
+post-extract:
+ @ ${CHMOD} -R a+r ${WRKSRC}
+ @ find ${WRKSRC} -type d -print0 | xargs -0 ${CHMOD} 755
+
+do-install:
+ ${MKDIR} ${FHOME}
+ cd ${WRKSRC} && ${CP} -pPR * ${FHOME}
+
+.include <bsd.port.mk>