aboutsummaryrefslogtreecommitdiffstats
path: root/audio/freebirth
diff options
context:
space:
mode:
authorlioux <lioux@FreeBSD.org>2002-08-29 10:07:32 +0800
committerlioux <lioux@FreeBSD.org>2002-08-29 10:07:32 +0800
commit36146e589fa3df615cf11bc06eacb7bc070c1ee7 (patch)
treebf56956a20ce82f7cb1eea5c74c476cbb68d3459 /audio/freebirth
parent4c9028a6c39dc51cbaacca48d1206c7073463d7d (diff)
downloadfreebsd-ports-gnome-36146e589fa3df615cf11bc06eacb7bc070c1ee7.tar.gz
freebsd-ports-gnome-36146e589fa3df615cf11bc06eacb7bc070c1ee7.tar.zst
freebsd-ports-gnome-36146e589fa3df615cf11bc06eacb7bc070c1ee7.zip
o Deploy USE_GNOMENG infrastrcuture
o USE_REINPLACE instead of PERL o Mark BROKEN for FreeBSD 5.x : too unstable on FreeBSD 5.x o Don't redundant strip binaries installed with INSTALL_PROGRAM Submitted by: maintainer
Diffstat (limited to 'audio/freebirth')
-rw-r--r--audio/freebirth/Makefile29
1 files changed, 19 insertions, 10 deletions
diff --git a/audio/freebirth/Makefile b/audio/freebirth/Makefile
index 25cceeed088e..119453d6244c 100644
--- a/audio/freebirth/Makefile
+++ b/audio/freebirth/Makefile
@@ -12,17 +12,28 @@ MASTER_SITES= http://www.bitmechanic.com/projects/freebirth/
MAINTAINER= dyeske@yahoo.com
-USE_GMAKE= yes
-USE_GTK= yes
USE_X_PREFIX= yes
+USE_GNOMENG= yes
+USE_GNOME= gtk12
+USE_GMAKE= yes
+USE_REINPLACE= yes
+
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} >= 500000
+BROKEN= "too unstable on FreeBSD 5.x"
+.endif
pre-build:
- @${PERL} -pi -e 's@-g -O6@${CFLAGS}@g; s@CC=gcc@CC=${CC}@g; \
- s@^all: freebirth@all: Makefile.deps freebirth @g; \
- s@gtk-config@${GTK_CONFIG}@g; \
- s@^LDFLAGS=@LDFLAGS=\$${LOADLIBES}@g' \
+ @${REINPLACE_CMD} -E -e 's|-g[[:space:]]+-O6|${CFLAGS}|; \
+ s|gtk-config|${GTK_CONFIG}|; \
+ s|^all: freebirth|all: Makefile.deps freebirth|; \
+ s|gcc|${CC}|; \
+ s|^LDFLAGS=|LDFLAGS=\$${LOADLIBES}|' \
${WRKSRC}/Makefile
- @${PERL} -pi -e 's@^#define FB_SAMPLES "."@#define FB_SAMPLES "${PREFIX}/share/freebirth"@g;' \
+ @${REINPLACE_CMD} -e 's|include <machine/soundcard.h>|include <sys/soundcard.h>|' \
+ ${WRKSRC}/freebirth.c
+ @${REINPLACE_CMD} -e 's|^#define FB_SAMPLES "."|#define FB_SAMPLES "${PREFIX}/share/freebirth"|' \
${WRKSRC}/raw_wave.h
do-install:
@@ -30,7 +41,5 @@ do-install:
${INSTALL_PROGRAM} ${WRKSRC}/fusebirth ${PREFIX}/bin
@${MKDIR} ${PREFIX}/share/freebirth/raw
${INSTALL_DATA} ${WRKSRC}/raw/*.raw ${PREFIX}/share/freebirth/raw
- ${STRIP_CMD} ${PREFIX}/bin/freebirth
- ${STRIP_CMD} ${PREFIX}/bin/fusebirth
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>