aboutsummaryrefslogtreecommitdiffstats
path: root/audio/funktrackergold
diff options
context:
space:
mode:
authorjylefort <jylefort@FreeBSD.org>2005-04-15 04:53:41 +0800
committerjylefort <jylefort@FreeBSD.org>2005-04-15 04:53:41 +0800
commitc575b16a74a1b779588542398c678cb7b2309c7d (patch)
tree19481657ecb27f670937bf8fb02835d4c7a5f9c1 /audio/funktrackergold
parent5eb7716529dcf666b4d53ad1dac783df701d1600 (diff)
downloadfreebsd-ports-gnome-c575b16a74a1b779588542398c678cb7b2309c7d.tar.gz
freebsd-ports-gnome-c575b16a74a1b779588542398c678cb7b2309c7d.tar.zst
freebsd-ports-gnome-c575b16a74a1b779588542398c678cb7b2309c7d.zip
Fix a crash on startup.
PR: ports/71591 Submitted by: Shawn K. Quinn <skquinn@xevious.kicks-ass.net>, Simon Barner <barner@in.tum.de> Approved by: adamw (mentor), maintainer timeout
Diffstat (limited to 'audio/funktrackergold')
-rw-r--r--audio/funktrackergold/Makefile1
-rw-r--r--audio/funktrackergold/files/patch-funkgold__misc.c26
2 files changed, 27 insertions, 0 deletions
diff --git a/audio/funktrackergold/Makefile b/audio/funktrackergold/Makefile
index b2a450e819a7..4c77ad258615 100644
--- a/audio/funktrackergold/Makefile
+++ b/audio/funktrackergold/Makefile
@@ -7,6 +7,7 @@
PORTNAME= funktrackergold
PORTVERSION= 1.5.2
+PORTREVISION= 1
CATEGORIES= audio
MASTER_SITES= ${MASTER_SITE_SUNSITE} \
http://jsno.leal.com.au/rel/unix_projects/
diff --git a/audio/funktrackergold/files/patch-funkgold__misc.c b/audio/funktrackergold/files/patch-funkgold__misc.c
new file mode 100644
index 000000000000..3557cd198a77
--- /dev/null
+++ b/audio/funktrackergold/files/patch-funkgold__misc.c
@@ -0,0 +1,26 @@
+--- funkgold_misc.c.orig Thu Apr 14 17:48:48 2005
++++ funkgold_misc.c Thu Apr 14 17:49:42 2005
+@@ -30,22 +30,7 @@
+
+ void get_environment(void)
+ {
+- char *os_type = getenv("OSTYPE");
+- register int x;
+- char *os_tt[] = {
+- "Linux",
+- "FreeBSD"
+- };
+-
+- for(x = 0;x < SO_TT_SIZE;x++)
+- if(strcmp(os_tt[x],os_type) == 0)
+- break;
+- switch(x)
+- {
+- case 0: funk_info.funk_cpu_type = FKCPU_LINUX; break;
+- case 1: funk_info.funk_cpu_type = FKCPU_FREEBSD; break;
+- default: funk_info.funk_cpu_type = FKCPU_UNKNOWN; break;
+- }
++ funk_info.funk_cpu_type = FKCPU_FREEBSD;
+ }
+
+ /***************************************************************************