aboutsummaryrefslogtreecommitdiffstats
path: root/audio/ghostess
diff options
context:
space:
mode:
authorEdward Tomasz Napierala <trasz@FreeBSD.org>2008-11-08 20:09:28 +0800
committerEdward Tomasz Napierala <trasz@FreeBSD.org>2008-11-08 20:09:28 +0800
commit23b9bced0bdce4df3ec5b763933938a15f1ba28c (patch)
tree0b9d3eee1df3cc94278ee5dbaff09456bc562e56 /audio/ghostess
parentf57f8d4a576b4254af716b6b7390db5bccb3e8a6 (diff)
downloadfreebsd-ports-gnome-23b9bced0bdce4df3ec5b763933938a15f1ba28c.tar.gz
freebsd-ports-gnome-23b9bced0bdce4df3ec5b763933938a15f1ba28c.tar.zst
freebsd-ports-gnome-23b9bced0bdce4df3ec5b763933938a15f1ba28c.zip
Fix build after recent audio/jack update.
PR: ports/125900
Diffstat (limited to 'audio/ghostess')
-rw-r--r--audio/ghostess/Makefile9
-rw-r--r--audio/ghostess/files/patch-src-ghostess.c22
2 files changed, 27 insertions, 4 deletions
diff --git a/audio/ghostess/Makefile b/audio/ghostess/Makefile
index 50ab6f532c0f..464c7dc892c3 100644
--- a/audio/ghostess/Makefile
+++ b/audio/ghostess/Makefile
@@ -7,7 +7,7 @@
PORTNAME= ghostess
PORTVERSION= 20061127
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= audio
MASTER_SITES= http://home.jps.net/~musound/
@@ -17,7 +17,12 @@ COMMENT= Graphical DSSI host with JACK MIDI support
LIB_DEPENDS= dssialsacompat.0:${PORTSDIR}/audio/libdssialsacompat \
lo.6:${PORTSDIR}/audio/liblo \
jack.0:${PORTSDIR}/audio/jack
-BUILD_DEPENDS= ${LOCALBASE}/include/dssi.h:${PORTSDIR}/audio/dssi
+BUILD_DEPENDS= ${LOCALBASE}/include/dssi.h:${PORTSDIR}/audio/dssi \
+ jackit>=0.109.2:${PORTSDIR}/audio/jack
+
+# Between 0.109.0 and earlier versions there was an api change in JACK.
+# However, the library version number was not changed. The line above
+# is supposed to work around that.
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --with-jackmidi
diff --git a/audio/ghostess/files/patch-src-ghostess.c b/audio/ghostess/files/patch-src-ghostess.c
index 3f50304bc872..910215fe1730 100644
--- a/audio/ghostess/files/patch-src-ghostess.c
+++ b/audio/ghostess/files/patch-src-ghostess.c
@@ -1,5 +1,5 @@
---- src/ghostess.c.orig Sat Jan 13 19:36:01 2007
-+++ src/ghostess.c Sat Jan 13 19:36:18 2007
+--- src/ghostess.c.orig 2006-11-28 06:39:41.000000000 +0100
++++ src/ghostess.c 2008-07-23 01:33:28.000000000 +0200
@@ -56,6 +56,7 @@
#include <dirent.h>
#include <pthread.h>
@@ -8,3 +8,21 @@
#include <gtk/gtk.h>
+@@ -232,7 +233,7 @@
+ void* midi_port_buf = jack_port_get_buffer(midi_input_port, nframes);
+ jack_midi_event_t jack_midi_event;
+ jack_nframes_t jack_midi_event_index = 0;
+- jack_nframes_t jack_midi_event_count = jack_midi_get_event_count(midi_port_buf, nframes);
++ jack_nframes_t jack_midi_event_count = jack_midi_get_event_count(midi_port_buf);
+ static snd_seq_event_t jack_seq_event_holder[3];
+ snd_seq_event_t *jack_seq_event = NULL, *osc_seq_event = NULL;
+ int had_midi_overflow = 0;
+@@ -258,7 +259,7 @@
+
+ int count;
+
+- jack_midi_event_get(&jack_midi_event, midi_port_buf, jack_midi_event_index, nframes);
++ jack_midi_event_get(&jack_midi_event, midi_port_buf, jack_midi_event_index);
+ jack_midi_event_index++;
+
+ jack_seq_event = jack_seq_event_holder;