aboutsummaryrefslogtreecommitdiffstats
path: root/audio/gmidimonitor
diff options
context:
space:
mode:
authorbapt <bapt@FreeBSD.org>2015-04-08 23:05:48 +0800
committerbapt <bapt@FreeBSD.org>2015-04-08 23:05:48 +0800
commit11557d3b1ca381824ecc50f020623ed56d4ce36a (patch)
tree81627af7b0f0c701d807cb8a4046a4740517b9f9 /audio/gmidimonitor
parent1ed12c409b16770d2cb109c7a67bf65ef1a3f27b (diff)
downloadfreebsd-ports-gnome-11557d3b1ca381824ecc50f020623ed56d4ce36a.tar.gz
freebsd-ports-gnome-11557d3b1ca381824ecc50f020623ed56d4ce36a.tar.zst
freebsd-ports-gnome-11557d3b1ca381824ecc50f020623ed56d4ce36a.zip
Add a new USES=waf to handle the waf building system, allowing to factorise code
Plug waf into MAKE_CMD and CONFIGURE_CMD so the regular defined targets can be reused Always define _MAKE_JOBS so that when bsd.port.mk will stop overwritting _MAKE_JOBS when parallel jobs are disabled we can enforce -j1 (which is needed to really disable parallelisation with waf WAF_CMD has been created to allow one to override the location of the waf script relatively to WRKSRC CONFIGURE_TARGET is by default defined to "configure" ALL_TARGET is by default defined to "build" INSTALL_TARGET is by default defined to "install" USES=waf is by default stagedir safe
Diffstat (limited to 'audio/gmidimonitor')
-rw-r--r--audio/gmidimonitor/Makefile15
1 files changed, 3 insertions, 12 deletions
diff --git a/audio/gmidimonitor/Makefile b/audio/gmidimonitor/Makefile
index 838e2d7106c1..7793400e5c1f 100644
--- a/audio/gmidimonitor/Makefile
+++ b/audio/gmidimonitor/Makefile
@@ -13,23 +13,14 @@ COMMENT= GTK+ application that shows MIDI events
LIB_DEPENDS= libjack.so:${PORTSDIR}/audio/jack \
liblash.so:${PORTSDIR}/audio/lash
-USES= pkgconfig tar:bzip2
+USES= pkgconfig tar:bzip2 waf
USE_GNOME= gtk20 libglade2
+CONFIGURE_ARGS= --alsa=no
+
LICENSE= GPLv2
LICENSE_FILE= ${WRKSRC}/COPYING
PLIST_FILES= bin/gmidimonitor %%DATADIR%%/gmidimonitor.ui
-MAKE_JOBS_ARGS= -j${MAKE_JOBS_NUMBER}
-
-do-configure:
- @(cd ${WRKSRC} && ./waf configure --prefix=${PREFIX} --alsa=no)
-
-do-build:
- @(cd ${WRKSRC} && ./waf ${MAKE_JOBS_ARGS})
-
-do-install:
- @(cd ${WRKSRC} && ./waf --destdir=${STAGEDIR} install)
-
.include <bsd.port.mk>