aboutsummaryrefslogtreecommitdiffstats
path: root/audio/gmpc-lyrics/Makefile
diff options
context:
space:
mode:
authormiwi <miwi@FreeBSD.org>2007-09-16 17:17:50 +0800
committermiwi <miwi@FreeBSD.org>2007-09-16 17:17:50 +0800
commit453e9d552d8084e8e4a077ae6f14d2b599783f65 (patch)
tree6bbc57763f787675dc2e60bf662e6867c6571749 /audio/gmpc-lyrics/Makefile
parent954175472d185e0429f983125277ffd6179f7629 (diff)
downloadfreebsd-ports-gnome-453e9d552d8084e8e4a077ae6f14d2b599783f65.tar.gz
freebsd-ports-gnome-453e9d552d8084e8e4a077ae6f14d2b599783f65.tar.zst
freebsd-ports-gnome-453e9d552d8084e8e4a077ae6f14d2b599783f65.zip
This plugin fetches lyrics from the internet. It uses the following websites
as sources: * LyricWiki * LeosLyrics * Lyrics Tracker WWW: http://sarine.nl/gmpc-plugins
Diffstat (limited to 'audio/gmpc-lyrics/Makefile')
-rw-r--r--audio/gmpc-lyrics/Makefile25
1 files changed, 25 insertions, 0 deletions
diff --git a/audio/gmpc-lyrics/Makefile b/audio/gmpc-lyrics/Makefile
new file mode 100644
index 000000000000..2bb28666f1de
--- /dev/null
+++ b/audio/gmpc-lyrics/Makefile
@@ -0,0 +1,25 @@
+# New ports collection makefile for: gmpc-lyrics
+# Date created: September 14 2007
+# Whom: Martin Wilke <miwi@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= gmpc-lyrics
+PORTVERSION= 0.15.0
+CATEGORIES= audio
+MASTER_SITES= http://download.sarine.nl/gmpc-${PORTVERSION}/plugins/
+
+MAINTAINER= miwi@FreeBSD.org
+COMMENT= A Lyrics Provider plugin for gmpc
+
+LIB_DEPENDS= mpd:${PORTSDIR}/audio/libmpd \
+ curl.4:${PORTSDIR}/ftp/curl
+BUILD_DEPENDS= ${LOCALBASE}/libdata/pkgconfig/gmpc.pc:${PORTSDIR}/audio/gmpc
+RUN_DEPEND= gmpc:${PORTSDIR}/audio/gmpc
+
+GNU_CONFIGURE= yes
+USE_XLIB= yes
+USE_GNOME= gnomehack
+
+.include <bsd.port.mk>