aboutsummaryrefslogtreecommitdiffstats
path: root/audio/gnump3d/Makefile
diff options
context:
space:
mode:
authorijliao <ijliao@FreeBSD.org>2002-05-27 21:25:00 +0800
committerijliao <ijliao@FreeBSD.org>2002-05-27 21:25:00 +0800
commitdee77b134aec99d5f7c863b2b8c3051d06d5267a (patch)
tree732fd48bb96e5d47b4e62eab0e4d02458d0bfd09 /audio/gnump3d/Makefile
parent80c8690d2bdcdaf0b8cd2db77ffa4dc364f6ad40 (diff)
downloadfreebsd-ports-gnome-dee77b134aec99d5f7c863b2b8c3051d06d5267a.tar.gz
freebsd-ports-gnome-dee77b134aec99d5f7c863b2b8c3051d06d5267a.tar.zst
freebsd-ports-gnome-dee77b134aec99d5f7c863b2b8c3051d06d5267a.zip
add gnump3d 0.9.9.7
A streaming server for MP3's, OGG vorbis, and other streamable audio files
Diffstat (limited to 'audio/gnump3d/Makefile')
-rw-r--r--audio/gnump3d/Makefile26
1 files changed, 26 insertions, 0 deletions
diff --git a/audio/gnump3d/Makefile b/audio/gnump3d/Makefile
new file mode 100644
index 000000000000..7b05e864ebb8
--- /dev/null
+++ b/audio/gnump3d/Makefile
@@ -0,0 +1,26 @@
+# ex:ts=8
+# Ports collection makefile for: gnump3d
+# Date created: May 27, 2002
+# Whom: ijliao
+#
+# $FreeBSD$
+#
+
+PORTNAME= gnump3d
+PORTVERSION= 0.9.9.7
+CATEGORIES= audio
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= ${PORTNAME}
+
+MAINTAINER= ports@FreeBSD.org
+
+ALL_TARGET= freebsd
+
+MAN1= mp3d.1 mp3d.conf.1 mp3d-top.1
+
+post-patch:
+ @${PERL} -pi -e "s,^PREFIX,#PREFIX,g ; \
+ s,/usr/local,${PREFIX},g ; \
+ s,-pthread,${PTHREAD_LIBS},g" ${WRKSRC}/mkfiles/freebsd
+
+.include <bsd.port.mk>