aboutsummaryrefslogtreecommitdiffstats
path: root/audio/grip/Makefile
diff options
context:
space:
mode:
authoredwin <edwin@FreeBSD.org>2003-09-08 14:12:56 +0800
committeredwin <edwin@FreeBSD.org>2003-09-08 14:12:56 +0800
commit1e234701a32047274621d9c16bf27a76107b3d10 (patch)
treed9047e6ce885bb88a035bf9ea138f93b72d7cc22 /audio/grip/Makefile
parenta4b639d7696f8f2f0fbe6bbf4d3a74a98167f8f6 (diff)
downloadfreebsd-ports-gnome-1e234701a32047274621d9c16bf27a76107b3d10.tar.gz
freebsd-ports-gnome-1e234701a32047274621d9c16bf27a76107b3d10.tar.zst
freebsd-ports-gnome-1e234701a32047274621d9c16bf27a76107b3d10.zip
Update port: audio/grip
- Reaarange USE_GNOME - Add optional cdparanoia support PR: ports/56521 Submitted by: KATO Tsuguru <tkato@prontomail.com>
Diffstat (limited to 'audio/grip/Makefile')
-rw-r--r--audio/grip/Makefile30
1 files changed, 13 insertions, 17 deletions
diff --git a/audio/grip/Makefile b/audio/grip/Makefile
index 8c4f9ef6c08c..b68d6c95e028 100644
--- a/audio/grip/Makefile
+++ b/audio/grip/Makefile
@@ -7,7 +7,7 @@
PORTNAME= grip
PORTVERSION= 3.0.7
-PORTREVISION= 0
+PORTREVISION= 1
CATEGORIES= audio
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR=grip
@@ -19,27 +19,23 @@ LIB_DEPENDS= id3-3.8.2:${PORTSDIR}/audio/id3lib \
ghttp.1:${PORTSDIR}/www/libghttp
USE_X_PREFIX= yes
-
+USE_GNOME= gnomehack gnomelibs gnomeprefix gnometarget
USE_GMAKE= yes
GNU_CONFIGURE= yes
-USE_GNOME= gnomelibs
-
-CONFIGURE_ARGS+= --datadir=${PREFIX}/share
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include ${PTHREAD_CFLAGS}" \
+ LDFLAGS="-L${LOCALBASE}/lib ${PTHREAD_LIBS}"
-CFLAGS+= ${PTHREAD_CFLAGS}
-LDFLAGS= -L${LOCALBASE}/lib
-
-.if defined(WITH_DEBUG)
-CFLAGS+= -g
-LDFLAGS+= -g
+.if defined(WITH_CDPARANOIA)
+LIB_DEPENDS+= cdda_paranoia.0:${PORTSDIR}/audio/cdparanoia
+.else
+CONFIGURE_ARGS+= --disable-cdpar
.endif
-CONFIGURE_ENV+= CFLAGS="${CFLAGS}"
-CONFIGURE_ENV+= CPPFLAGS="-I${LOCALBASE}/include"
-CONFIGURE_ENV+= CXXFLAGS="${CXXFLAGS}"
-CONFIGURE_ENV+= LDFLAGS="${LDFLAGS}"
-CONFIGURE_ENV+= LIBS=${PTHREAD_LIBS}
-post-install::
+post-patch:
+ @${REINPLACE_CMD} -e \
+ 's|helpdir)/images|helpdir)|g' ${WRKSRC}/doc/C/Makefile.in
+
+post-install:
@${CAT} ${PKGMESSAGE}
.include <bsd.port.mk>