aboutsummaryrefslogtreecommitdiffstats
path: root/audio/grip
diff options
context:
space:
mode:
authorpav <pav@FreeBSD.org>2004-05-25 16:51:01 +0800
committerpav <pav@FreeBSD.org>2004-05-25 16:51:01 +0800
commit5dbb96d26eecba89ce7c3269282c4d4870c3864b (patch)
treeff35b95a007c9d857f76a0ce9ddea90df584e184 /audio/grip
parentca3f9b35205574f258fa57a7903f133e044807cb (diff)
downloadfreebsd-ports-gnome-5dbb96d26eecba89ce7c3269282c4d4870c3864b.tar.gz
freebsd-ports-gnome-5dbb96d26eecba89ce7c3269282c4d4870c3864b.tar.zst
freebsd-ports-gnome-5dbb96d26eecba89ce7c3269282c4d4870c3864b.zip
- Convert de es fr pt_BR ru gettext catalogues to Unicode. This should fix
weird characters under these locales. PR: ports/66796 Submitted by: Franz Klammer <klammer@webonaut.com> Approved by: maintainer
Diffstat (limited to 'audio/grip')
-rw-r--r--audio/grip/Makefile10
1 files changed, 9 insertions, 1 deletions
diff --git a/audio/grip/Makefile b/audio/grip/Makefile
index 9bc99b5059d8..aa9d5fdc27e6 100644
--- a/audio/grip/Makefile
+++ b/audio/grip/Makefile
@@ -7,7 +7,7 @@
PORTNAME= grip
PORTVERSION= 3.2.0
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= audio
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
@@ -17,6 +17,7 @@ COMMENT= GTK front-end to external cd rippers and audio encoders
LIB_DEPENDS= id3-3.8.3:${PORTSDIR}/audio/id3lib \
curl.2:${PORTSDIR}/ftp/curl
+PATCH_DEPENDS= iconv:${PORTSDIR}/converters/libiconv
USE_X_PREFIX= yes
USE_GNOME= gnomehack gnomeprefix gnometarget libgnomeui vte
@@ -36,6 +37,8 @@ OPTIONS= CDPARANOIA "Ripper: Enable cdparanoia support" on \
MP3ENCODE "Encoder: mp3encode: Install audio/mp3encode" off \
VORBIS "Encoder: oggenc: Install audio/vorbis-tools" off
+ISO_LOCALES= de es fr pt_BR ru
+
.include <bsd.port.pre.mk>
.if defined(WITH_CDROM_DEVICE)
@@ -105,5 +108,10 @@ post-patch:
s|{"l3enc","-br %b %w %m","mp3"},|{"faac","-w -b %b %w -o %m", "m4a"},|; \
s|mp3encode|encode|' \
${WRKSRC}/src/gripcfg.c
+.for l in ${ISO_LOCALES}
+ @${MV} ${WRKSRC}/po/${l}.po ${WRKSRC}/po/_${l}.po
+ ${LOCALBASE}/bin/iconv -f ISO-8859-15 -t UTF-8 \
+ ${WRKSRC}/po/_${l}.po > ${WRKSRC}/po/${l}.po
+.endfor
.include <bsd.port.post.mk>