aboutsummaryrefslogtreecommitdiffstats
path: root/audio/icecast
diff options
context:
space:
mode:
authorKoop Mast <kwm@rainbow-runner.nl>2018-11-12 00:22:39 +0800
committerKoop Mast <kwm@rainbow-runner.nl>2018-11-12 00:22:39 +0800
commit9b580ffb435c69606f640c5a657190b54a1ef870 (patch)
treeb85006a979d929da61946937a62b6c6b97fa4c79 /audio/icecast
parent6a4416929169733984a0ac898468560f66931e1c (diff)
parentf86bb659dcd66c74ffce85ffcc1575d2095989f8 (diff)
downloadfreebsd-ports-gnome-gnome-3.28.tar.gz
freebsd-ports-gnome-gnome-3.28.tar.zst
freebsd-ports-gnome-gnome-3.28.zip
Merge branch 'master' into gnome-3.28gnome-3.28
Diffstat (limited to 'audio/icecast')
-rw-r--r--audio/icecast/Makefile44
-rw-r--r--audio/icecast/distinfo5
-rw-r--r--audio/icecast/files/icecast.in41
-rw-r--r--audio/icecast/files/patch-conf-Makefile.in12
-rw-r--r--audio/icecast/files/pkg-message.in18
-rw-r--r--audio/icecast/pkg-descr8
-rw-r--r--audio/icecast/pkg-plist63
7 files changed, 191 insertions, 0 deletions
diff --git a/audio/icecast/Makefile b/audio/icecast/Makefile
new file mode 100644
index 000000000000..8de228ce9b17
--- /dev/null
+++ b/audio/icecast/Makefile
@@ -0,0 +1,44 @@
+# Created by: Chip Marshall <chip@eboai.org>
+# $FreeBSD$
+
+PORTNAME= icecast
+PORTVERSION= 2.4.4
+PORTEPOCH= 1
+CATEGORIES= audio net ipv6
+MASTER_SITES= https://downloads.xiph.org/releases/icecast/:source \
+ https://svn.xiph.org/releases/icecast/:source \
+ LOCAL/sunpoet/icecast:icon,source \
+ https://github.com/xiph/Icecast-Server/raw/master/web/:icon
+DISTFILES= ${DISTNAME}${EXTRACT_SUFX}:source \
+ favicon.ico:icon
+DIST_SUBDIR= icecast
+EXTRACT_ONLY= ${DISTNAME}${EXTRACT_SUFX}
+
+MAINTAINER= sunpoet@FreeBSD.org
+COMMENT= Streaming mp3/ogg-vorbis audio server
+
+LICENSE= GPLv2
+LICENSE_FILE= ${WRKSRC}/COPYING
+
+LIB_DEPENDS= libcurl.so:ftp/curl \
+ libogg.so:audio/libogg \
+ libspeex.so:audio/speex \
+ libtheora.so:multimedia/libtheora \
+ libvorbis.so:audio/libvorbis
+
+OPTIONS_DEFINE= DOCS
+
+USES= cpe gmake gnome localbase ssl
+USE_GNOME= libxml2 libxslt
+
+GNU_CONFIGURE= yes
+USE_RC_SUBR= ${PORTNAME}
+
+SUB_FILES= pkg-message
+
+CPE_VENDOR= xiph
+
+post-install:
+ ${INSTALL_DATA} ${DISTDIR}/${DIST_SUBDIR}/favicon.ico ${STAGEDIR}${DATADIR}/web/
+
+.include <bsd.port.mk>
diff --git a/audio/icecast/distinfo b/audio/icecast/distinfo
new file mode 100644
index 000000000000..c8649b64a8e7
--- /dev/null
+++ b/audio/icecast/distinfo
@@ -0,0 +1,5 @@
+TIMESTAMP = 1541182977
+SHA256 (icecast/icecast-2.4.4.tar.gz) = 49b5979f9f614140b6a38046154203ee28218d8fc549888596a683ad604e4d44
+SIZE (icecast/icecast-2.4.4.tar.gz) = 2360592
+SHA256 (icecast/favicon.ico) = 6e22f7e26d2f97e9c1b7840458bcd29a81a6ad3433248506f56cdc305ec7487e
+SIZE (icecast/favicon.ico) = 1406
diff --git a/audio/icecast/files/icecast.in b/audio/icecast/files/icecast.in
new file mode 100644
index 000000000000..83261185e2af
--- /dev/null
+++ b/audio/icecast/files/icecast.in
@@ -0,0 +1,41 @@
+#!/bin/sh
+#
+# $FreeBSD$
+#
+
+# PROVIDE: icecast
+# REQUIRE: DAEMON
+# BEFORE: LOGIN
+# KEYWORD: shutdown
+
+# Add the following line to /etc/rc.conf to enable `icecast'.
+#
+#icecast_enable="YES"
+#
+# To specify a non-default configuration file, set icecast_config
+# in /etc/rc.conf:
+#
+#icecast_config="%%PREFIX%%/etc/icecast.xml"
+#
+# Make sure the <changeowner> section in your configuration file is
+# not commented out - icecast refuses to run as root.
+#
+
+. /etc/rc.subr
+
+name="icecast"
+rcvar=icecast_enable
+
+command="%%PREFIX%%/bin/icecast"
+command_args="-b 1>/dev/null"
+extra_commands="reload"
+
+# read configuration and set defaults
+load_rc_config "$name"
+: ${icecast_enable="NO"}
+: ${icecast_config="%%PREFIX%%/etc/${name}.xml"}
+: ${icecast_flags="-c ${icecast_config}"}
+
+required_files="${icecast_config}"
+
+run_rc_command "$1"
diff --git a/audio/icecast/files/patch-conf-Makefile.in b/audio/icecast/files/patch-conf-Makefile.in
new file mode 100644
index 000000000000..d515eed5ad6a
--- /dev/null
+++ b/audio/icecast/files/patch-conf-Makefile.in
@@ -0,0 +1,12 @@
+--- conf/Makefile.in.orig 2016-01-04 21:07:07 UTC
++++ conf/Makefile.in
+@@ -539,8 +539,7 @@ uninstall-am: uninstall-docDATA
+
+ install-data-hook:
+ $(mkinstalldirs) $(DESTDIR)$(sysconfdir)
+- test -f $(DESTDIR)$(sysconfdir)/icecast.xml || \
+- $(INSTALL_DATA) icecast.xml.dist $(DESTDIR)$(sysconfdir)/icecast.xml
++ $(INSTALL_DATA) icecast.xml.dist $(DESTDIR)$(sysconfdir)/icecast.xml.sample
+
+ icecast.xml.dist: $(srcdir)/icecast.xml.in
+ $(edit) $(srcdir)/icecast.xml.in > icecast.xml.dist
diff --git a/audio/icecast/files/pkg-message.in b/audio/icecast/files/pkg-message.in
new file mode 100644
index 000000000000..0bb7e6898662
--- /dev/null
+++ b/audio/icecast/files/pkg-message.in
@@ -0,0 +1,18 @@
+To start icecast at system boot, copy
+%%PREFIX%%/etc/icecast.xml.sample to %%PREFIX%%/etc/icecast.xml, customize
+to your environment as desired and add:
+
+icecast_enable="yes"
+
+to /etc/rc.conf. See the icecast -h command for optional additional
+flags. To specify an alternative config file for example add:
+
+icecast_flags="-c /path/to/your/configuration.xml"
+
+**********************************************************************
+** Make sure the <changeowner> section in your configuration file **
+** is NOT commented out. Icecast will refuse to run as root. **
+** **
+** Also make sure that the user you choose is able to write to your **
+** configured log directory, otherwise icecast will refuse to run. **
+**********************************************************************
diff --git a/audio/icecast/pkg-descr b/audio/icecast/pkg-descr
new file mode 100644
index 000000000000..65ba53f24737
--- /dev/null
+++ b/audio/icecast/pkg-descr
@@ -0,0 +1,8 @@
+Icecast is a streaming mp3/ogg-vorbis audio server.
+
+Icecast provides nearly all the functionality of the Shoutcast server.
+It will accept encoding streams from encoders like winamp, shout and ices.
+It can also add itself to a directory server such as our own
+icecast.linuxpower.org or Nullsoft's yp.shoutcast.com.
+
+WWW: https://icecast.org/
diff --git a/audio/icecast/pkg-plist b/audio/icecast/pkg-plist
new file mode 100644
index 000000000000..37580c527c60
--- /dev/null
+++ b/audio/icecast/pkg-plist
@@ -0,0 +1,63 @@
+bin/icecast
+etc/icecast.xml.sample
+%%PORTDOCS%%%%DOCSDIR%%/AUTHORS
+%%PORTDOCS%%%%DOCSDIR%%/COPYING
+%%PORTDOCS%%%%DOCSDIR%%/ChangeLog
+%%PORTDOCS%%%%DOCSDIR%%/NEWS
+%%PORTDOCS%%%%DOCSDIR%%/README
+%%PORTDOCS%%%%DOCSDIR%%/TODO
+%%PORTDOCS%%%%DOCSDIR%%/admin-interface.html
+%%PORTDOCS%%%%DOCSDIR%%/assets/css/style.css
+%%PORTDOCS%%%%DOCSDIR%%/assets/font/FiraMono-Bold.eot
+%%PORTDOCS%%%%DOCSDIR%%/assets/font/FiraMono-Bold.woff
+%%PORTDOCS%%%%DOCSDIR%%/assets/font/FiraMono-Regular.eot
+%%PORTDOCS%%%%DOCSDIR%%/assets/font/FiraMono-Regular.woff
+%%PORTDOCS%%%%DOCSDIR%%/assets/font/FiraSans-Bold.eot
+%%PORTDOCS%%%%DOCSDIR%%/assets/font/FiraSans-Bold.woff
+%%PORTDOCS%%%%DOCSDIR%%/assets/font/FiraSans-BoldItalic.eot
+%%PORTDOCS%%%%DOCSDIR%%/assets/font/FiraSans-BoldItalic.woff
+%%PORTDOCS%%%%DOCSDIR%%/assets/font/FiraSans-Italic.eot
+%%PORTDOCS%%%%DOCSDIR%%/assets/font/FiraSans-Italic.woff
+%%PORTDOCS%%%%DOCSDIR%%/assets/font/FiraSans-Regular.eot
+%%PORTDOCS%%%%DOCSDIR%%/assets/font/FiraSans-Regular.woff
+%%PORTDOCS%%%%DOCSDIR%%/assets/img/xiph-community.svg
+%%PORTDOCS%%%%DOCSDIR%%/auth.html
+%%PORTDOCS%%%%DOCSDIR%%/basic-setup.html
+%%PORTDOCS%%%%DOCSDIR%%/changes.html
+%%PORTDOCS%%%%DOCSDIR%%/config-file.html
+%%PORTDOCS%%%%DOCSDIR%%/faq.html
+%%PORTDOCS%%%%DOCSDIR%%/glossary.html
+%%PORTDOCS%%%%DOCSDIR%%/img/listener_auth1.png
+%%PORTDOCS%%%%DOCSDIR%%/img/listener_auth2.png
+%%PORTDOCS%%%%DOCSDIR%%/img/listener_auth3.png
+%%PORTDOCS%%%%DOCSDIR%%/img/masterslave.png
+%%PORTDOCS%%%%DOCSDIR%%/img/relay.png
+%%PORTDOCS%%%%DOCSDIR%%/index.html
+%%PORTDOCS%%%%DOCSDIR%%/introduction.html
+%%PORTDOCS%%%%DOCSDIR%%/relaying.html
+%%PORTDOCS%%%%DOCSDIR%%/server-stats.html
+%%PORTDOCS%%%%DOCSDIR%%/win32.html
+%%PORTDOCS%%%%DOCSDIR%%/yp.html
+%%DATADIR%%/admin/listclients.xsl
+%%DATADIR%%/admin/listmounts.xsl
+%%DATADIR%%/admin/manageauth.xsl
+%%DATADIR%%/admin/moveclients.xsl
+%%DATADIR%%/admin/response.xsl
+%%DATADIR%%/admin/stats.xsl
+%%DATADIR%%/admin/updatemetadata.xsl
+%%DATADIR%%/admin/vclt.xsl
+%%DATADIR%%/admin/xspf.xsl
+%%DATADIR%%/doc/icecast.xml.dist
+%%DATADIR%%/doc/icecast_minimal.xml.dist
+%%DATADIR%%/doc/icecast_shoutcast_compat.xml.dist
+%%DATADIR%%/doc/icecast_urlauth.xml.dist
+%%DATADIR%%/web/auth.xsl
+%%DATADIR%%/web/favicon.ico
+%%DATADIR%%/web/icecast.png
+%%DATADIR%%/web/key.png
+%%DATADIR%%/web/server_version.xsl
+%%DATADIR%%/web/status-json.xsl
+%%DATADIR%%/web/status.xsl
+%%DATADIR%%/web/style.css
+%%DATADIR%%/web/tunein.png
+%%DATADIR%%/web/xml2json.xslt