aboutsummaryrefslogtreecommitdiffstats
path: root/audio/ices
diff options
context:
space:
mode:
authorarved <arved@FreeBSD.org>2003-01-19 00:56:25 +0800
committerarved <arved@FreeBSD.org>2003-01-19 00:56:25 +0800
commit3197f15fa8655f5e589ca374e1a2ca4b66dfb2f7 (patch)
treec4c689214caa7a3561b5e4608659cf2434b7a357 /audio/ices
parent202ef9e4d964ddb7933e45a7b7116ef23152bd7c (diff)
downloadfreebsd-ports-gnome-3197f15fa8655f5e589ca374e1a2ca4b66dfb2f7.tar.gz
freebsd-ports-gnome-3197f15fa8655f5e589ca374e1a2ca4b66dfb2f7.tar.zst
freebsd-ports-gnome-3197f15fa8655f5e589ca374e1a2ca4b66dfb2f7.zip
Add ices, streaming source client for icecast 2 servers. It provides flexible
and powerful static and live streaming capabilities for Ogg Vorbis streams. PR: 45249 Submitted by: Michael Nottebrock <michaelnottebrock@gmx.net>
Diffstat (limited to 'audio/ices')
-rw-r--r--audio/ices/Makefile46
-rw-r--r--audio/ices/distinfo1
-rw-r--r--audio/ices/pkg-comment1
-rw-r--r--audio/ices/pkg-descr4
-rw-r--r--audio/ices/pkg-plist2
5 files changed, 54 insertions, 0 deletions
diff --git a/audio/ices/Makefile b/audio/ices/Makefile
new file mode 100644
index 000000000000..34f3af4d5d96
--- /dev/null
+++ b/audio/ices/Makefile
@@ -0,0 +1,46 @@
+# New ports collection makefile for: ices
+# Date created: 11 Nov 2002
+# Whom: Michael Nottebrock <michaelnottebrock@gmx.net>
+#
+# $FreeBSD$
+#
+
+PORTNAME= ices
+PORTVERSION= 20021112
+CATEGORIES= audio net
+MASTER_SITES= http://tigress.com/lofi/ \
+ http://lofi.dyndns.org/
+DISTNAME= ${PORTNAME}-devel-${PORTVERSION}
+
+MAINTAINER= michaelnottebrock@gmx.net
+
+LIB_DEPENDS= ogg.4:${PORTSDIR}/audio/libogg \
+ shout.3:${PORTSDIR}/audio/libshout2 \
+ vorbis.2:${PORTSDIR}/audio/libvorbis \
+ xml2.5:${PORTSDIR}/textproc/libxml2
+
+CONFIGURE_ARGS= --disable-oggtest --disable-vorbistest --disable-shouttest
+CONFIGURE_ENV= CFLAGS="${PTHREAD_CFLAGS} -I${LOCALBASE}/include" \
+ LDFLAGS="${PTHREAD_LIBS} -L${LOCALBASE}/lib"
+GNU_CONFIGURE= yes
+USE_GMAKE= yes
+USE_LIBTOOL= yes
+USE_REINPLACE= yes
+
+WRKSRC= ${WRKDIR}/ices
+
+post-configure:
+ @${REINPLACE_CMD} -e 's|-lpthread|${PTHREAD_LIBS}|g' ${WRKSRC}/src/Makefile
+ @${REINPLACE_CMD} -e 's|-O20|${CFLAGS}|g' ${WRKSRC}/conf/Makefile \
+ ${WRKSRC}/src/avl/Makefile \
+ ${WRKSRC}/src/log/Makefile \
+ ${WRKSRC}/src/net/Makefile \
+ ${WRKSRC}/src/thread/Makefile \
+ ${WRKSRC}/src/timing/Makefile \
+ ${WRKSRC}/src/Makefile \
+ ${WRKSRC}/Makefile
+
+post-install:
+ @${INSTALL_SCRIPT} ${WRKSRC}/contrib/run_ices ${LOCALBASE}/bin
+
+.include <bsd.port.mk>
diff --git a/audio/ices/distinfo b/audio/ices/distinfo
new file mode 100644
index 000000000000..47b1fdb9a4fa
--- /dev/null
+++ b/audio/ices/distinfo
@@ -0,0 +1 @@
+MD5 (ices-devel-20021112.tar.gz) = 29f97b879e4daba9a7eb8b1b15e4d96d
diff --git a/audio/ices/pkg-comment b/audio/ices/pkg-comment
new file mode 100644
index 000000000000..9e83236e91b0
--- /dev/null
+++ b/audio/ices/pkg-comment
@@ -0,0 +1 @@
+A streaming source client for icecast 2
diff --git a/audio/ices/pkg-descr b/audio/ices/pkg-descr
new file mode 100644
index 000000000000..36d149899762
--- /dev/null
+++ b/audio/ices/pkg-descr
@@ -0,0 +1,4 @@
+IceS2 is a streaming source client for icecast 2 servers. It provides flexible
+and powerful static and live streaming capabilities for Ogg Vorbis streams.
+
+WWW: http://www.icecast.org/
diff --git a/audio/ices/pkg-plist b/audio/ices/pkg-plist
new file mode 100644
index 000000000000..44498d7572a3
--- /dev/null
+++ b/audio/ices/pkg-plist
@@ -0,0 +1,2 @@
+bin/ices
+bin/run_ices