aboutsummaryrefslogtreecommitdiffstats
path: root/audio/jack
diff options
context:
space:
mode:
authorade <ade@FreeBSD.org>2005-11-15 14:52:12 +0800
committerade <ade@FreeBSD.org>2005-11-15 14:52:12 +0800
commit8d9d5197561118544281733430b48b0b60884450 (patch)
tree45e5dcd7c2206fce8b01186555aac96b6292c602 /audio/jack
parent081b17449bd91bcac5390cd0d8a63ed3914df51d (diff)
downloadfreebsd-ports-gnome-8d9d5197561118544281733430b48b0b60884450.tar.gz
freebsd-ports-gnome-8d9d5197561118544281733430b48b0b60884450.tar.zst
freebsd-ports-gnome-8d9d5197561118544281733430b48b0b60884450.zip
Mass-conversion to the USE_AUTOTOOLS New World Order. The code present
in bsd.autotools.mk essentially makes this a no-op given that all the old variables set a USE_AUTOTOOLS_COMPAT variable, which is parsed in exactly the same way as USE_AUTOTOOLS itself. Moreover, USE_AUTOTOOLS has already been extensively tested by the GNOME team -- all GNOME 2.12.x ports use it. Preliminary documentation can be found at: http://people.FreeBSD.org/~ade/autotools.txt which is in the process of being SGMLized before introduction into the Porters Handbook. Light blue touch-paper. Run.
Diffstat (limited to 'audio/jack')
-rw-r--r--audio/jack/Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/audio/jack/Makefile b/audio/jack/Makefile
index ef240bdef605..d3fff06cddf0 100644
--- a/audio/jack/Makefile
+++ b/audio/jack/Makefile
@@ -23,7 +23,7 @@ LATEST_LINK= jack
CONFIGURE_ENV= LIBS="${PTHREAD_LIBS}" LDFLAGS="-L${LOCALBASE}/lib" \
CPPFLAGS="-I${LOCALBASE}/include" \
CFLAGS="${CFLAGS} ${PTHREAD_CFLAGS}"
-USE_LIBTOOL_VER= 15
+USE_AUTOTOOLS= libtool:15
USE_GETOPT_LONG= yes
USE_REINPLACE= yes
INSTALLS_SHLIB= yes