aboutsummaryrefslogtreecommitdiffstats
path: root/audio/juk
diff options
context:
space:
mode:
authorMichael Nottebrock <lofi@FreeBSD.org>2006-04-13 16:51:31 +0800
committerMichael Nottebrock <lofi@FreeBSD.org>2006-04-13 16:51:31 +0800
commitaef6bbc866712f72cc513690c599ab28d0ba7d08 (patch)
tree061835bfcbb731d3528aa4ac3a46b7e657d948dc /audio/juk
parentfe22d50fbdd61870a8edd935850984c1e5ee78eb (diff)
downloadfreebsd-ports-gnome-aef6bbc866712f72cc513690c599ab28d0ba7d08.tar.gz
freebsd-ports-gnome-aef6bbc866712f72cc513690c599ab28d0ba7d08.tar.zst
freebsd-ports-gnome-aef6bbc866712f72cc513690c599ab28d0ba7d08.zip
Juk's configure check for tunepimp 0.4 is broken - and I would've never noticed
if it weren't for gcc 2.95, since gcc 3.4 simply irons over the member function parameter mismatches. Way to facilitate creating hard to spot runtime-bugs. With this fix, juk actually uses the updated tunepimp API.
Diffstat (limited to 'audio/juk')
-rw-r--r--audio/juk/Makefile6
1 files changed, 5 insertions, 1 deletions
diff --git a/audio/juk/Makefile b/audio/juk/Makefile
index 9256f1fcd4fc..31416d3d375b 100644
--- a/audio/juk/Makefile
+++ b/audio/juk/Makefile
@@ -7,7 +7,7 @@
PORTNAME= juk
PORTVERSION= ${KDE_VERSION}
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= audio kde
MASTER_SITES= ${MASTER_SITE_KDE}
MASTER_SITE_SUBDIR= stable/${PORTVERSION:S/.0//}/src
@@ -60,6 +60,10 @@ pre-everything::
@${ECHO_MSG}
.endif
+post-patch:
+ @${REINPLACE_CMD} -e 's|LIBS="-ltunepimp $$LIBS"|LIBS="-ltunepimp -liconv $$LIBS"|g' \
+ ${WRKSRC}/configure
+
do-build:
cd ${WRKSRC}/arts/runtime && ${SETENV} ${MAKE_ENV} ${GMAKE}
cd ${WRKSRC}/juk && ${SETENV} ${MAKE_ENV} ${GMAKE}