aboutsummaryrefslogtreecommitdiffstats
path: root/audio/kid3-kde4
diff options
context:
space:
mode:
authormakc <makc@FreeBSD.org>2012-07-27 19:03:38 +0800
committermakc <makc@FreeBSD.org>2012-07-27 19:03:38 +0800
commit7e9888a561c1f2a53cfeca5bf54f5278294df386 (patch)
tree167ee4bd8c4cd737246cf4e2c40f36e42042084e /audio/kid3-kde4
parent7c887ca2a204b4cd88ce46806edb8ea718e69d9e (diff)
downloadfreebsd-ports-gnome-7e9888a561c1f2a53cfeca5bf54f5278294df386.tar.gz
freebsd-ports-gnome-7e9888a561c1f2a53cfeca5bf54f5278294df386.tar.zst
freebsd-ports-gnome-7e9888a561c1f2a53cfeca5bf54f5278294df386.zip
- Convert my ports to new options framework
- use CONFLICTS_INSTALL - other minor changes
Diffstat (limited to 'audio/kid3-kde4')
-rw-r--r--audio/kid3-kde4/Makefile23
1 files changed, 13 insertions, 10 deletions
diff --git a/audio/kid3-kde4/Makefile b/audio/kid3-kde4/Makefile
index 3db24683282f..ee52b4840a22 100644
--- a/audio/kid3-kde4/Makefile
+++ b/audio/kid3-kde4/Makefile
@@ -27,36 +27,39 @@ CMAKE_ARGS= -DWITH_CHROMAPRINT=off
USE_GETTEXT= yes
MAKE_JOBS_SAFE= yes
-OPTIONS= FLAC "Support for FLAC files" on \
- ID3LIB "Support for mp3 files" on \
- MP4V2 "Support for mp4 files" on \
- VORBIS "Support for Ogg/Vorbis files" on \
- TAGLIB "Support for various audio formats" on
+OPTIONS_DEFINE= FLAC ID3LIB MP4V2 VORBIS TAGLIB
+OPTIONS_DEFAULT= ${OPTIONS_DEFINE}
+
+FLAC_DESC= Support for FLAC files
+ID3LIB_DESC= Support for mp3 files
+MP4V2_DESC= Support for mp4 files
+VORBIS_DESC= Support for Ogg/Vorbis files
+TAGLIB_DESC= Support for various audio formats
.include <bsd.port.options.mk>
-.if defined(WITHOUT_FLAC)
+.if ${PORT_OPTIONS:MFLAC}
CMAKE_ARGS+= -DWITH_FLAC=OFF
.else
CMAKE_ARGS+= -DWITH_FLAC=ON
LIB_DEPENDS+= FLAC.10:${PORTSDIR}/audio/flac
.endif
-.if defined(WITHOUT_ID3LIB)
+.if ${PORT_OPTIONS:MID3LIB}
CMAKE_ARGS+= -DWITH_ID3LIB=OFF
.else
CMAKE_ARGS+= -DWITH_ID3LIB=ON
LIB_DEPENDS+= id3-3.8.3:${PORTSDIR}/audio/id3lib
.endif
-.if defined(WITHOUT_MP4V2)
+.if ${PORT_OPTIONS:MMP4V2}
CMAKE_ARGS+= -DWITH_MP4V2=OFF
.else
CMAKE_ARGS+= -DWITH_MP4V2=ON
LIB_DEPENDS+= mp4v2.10:${PORTSDIR}/multimedia/mp4v2
.endif
-.if defined(WITHOUT_VORBIS)
+.if ${PORT_OPTIONS:MVORBIS}
CMAKE_ARGS+= -DWITH_VORBIS=OFF
.else
CMAKE_ARGS+= -DWITH_VORBIS=ON
@@ -64,7 +67,7 @@ LIB_DEPENDS+= vorbis.4:${PORTSDIR}/audio/libvorbis \
ogg:${PORTSDIR}/audio/libogg
.endif
-.if defined(WITHOUT_TAGLIB)
+.if ${PORT_OPTIONS:MTAGLIB}
CMAKE_ARGS+= -DWITH_TAGLIB=OFF
.else
CMAKE_ARGS+= -DWITH_TAGLIB=ON