aboutsummaryrefslogtreecommitdiffstats
path: root/audio/kid3-qt5
diff options
context:
space:
mode:
authorrene <rene@FreeBSD.org>2019-01-01 02:20:49 +0800
committerrene <rene@FreeBSD.org>2019-01-01 02:20:49 +0800
commit1ec548e261b4baa37baaef3c2073148d35bace5e (patch)
tree58bac92e7737377fa9e83316400201328ac084c3 /audio/kid3-qt5
parent21ce8a5b6cd01f183b1f9518795b015927849f42 (diff)
downloadfreebsd-ports-gnome-1ec548e261b4baa37baaef3c2073148d35bace5e.tar.gz
freebsd-ports-gnome-1ec548e261b4baa37baaef3c2073148d35bace5e.tar.zst
freebsd-ports-gnome-1ec548e261b4baa37baaef3c2073148d35bace5e.zip
Update audio/kid3-qt5 to be the new master port for audio/kid3-kf5 and itself.
Diffstat (limited to 'audio/kid3-qt5')
-rw-r--r--audio/kid3-qt5/Makefile40
1 files changed, 8 insertions, 32 deletions
diff --git a/audio/kid3-qt5/Makefile b/audio/kid3-qt5/Makefile
index 708bc3165e95..bf253cbeb1f6 100644
--- a/audio/kid3-qt5/Makefile
+++ b/audio/kid3-qt5/Makefile
@@ -28,45 +28,26 @@ CMAKE_ARGS= -DWITH_DOCBOOKDIR="${LOCALBASE}/share/xsl/docbook" \
-DWITH_APPS="${KID3_APPS:S/ /;/gW}"
PLIST_SUB+= SHLIB_VER=${PORTVERSION}
-SLAVE?= kde4
-.if ${SLAVE} == qt4 || ${SLAVE} == qt5
-# Qt4 and Qt5
+SLAVE?= qt5
+.if ${SLAVE} == qt5
+# Qt5
USES+= desktop-file-utils
-PLIST_SUB+= KDE="@comment " KDE4="@comment " KF5="@comment " QT="" QT_SUFX="-qt"
+PLIST_SUB+= KDE="@comment " KF5="@comment " QT="" QT_SUFX="-qt"
KID3_APPS+= QT
.else
-# KDE4 and KF5
+# KF5
PLIST_SUB+= KDE="" QT="@comment " QT_SUFX=""
KID3_APPS+= KDE
.endif
-.if ${SLAVE} == kde4 || ${SLAVE} == qt4
-# KDE4 and Qt4
-DEPRECATED= Qt4 and KDE4 EOL upstream. Use audio/kid3-qt5 or audio/kid3-kf5 instead
-EXPIRATION_DATE= 2018-12-31
-
-USES+= qt:4
-USE_QT+= corelib dbus gui network xml \
- qmake_build moc_build rcc_build uic_build \
- linguisttools_build
-CMAKE_ON+= WITH_QT4
-.else
# KF5 and Qt5
USES+= compiler:c++11-lang qt:5
USE_QT+= core dbus gui multimedia network xml widgets \
buildtools_build linguisttools_build qmake_build
CMAKE_ON+= WITH_QT5
OPTIONS_EXCLUDE+= PHONON
-.endif
-.if ${SLAVE} == kde4
-# KDE4 only
-USES+= kde:4
-USE_KDE+= kdelibs automoc4
-USE_QT+= svg
-PLIST_SUB+= KDE4="" KF5="@comment "
-OPTIONS_SLAVE+= PHONON
-.elif ${SLAVE} == kf5
+.if ${SLAVE} == kf5
# KF5 only
USES+= desktop-file-utils kde:5
USE_KDE+= auth codecs config configwidgets coreaddons \
@@ -74,7 +55,7 @@ USE_KDE+= auth codecs config configwidgets coreaddons \
PLIST_SUB+= KDE4="@comment " KF5=""
.endif
-.for s in kde4 kf5 qt4 qt5
+.for s in kf5 qt5
. if ${SLAVE} != ${s}
CONFLICTS_INSTALL+= kid3-${s}
. endif
@@ -109,12 +90,7 @@ TAGLIB_DESC= Various audio formats support via Taglib
TAGLIB_LIB_DEPENDS= libtag.so:audio/taglib
TAGLIB_CMAKE_BOOL= WITH_TAGLIB
-TEST_USE= LOCALE=en_US.UTF-8
-.if ${SLAVE} == qt4 || ${SLAVE} == kde4
-TEST_USE+= QT=qtestlib_build
-.else
-TEST_USE+= QT=testlib_build
-.endif
+TEST_USE= LOCALE=en_US.UTF-8 QT=testlib_build
TEST_WRKSRC= ${BUILD_WRKSRC}/src/test
TEST_VARS= KID3_APPS+=TEST