aboutsummaryrefslogtreecommitdiffstats
path: root/audio/last.fm
diff options
context:
space:
mode:
authorarved <arved@FreeBSD.org>2012-12-10 19:06:14 +0800
committerarved <arved@FreeBSD.org>2012-12-10 19:06:14 +0800
commit365dc41664dc2b04e88f4525eea11ff1c3cd36d3 (patch)
tree802438cb64e9afcf8ab907cb2adb3512d2fbf786 /audio/last.fm
parente775b1b79790e51640283766ee2f8f5f705b09b5 (diff)
downloadfreebsd-ports-gnome-365dc41664dc2b04e88f4525eea11ff1c3cd36d3.tar.gz
freebsd-ports-gnome-365dc41664dc2b04e88f4525eea11ff1c3cd36d3.tar.zst
freebsd-ports-gnome-365dc41664dc2b04e88f4525eea11ff1c3cd36d3.zip
Update to 1.5.4.26862
Tested by: Rainer Hurling <rhurlin@gwdg.de>, ajtiM <lumiwa@gmail.com>
Diffstat (limited to 'audio/last.fm')
-rw-r--r--audio/last.fm/Makefile10
-rw-r--r--audio/last.fm/distinfo4
-rw-r--r--audio/last.fm/files/patch-LastFM.pro11
-rw-r--r--audio/last.fm/files/patch-src-Helper-mediadevicewather.cpp10
-rw-r--r--audio/last.fm/files/patch-src-mediadevice-itunes-itunesdevice.cpp13
-rw-r--r--audio/last.fm/files/patch-src-output-alsa-playback-xconvert.c10
-rw-r--r--audio/last.fm/files/patch-src-updatewizard.h11
-rw-r--r--audio/last.fm/files/patch-src-wizardselectupdatespage.h11
-rw-r--r--audio/last.fm/files/patch-src_LastFMHelper-controlinterface.h10
-rw-r--r--audio/last.fm/pkg-plist6
10 files changed, 54 insertions, 42 deletions
diff --git a/audio/last.fm/Makefile b/audio/last.fm/Makefile
index ca6e177369aa..c303d532d160 100644
--- a/audio/last.fm/Makefile
+++ b/audio/last.fm/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= last.fm
-PORTVERSION= 1.4.2.58240
-PORTREVISION= 6
+PORTVERSION= 1.5.4.26862
CATEGORIES= audio net
MASTER_SITES= http://cdn.last.fm/client/src/
DISTNAME= ${PORTNAME}-${PORTVERSION}.src
@@ -32,7 +31,7 @@ USE_QT4= gui imageformats_run moc_build network qmake_build rcc_build \
sql uic_build xml
HAS_CONFIGURE= yes
USE_LDCONFIG= yes
-USE_DOS2UNIX= yes
+USE_DOS2UNIX= *.h
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
@@ -43,6 +42,7 @@ USE_GCC=4.2+
.endif
post-patch:
+ ${CP} ${WRKSRC}/dist/tarball_files/configure ${WRKSRC}/configure
${REINPLACE_CMD} -e 's|/bin/bash|/${LOCALBASE}/bin/bash|g' \
-E -e 's|(.*"CONFIG-=debug")|\1 ${QMAKEFLAGS}|g' \
-e 's|function header|header()|g' \
@@ -55,7 +55,9 @@ post-patch:
${WRKSRC}/src/mediadevices/ipod/ipod.pro
${REINPLACE_CMD} -e 's|^RUNDIR.*|RUNDIR=${DATADIR}|' ${WRKSRC}/bin/last.fm.sh
${RM} ${WRKSRC}/bin/libmad.1.dylib ${WRKSRC}/bin/libmad.dylib \
- ${WRKSRC}/bin/last.fm.sh.bak
+ ${WRKSRC}/bin/last.fm.sh.bak \
+ ${WRKSRC}/bin/*.dll ${WRKSRC}/bin/LastFM.exe.config
+ ${RM} -rf ${WRKSRC}/bin/Microsoft* ${WRKSRC}/bin/sqldrivers
post-build:
cd ${WRKSRC}/src/output/RtAudio && \
diff --git a/audio/last.fm/distinfo b/audio/last.fm/distinfo
index 2c3e4bcec097..df68b41d7c74 100644
--- a/audio/last.fm/distinfo
+++ b/audio/last.fm/distinfo
@@ -1,2 +1,2 @@
-SHA256 (last.fm-1.4.2.58240.src.tar.bz2) = 6e66f3408021b3ea512224451599e81bd0fb9ede464575d9acae2cc16d5b6429
-SIZE (last.fm-1.4.2.58240.src.tar.bz2) = 7302117
+SHA256 (last.fm-1.5.4.26862.src.tar.bz2) = 5c110ab6e7a4c4ec950fb65912bc5ddfd106ce969c4b7376a7603cf7b3720e2a
+SIZE (last.fm-1.5.4.26862.src.tar.bz2) = 11415025
diff --git a/audio/last.fm/files/patch-LastFM.pro b/audio/last.fm/files/patch-LastFM.pro
new file mode 100644
index 000000000000..519abaf586e0
--- /dev/null
+++ b/audio/last.fm/files/patch-LastFM.pro
@@ -0,0 +1,11 @@
+--- LastFM.pro.orig 2012-12-02 14:23:24.000000000 +0100
++++ LastFM.pro 2012-12-02 14:23:37.000000000 +0100
+@@ -37,7 +37,7 @@
+ SUBDIRS -= src/mediadevices/ipod
+ }
+
+-linux* {
++unix:!mac* {
+ SUBDIRS -= src/Twiddly \
+ src/Bootstrapper/ITunesDevice
+
diff --git a/audio/last.fm/files/patch-src-Helper-mediadevicewather.cpp b/audio/last.fm/files/patch-src-Helper-mediadevicewather.cpp
deleted file mode 100644
index d5d6da6f7f4b..000000000000
--- a/audio/last.fm/files/patch-src-Helper-mediadevicewather.cpp
+++ /dev/null
@@ -1,10 +0,0 @@
---- src/Helper/mediadevicewatcher.cpp.orig 2009-11-04 22:48:51.000000000 +0100
-+++ src/Helper/mediadevicewatcher.cpp 2009-11-04 22:50:13.000000000 +0100
-@@ -73,6 +73,7 @@
- QString appExe = "Last.fm_debug";
- #endif
- #endif
-+ QString appExe = "last.fm";
-
- QString app = QCoreApplication::applicationDirPath() + "/" + appExe;
- QStringList params( "-tray" );
diff --git a/audio/last.fm/files/patch-src-mediadevice-itunes-itunesdevice.cpp b/audio/last.fm/files/patch-src-mediadevice-itunes-itunesdevice.cpp
deleted file mode 100644
index 59dce4a1dcb0..000000000000
--- a/audio/last.fm/files/patch-src-mediadevice-itunes-itunesdevice.cpp
+++ /dev/null
@@ -1,13 +0,0 @@
---- src/mediadevices/itunes/itunesdevice.cpp.orig 2009-11-04 22:07:06.000000000 +0100
-+++ src/mediadevices/itunes/itunesdevice.cpp 2009-11-04 22:07:12.000000000 +0100
-@@ -589,8 +589,9 @@
- //HACK
- #ifdef WIN32
- QDir qcd = m_path;
-- #endif
- QSettings().setValue( "devicePaths/" + uid + "/path", qcd.absolutePath() );
-+ #endif
-+
- //HACK
- }
- else
diff --git a/audio/last.fm/files/patch-src-output-alsa-playback-xconvert.c b/audio/last.fm/files/patch-src-output-alsa-playback-xconvert.c
new file mode 100644
index 000000000000..385a3b6a823c
--- /dev/null
+++ b/audio/last.fm/files/patch-src-output-alsa-playback-xconvert.c
@@ -0,0 +1,10 @@
+--- src/output/alsa-playback/xconvert.c.orig 2012-12-02 14:30:50.000000000 +0100
++++ src/output/alsa-playback/xconvert.c 2012-12-02 14:33:58.000000000 +0100
+@@ -57,6 +57,7 @@
+
+ #endif
+
++#define uint size_t
+
+ struct buffer {
+ void *buffer;
diff --git a/audio/last.fm/files/patch-src-updatewizard.h b/audio/last.fm/files/patch-src-updatewizard.h
new file mode 100644
index 000000000000..91f6896c163c
--- /dev/null
+++ b/audio/last.fm/files/patch-src-updatewizard.h
@@ -0,0 +1,11 @@
+--- src/updatewizard.h.orig 2012-12-02 14:01:31.000000000 +0100
++++ src/updatewizard.h 2012-12-02 14:01:42.000000000 +0100
+@@ -50,7 +50,7 @@
+ CAutoUpdater& updater,
+ QWidget* parent = NULL);
+
+- UpdateWizard::UpdateWizard( CComponentInfo* );
++ UpdateWizard( CComponentInfo* );
+
+ bool shouldShow() const{ return m_showWizard; }
+
diff --git a/audio/last.fm/files/patch-src-wizardselectupdatespage.h b/audio/last.fm/files/patch-src-wizardselectupdatespage.h
new file mode 100644
index 000000000000..630a18a8afb3
--- /dev/null
+++ b/audio/last.fm/files/patch-src-wizardselectupdatespage.h
@@ -0,0 +1,11 @@
+--- src/wizardselectupdatespage.h.orig 2012-12-02 13:59:46.000000000 +0100
++++ src/wizardselectupdatespage.h 2012-12-02 14:00:17.000000000 +0100
+@@ -58,7 +58,7 @@
+ GetChecked(
+ std::vector<CComponentInfo*>& vecChecked);
+
+- void WizardSelectUpdatesPage::GetMajorUpdateComponent( std::vector<CComponentInfo*>& vecToUpdate );
++ void GetMajorUpdateComponent( std::vector<CComponentInfo*>& vecToUpdate );
+
+ public slots:
+
diff --git a/audio/last.fm/files/patch-src_LastFMHelper-controlinterface.h b/audio/last.fm/files/patch-src_LastFMHelper-controlinterface.h
deleted file mode 100644
index a9d30beadad3..000000000000
--- a/audio/last.fm/files/patch-src_LastFMHelper-controlinterface.h
+++ /dev/null
@@ -1,10 +0,0 @@
---- src/Helper/controlinterface.h.orig 2007-09-24 23:41:54.000000000 +0200
-+++ src/Helper/controlinterface.h 2007-09-24 23:42:01.000000000 +0200
-@@ -24,6 +24,7 @@
-
- #include <QObject>
- #include <QMutex>
-+#include <QCoreApplication>
-
- class ControlInterface : public QObject
- {
diff --git a/audio/last.fm/pkg-plist b/audio/last.fm/pkg-plist
index 15d10a7c818a..d37a8df70d34 100644
--- a/audio/last.fm/pkg-plist
+++ b/audio/last.fm/pkg-plist
@@ -1,5 +1,4 @@
bin/last.fm
-%%DATADIR%%/LastFmHelper
%%DATADIR%%/data/about.png
%%DATADIR%%/data/about_generic.png
%%DATADIR%%/data/about_mac.png
@@ -34,6 +33,7 @@ bin/last.fm
%%DATADIR%%/data/icons/my_friends.png
%%DATADIR%%/data/icons/my_neighbours.png
%%DATADIR%%/data/icons/my_tags.png
+%%DATADIR%%/data/icons/mymix_radio.png
%%DATADIR%%/data/icons/neighbour_radio.png
%%DATADIR%%/data/icons/options_account.png
%%DATADIR%%/data/icons/options_connection.png
@@ -105,10 +105,10 @@ bin/last.fm
%%DATADIR%%/libfftw3f-3.lib
%%DATADIR%%/services/libsrv_Ipod_device.so
%%DATADIR%%/services/libsrv_httpinput.so
-%%DATADIR%%/services/libsrv_itunesdevice.so
%%DATADIR%%/services/libsrv_madtranscode.so
%%DATADIR%%/services/libsrv_rtaudioplayback.so
-%%DATADIR%%/updater-autorestart.sh
+%%DATADIR%%/services/libsrv_output_alsa.so
+%%DATADIR%%/services/libsrv_output_portaudio.so
%%DATADIR%%/zlibwapi.lib
share/applications/last.fm.desktop
share/services/lastfm.protocol