aboutsummaryrefslogtreecommitdiffstats
path: root/audio/libmad/Makefile
diff options
context:
space:
mode:
authorpav <pav@FreeBSD.org>2004-10-12 06:20:46 +0800
committerpav <pav@FreeBSD.org>2004-10-12 06:20:46 +0800
commit6675927a5a82c6b0aa9d061bec7456bc5ffa1677 (patch)
treefd4f5bdab13d968920ead77eeacfbcd009b64e4f /audio/libmad/Makefile
parent1e0a599bb4d3fb92ff928db85b23f204c18451d5 (diff)
downloadfreebsd-ports-gnome-6675927a5a82c6b0aa9d061bec7456bc5ffa1677.tar.gz
freebsd-ports-gnome-6675927a5a82c6b0aa9d061bec7456bc5ffa1677.tar.zst
freebsd-ports-gnome-6675927a5a82c6b0aa9d061bec7456bc5ffa1677.zip
- Install pkgconfig file
Approved by: maintainer Obtained from: Debian
Diffstat (limited to 'audio/libmad/Makefile')
-rw-r--r--audio/libmad/Makefile9
1 files changed, 9 insertions, 0 deletions
diff --git a/audio/libmad/Makefile b/audio/libmad/Makefile
index f2b8c0d265cf..4c8079aad95b 100644
--- a/audio/libmad/Makefile
+++ b/audio/libmad/Makefile
@@ -7,6 +7,7 @@
PORTNAME= libmad
PORTVERSION= 0.15.1b
+PORTREVISION= 1
CATEGORIES= audio
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE} \
ftp://ftp.mars.org/pub/mpeg/
@@ -16,9 +17,17 @@ MAINTAINER= asa@gascom.ru
COMMENT= Libmad library (part of MAD project)
USE_INC_LIBTOOL_VER= 13
+USE_GNOME= pkgconfig
INSTALLS_SHLIB= yes
CONFIGURE_ARGS= --disable-debugging \
--enable-sso \
--enable-accuracy
+post-patch:
+ @${SED} -e 's|%PREFIX%|${PREFIX}|g ; s|%VERSION%|${PORTVERSION}|g' \
+ ${FILESDIR}/mad.pc.in > ${WRKDIR}/mad.pc
+
+post-install:
+ ${INSTALL_DATA} ${WRKDIR}/mad.pc ${PREFIX}/libdata/pkgconfig
+
.include <bsd.port.mk>