aboutsummaryrefslogtreecommitdiffstats
path: root/audio/libmad/Makefile
diff options
context:
space:
mode:
authortijl <tijl@FreeBSD.org>2014-12-09 00:48:38 +0800
committertijl <tijl@FreeBSD.org>2014-12-09 00:48:38 +0800
commite2300845f96fc1f90e03af0a746423bff0b0e770 (patch)
treefd2d9471767ad6e92fff12ef08f1cb015017f9f8 /audio/libmad/Makefile
parentb0b474e0ac449202a591c50a796cb0435cbf54fb (diff)
downloadfreebsd-ports-gnome-e2300845f96fc1f90e03af0a746423bff0b0e770.tar.gz
freebsd-ports-gnome-e2300845f96fc1f90e03af0a746423bff0b0e770.tar.zst
freebsd-ports-gnome-e2300845f96fc1f90e03af0a746423bff0b0e770.zip
Replace USES=libtool:oldver with USES=libtool or USES=libtool:keepla in
the 32 ports that still use it. Bump PORTREVISION on their dependent ports except the ones that depend on these: audio/libogg audio/libvorbis devel/pcre ftp/curl graphics/jpeg graphics/libart_lgpl graphics/tiff textproc/expat2 textproc/libxslt In these cases the same trick as in the recent gettext update is used. The ports install a symlink with the old library version. When enough of their dependent ports have had regular updates the remaining ones can get a PORTREVISION bump and the links can be removed. Also remove the devel/pcre dependency from USE_GNOME=glib20. It causes over 2200 packages to depend on devel/pcre while less than 200 actually link with it. The glib20 package still depends on devel/pcre so this should not make a difference for ports with USE_GNOME=glib20. Also, libdata/pkgconfig/glib-2.0.pc lists pcre as a private library so USE_GNOME=glib20 should not propagate it. PR: 195724 Exp-run by: antoine Approved by: portmgr (antoine)
Diffstat (limited to 'audio/libmad/Makefile')
-rw-r--r--audio/libmad/Makefile8
1 files changed, 3 insertions, 5 deletions
diff --git a/audio/libmad/Makefile b/audio/libmad/Makefile
index 91c75f7b3bca..74a2f1899853 100644
--- a/audio/libmad/Makefile
+++ b/audio/libmad/Makefile
@@ -3,7 +3,7 @@
PORTNAME= libmad
PORTVERSION= 0.15.1b
-PORTREVISION= 5
+PORTREVISION= 6
CATEGORIES= audio
MASTER_SITES= SF/mad/${PORTNAME}/${PORTVERSION}
@@ -15,8 +15,9 @@ SPEED_DESC= Optimize for speed over accuracy
CONFIGURE_ARGS= --disable-debugging --enable-sso
GNU_CONFIGURE= yes
+INSTALL_TARGET= install-strip
+USES= libtool
USE_LDCONFIG= yes
-USES= libtool:oldver
SUB_LIST= VERSION=${PORTVERSION}
SUB_FILES= mad.pc
@@ -27,9 +28,6 @@ SPEED_CONFIGURE_OFF= --enable-accuracy
post-patch:
@${REINPLACE_CMD} -e 's| -fforce-mem||' ${WRKSRC}/configure
-post-build:
- @${STRIP_CMD} ${WRKSRC}/.libs/libmad.so.2
-
post-install:
${INSTALL_DATA} ${WRKDIR}/mad.pc ${STAGEDIR}${PREFIX}/libdata/pkgconfig/