aboutsummaryrefslogtreecommitdiffstats
path: root/audio/libmusicbrainz3
diff options
context:
space:
mode:
authormezz <mezz@FreeBSD.org>2010-07-31 06:14:49 +0800
committermezz <mezz@FreeBSD.org>2010-07-31 06:14:49 +0800
commit8a75df1e833f84364de759d817393f7f8b64d203 (patch)
treea2e76c941c3182693aac1bfa5c06a593fb873be1 /audio/libmusicbrainz3
parent15c8487f4af55fa07fe1d84fa179a42a4ddaed82 (diff)
downloadfreebsd-ports-gnome-8a75df1e833f84364de759d817393f7f8b64d203.tar.gz
freebsd-ports-gnome-8a75df1e833f84364de759d817393f7f8b64d203.tar.zst
freebsd-ports-gnome-8a75df1e833f84364de759d817393f7f8b64d203.zip
- Makes neon29 our default neon library. The neon 0.27.x to 0.29.x are API and
ABI backwards compatible. It is unnecessary to have more than one same libraries (ie: neon28 and neon29) as it creates issue in our ports tree such as CONFLICTS and made our Makefile complicate. - Remove www/neonpp and www/neon28. - Add USE_GNOME=ltverhack; it corrects the shared library version by change from libneon.so.29 to libneon.so.27. It won't get bump again with no reason unless ABI changes. - Bump the PORTREVISION on all ports and chase the shared library change. - Add info in the UPDATING for how to rebuild on all ports that depend on neon. PR: ports/148295 Approved by: lev (maintainer timeout, no respone for months), portmgr Tested by: pointyhat-exp by pav
Diffstat (limited to 'audio/libmusicbrainz3')
-rw-r--r--audio/libmusicbrainz3/Makefile17
1 files changed, 4 insertions, 13 deletions
diff --git a/audio/libmusicbrainz3/Makefile b/audio/libmusicbrainz3/Makefile
index 4356a88455a2..dc20a40cb744 100644
--- a/audio/libmusicbrainz3/Makefile
+++ b/audio/libmusicbrainz3/Makefile
@@ -7,7 +7,7 @@
PORTNAME= libmusicbrainz3
PORTVERSION= 3.0.2
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= audio
MASTER_SITES= ftp://ftp.musicbrainz.org/pub/musicbrainz/ \
http://uk.musicbrainz.org/pub/musicbrainz/ \
@@ -17,7 +17,8 @@ DISTNAME= ${PORTNAME:S/3//}-${PORTVERSION}
MAINTAINER= bsdkaffee@gmail.com
COMMENT= MusicBrainz client library for audio metadata lookup
-LIB_DEPENDS= discid:${PORTSDIR}/audio/libdiscid
+LIB_DEPENDS= discid:${PORTSDIR}/audio/libdiscid \
+ neon.27:${PORTSDIR}/www/neon29
USE_CMAKE= yes
USE_GNOME= pkgconfig
@@ -25,18 +26,8 @@ USE_LDCONFIG= yes
MAKE_JOBS_SAFE= yes
-.include <bsd.port.pre.mk>
-
-.if exists(${LOCALBASE}/bin/neon-config)
-NEON_VER!= ${LOCALBASE}/bin/neon-config --version | \
- ${SED} -n -E 's/^neon [0-9]+\.([0-9]+)\..*$$/\1/p'
-.else
-NEON_VER= 29
-.endif
-LIB_DEPENDS+= neon.${NEON_VER}:${PORTSDIR}/www/neon${NEON_VER}
-
pre-configure:
${REINPLACE_CMD} -e '/pkgconfig/s|$${LIB_INSTALL_DIR}|libdata|' \
-e '/CppUnit/d' ${WRKSRC}/CMakeLists.txt
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>