aboutsummaryrefslogtreecommitdiffstats
path: root/audio/libogg/Makefile
diff options
context:
space:
mode:
authortrevor <trevor@FreeBSD.org>2000-11-03 05:11:47 +0800
committertrevor <trevor@FreeBSD.org>2000-11-03 05:11:47 +0800
commit843ce62cc4d78c91a399ec2586b573b98b5db8db (patch)
tree9b94595a19ae3fd34afcfb426897e0570e15e4c3 /audio/libogg/Makefile
parentcb9014e734b294012c70b983e08e4186aad4d974 (diff)
downloadfreebsd-ports-gnome-843ce62cc4d78c91a399ec2586b573b98b5db8db.tar.gz
freebsd-ports-gnome-843ce62cc4d78c91a399ec2586b573b98b5db8db.tar.zst
freebsd-ports-gnome-843ce62cc4d78c91a399ec2586b573b98b5db8db.zip
Add new port of libogg, a library for handling Ogg streams.
PR: 22096 Submitted by: Theo van Klaveren <t.vanklaveren@student.utwente.nl>
Diffstat (limited to 'audio/libogg/Makefile')
-rw-r--r--audio/libogg/Makefile30
1 files changed, 30 insertions, 0 deletions
diff --git a/audio/libogg/Makefile b/audio/libogg/Makefile
new file mode 100644
index 000000000000..3a5280eb073b
--- /dev/null
+++ b/audio/libogg/Makefile
@@ -0,0 +1,30 @@
+# New ports collection makefile for: libogg
+# Date created: 18 October 2000
+# Whom: t.vanklaveren@student.utwente.nl
+#
+# $FreeBSD$
+#
+
+PORTNAME= libogg
+PORTVERSION= 20001018
+CATEGORIES= audio
+MASTER_SITES= http://home.student.utwente.nl/t.vanklaveren/distfiles/
+DISTNAME= ogg-${PORTVERSION}
+
+MAINTAINER= t.vanklaveren@student.utwente.nl
+
+GNU_CONFIGURE= yes
+USE_GMAKE= yes
+USE_LIBTOOL= yes
+WRKSRC= ${WRKDIR}/ogg
+
+ACLOCAL?= ${LOCALBASE}/bin/aclocal
+AUTOHEADER?= ${LOCALBASE}/bin/autoheader
+
+post-patch:
+ cd ${WRKSRC} && ${ACLOCAL}
+ cd ${WRKSRC} && ${AUTOHEADER}
+ cd ${WRKSRC} && ${AUTOMAKE} --add-missing
+ cd ${WRKSRC} && ${AUTOCONF}
+
+.include <bsd.port.mk>