aboutsummaryrefslogtreecommitdiffstats
path: root/audio/libopenmpt
diff options
context:
space:
mode:
authorEmanuel Haupt <ehaupt@FreeBSD.org>2018-09-12 03:09:25 +0800
committerEmanuel Haupt <ehaupt@FreeBSD.org>2018-09-12 03:09:25 +0800
commitb4336afddff2b551e78728561d09d134a388f915 (patch)
treec42df89789cd5bf607ed10e438045629a3581099 /audio/libopenmpt
parent03fb07ec7e9e37b37ebc3b6eae6778d975c3eff2 (diff)
downloadfreebsd-ports-gnome-b4336afddff2b551e78728561d09d134a388f915.tar.gz
freebsd-ports-gnome-b4336afddff2b551e78728561d09d134a388f915.tar.zst
freebsd-ports-gnome-b4336afddff2b551e78728561d09d134a388f915.zip
Add libopenmpt 0.3.11, module music library based on OpenMPT.
Diffstat (limited to 'audio/libopenmpt')
-rw-r--r--audio/libopenmpt/Makefile29
-rw-r--r--audio/libopenmpt/distinfo3
-rw-r--r--audio/libopenmpt/pkg-descr4
-rw-r--r--audio/libopenmpt/pkg-plist23
4 files changed, 59 insertions, 0 deletions
diff --git a/audio/libopenmpt/Makefile b/audio/libopenmpt/Makefile
new file mode 100644
index 000000000000..3d1a549b75e1
--- /dev/null
+++ b/audio/libopenmpt/Makefile
@@ -0,0 +1,29 @@
+# Created by: Emanuel Haupt <ehaupt@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= libopenmpt
+PORTVERSION= 0.3.11
+CATEGORIES= audio
+
+MAINTAINER= ehaupt@FreeBSD.org
+COMMENT= Module music library based on OpenMPT
+
+LICENSE= BSD3CLAUSE
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+USES= gmake pkgconfig
+USE_LDCONFIG= yes
+USE_GITHUB= yes
+
+GH_ACCOUNT= OpenMPT
+GH_PROJECT= openmpt
+GH_TAGNAME= ${PORTNAME}-${PORTVERSION}
+
+OPTIONS_DEFINE= DOCS EXAMPLES
+
+post-patch:
+ @${REINPLACE_CMD} -e \
+ 's|$$(PREFIX)/share/doc/libopenmpt/examples|${EXAMPLESDIR}|g' \
+ ${WRKSRC}/Makefile
+
+.include <bsd.port.mk>
diff --git a/audio/libopenmpt/distinfo b/audio/libopenmpt/distinfo
new file mode 100644
index 000000000000..324af20c2051
--- /dev/null
+++ b/audio/libopenmpt/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1536677968
+SHA256 (OpenMPT-openmpt-0.3.11-libopenmpt-0.3.11_GH0.tar.gz) = 416355f542e2cbfde987e5af3d26c7ee15648c6c457ae19e55fe38dd2f40b942
+SIZE (OpenMPT-openmpt-0.3.11-libopenmpt-0.3.11_GH0.tar.gz) = 12049714
diff --git a/audio/libopenmpt/pkg-descr b/audio/libopenmpt/pkg-descr
new file mode 100644
index 000000000000..b03d4440c572
--- /dev/null
+++ b/audio/libopenmpt/pkg-descr
@@ -0,0 +1,4 @@
+A cross-platform C++ and C library to decode tracked music files (modules) into
+a raw PCM audio stream.
+
+WWW: http://lib.openmpt.org/
diff --git a/audio/libopenmpt/pkg-plist b/audio/libopenmpt/pkg-plist
new file mode 100644
index 000000000000..bcb9dd917a97
--- /dev/null
+++ b/audio/libopenmpt/pkg-plist
@@ -0,0 +1,23 @@
+bin/openmpt123
+include/libopenmpt/libopenmpt.h
+include/libopenmpt/libopenmpt.hpp
+include/libopenmpt/libopenmpt_config.h
+include/libopenmpt/libopenmpt_ext.h
+include/libopenmpt/libopenmpt_ext.hpp
+include/libopenmpt/libopenmpt_stream_callbacks_buffer.h
+include/libopenmpt/libopenmpt_stream_callbacks_fd.h
+include/libopenmpt/libopenmpt_stream_callbacks_file.h
+include/libopenmpt/libopenmpt_version.h
+lib/libopenmpt.a
+lib/libopenmpt.so
+lib/libopenmpt.so.1
+libdata/pkgconfig/libopenmpt.pc
+%%PORTDOCS%%%%DOCSDIR%%/LICENSE
+%%PORTDOCS%%%%DOCSDIR%%/README.md
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/libopenmpt_example_c.c
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/libopenmpt_example_c_mem.c
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/libopenmpt_example_c_pipe.c
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/libopenmpt_example_c_probe.c
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/libopenmpt_example_c_stdout.c
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/libopenmpt_example_c_unsafe.c
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/libopenmpt_example_cxx.cpp