aboutsummaryrefslogtreecommitdiffstats
path: root/audio/lmms
diff options
context:
space:
mode:
authorkwm <kwm@FreeBSD.org>2013-12-25 05:22:21 +0800
committerkwm <kwm@FreeBSD.org>2013-12-25 05:22:21 +0800
commit3602daba968a0e16ff8817cb961f23cd54730acc (patch)
tree93506aaee5230ee46b75930c4b3a6b8e0f243d74 /audio/lmms
parentb6e03796b2af561162757d9125b17f9d15197d64 (diff)
downloadfreebsd-ports-gnome-3602daba968a0e16ff8817cb961f23cd54730acc.tar.gz
freebsd-ports-gnome-3602daba968a0e16ff8817cb961f23cd54730acc.tar.zst
freebsd-ports-gnome-3602daba968a0e16ff8817cb961f23cd54730acc.zip
Update freetype to 2.5.2.
Remove patch to add -I/usr/local/include in freetype-config --cflags. If ports need extra headers they should look for them, and not get them via a side-effect. Freetype had a header resuffle in 2.5.1, patch ports to use the new header style. Thanks go to bdrewery for the two exp-runs and rakuco for helping me with some troublesome cmake ports. PR: ports/184587
Diffstat (limited to 'audio/lmms')
-rw-r--r--audio/lmms/files/patch-plugins_zynaddsubfx_fltk_CMakeLists.txt11
1 files changed, 11 insertions, 0 deletions
diff --git a/audio/lmms/files/patch-plugins_zynaddsubfx_fltk_CMakeLists.txt b/audio/lmms/files/patch-plugins_zynaddsubfx_fltk_CMakeLists.txt
new file mode 100644
index 000000000000..b6f61c73d1a1
--- /dev/null
+++ b/audio/lmms/files/patch-plugins_zynaddsubfx_fltk_CMakeLists.txt
@@ -0,0 +1,11 @@
+--- plugins/zynaddsubfx/fltk/CMakeLists.txt.orig 2013-12-24 21:48:53.000000000 +0200
++++ plugins/zynaddsubfx/fltk/CMakeLists.txt 2013-12-24 21:49:16.000000000 +0200
+@@ -165,7 +165,7 @@
+ mark_as_advanced(HAVE_SYS_STDTYPES_H HAVE_XDBE_H)
+
+ # where to find freetype headers
+-find_path(FREETYPE_PATH freetype/config/ftheader.h PATH_SUFFIXES freetype2)
++find_path(FREETYPE_PATH config/ftheader.h PATH_SUFFIXES freetype2)
+ if(FREETYPE_PATH)
+ include_directories(${FREETYPE_PATH})
+ endif(FREETYPE_PATH)