aboutsummaryrefslogtreecommitdiffstats
path: root/audio/moc
diff options
context:
space:
mode:
authoramdmi3 <amdmi3@FreeBSD.org>2015-01-18 22:35:00 +0800
committeramdmi3 <amdmi3@FreeBSD.org>2015-01-18 22:35:00 +0800
commitd8e53bcfdba8cb2ed11aadc653e1bcdb2567fa96 (patch)
treeda6b169d93c9ede163f82b252184380d8ed5779b /audio/moc
parente5600ec74c71db7a2bf9d3e7c8cd76a024d0d609 (diff)
downloadfreebsd-ports-gnome-d8e53bcfdba8cb2ed11aadc653e1bcdb2567fa96.tar.gz
freebsd-ports-gnome-d8e53bcfdba8cb2ed11aadc653e1bcdb2567fa96.tar.zst
freebsd-ports-gnome-d8e53bcfdba8cb2ed11aadc653e1bcdb2567fa96.zip
- Update to 2.5.0
- Update MASTER_SITES - Add LICENSE - Sort options - Use %%DOCSDIR%%, %%DATADIR%% in plist PR: 195751 Submitted by: h.skuhra@gmail.com Approved by: maintainer timeout
Diffstat (limited to 'audio/moc')
-rw-r--r--audio/moc/Makefile91
-rw-r--r--audio/moc/distinfo4
-rw-r--r--audio/moc/pkg-plist28
3 files changed, 71 insertions, 52 deletions
diff --git a/audio/moc/Makefile b/audio/moc/Makefile
index d0a108bdc79f..c5516c39a3c6 100644
--- a/audio/moc/Makefile
+++ b/audio/moc/Makefile
@@ -2,75 +2,94 @@
# $FreeBSD$
PORTNAME= moc
-PORTVERSION= 2.4.4
-PORTREVISION= 19
+PORTVERSION= 2.5.0
CATEGORIES= audio
-MASTER_SITES= ftp://ftp.daper.net/pub/soft/moc/stable/
+MASTER_SITES= http://ftp.daper.net/pub/soft/moc/stable/
MAINTAINER= rzinkov@gmail.com
COMMENT= Console audio player designed to be powerful and easy to use
+LICENSE= GPLv2 # or later
+LICENSE_FILE= ${WRKSRC}/COPYING
+
+LIB_DEPENDS= libltdl.so:${PORTSDIR}/devel/libltdl
+
USES= gmake libtool pkgconfig tar:bzip2
USE_LDCONFIG= yes
GNU_CONFIGURE= yes
+USE_BDB= yes
+INSTALL_TARGET= install-strip
-CPPFLAGS+= -I${LOCALBASE}/include
-LDFLAGS+= -L${LOCALBASE}/lib
+CPPFLAGS+= -I${LOCALBASE}/include -I${BDB_INCLUDE_DIR}
+LDFLAGS+= -L${LOCALBASE}/lib -L${BDB_LIB_DIR}
-OPTIONS_DEFINE= JACK MP3 FFMPEG MUSEPACK VORBIS FLAC SNDFILE SPEEX SAMPLERATE CURL RCC
+OPTIONS_DEFINE= AAC CURL DEBUG FFMPEG FLAC JACK MODPLUG MP3 MUSEPACK RCC \
+ SAMPLERATE SIDPLAY2 SNDFILE SPEEX VORBIS WAVPACK
OPTIONS_DEFAULT= MP3 VORBIS FLAC CURL
CURL_DESC= curl support (Internet streams)
RCC_DESC= RCC support
+SIDPLAY2_DESC= libsidplay2 support
+
+AAC_LIB_DEPENDS= libfaad.so:${PORTSDIR}/audio/faad
+AAC_PLIST_FILES= lib/moc/decoder_plugins/libaac_decoder.so
+AAC_CONFIGURE_OFF= --without-aac
+
+CURL_LIB_DEPENDS= libcurl.so:${PORTSDIR}/ftp/curl
+CURL_CONFIGURE_OFF= --without-curl
+
+DEBUG_CONFIGURE_OFF= --enable-debug=no
+
+FFMPEG_LIB_DEPENDS= libavcodec.so:${PORTSDIR}/multimedia/ffmpeg
+FFMPEG_PLIST_FILES= lib/moc/decoder_plugins/libffmpeg_decoder.so
+FFMPEG_CONFIGURE_OFF= --without-ffmpeg
+
+FLAC_LIB_DEPENDS= libFLAC.so:${PORTSDIR}/audio/flac
+FLAC_PLIST_FILES= lib/moc/decoder_plugins/libflac_decoder.so
+FLAC_CONFIGURE_OFF= --without-flac
JACK_LIB_DEPENDS= libjack.so:${PORTSDIR}/audio/jack
JACK_CONFIGURE_OFF= --without-jack
+MODPLUG_LIB_DEPENDS= libmodplug.so:${PORTSDIR}/audio/libmodplug
+MODPLUG_PLIST_FILES= lib/moc/decoder_plugins/libmodplug_decoder.so
+MODPLUG_CONFIGURE_OFF= --without-modplug
+
MP3_LIB_DEPENDS= libmad.so:${PORTSDIR}/audio/libmad \
- libid3tag.so:${PORTSDIR}/audio/libid3tag
-MP3_PLIST_FILES= lib/moc/decoder_plugins/libmp3_decoder.a \
- lib/moc/decoder_plugins/libmp3_decoder.so
+ libid3tag.so:${PORTSDIR}/audio/libid3tag
+MP3_PLIST_FILES= lib/moc/decoder_plugins/libmp3_decoder.so
MP3_CONFIGURE_OFF= --without-mp3
MUSEPACK_LIB_DEPENDS= libmpcdec.so:${PORTSDIR}/audio/musepack \
- libtag_c.so:${PORTSDIR}/audio/taglib
-MUSEPACK_PLIST_FILES= lib/moc/decoder_plugins/libmusepack_decoder.a \
- lib/moc/decoder_plugins/libmusepack_decoder.so
+ libtag_c.so:${PORTSDIR}/audio/taglib
+MUSEPACK_PLIST_FILES= lib/moc/decoder_plugins/libmusepack_decoder.so
MUSEPACK_CONFIGURE_OFF= --without-musepack
-VORBIS_LIB_DEPENDS= libvorbis.so:${PORTSDIR}/audio/libvorbis
-VORBIS_PLIST_FILES= lib/moc/decoder_plugins/libvorbis_decoder.a \
- lib/moc/decoder_plugins/libvorbis_decoder.so
-VORBIS_CONFIGURE_OFF= --without-ogg
+RCC_LIB_DEPENDS= librcc.so:${PORTSDIR}/devel/librcc \
+ librcd.so:${PORTSDIR}/devel/librcd
+RCC_CONFIGURE_OFF= --without-rcc
-FLAC_LIB_DEPENDS= libFLAC.so:${PORTSDIR}/audio/flac
-FLAC_PLIST_FILES= lib/moc/decoder_plugins/libflac_decoder.a \
- lib/moc/decoder_plugins/libflac_decoder.so
-FLAC_CONFIGURE_OFF= --without-flac
+SAMPLERATE_LIB_DEPENDS= libsamplerate.so:${PORTSDIR}/audio/libsamplerate
+SAMPLERATE_CONFIGURE_OFF= --without-samplerate
-FFMPEG_LIB_DEPENDS= libavcodec.so:${PORTSDIR}/multimedia/ffmpeg
-FFMPEG_PLIST_FILES= lib/moc/decoder_plugins/libffmpeg_decoder.a \
- lib/moc/decoder_plugins/libffmpeg_decoder.so
-FFMPEG_CONFIGURE_OFF= --without-ffmpeg
+SIDPLAY2_LIB_DEPENDS= libsidplay2.so:${PORTSDIR}/audio/libsidplay2
+SIDPLAY2_PLIST_FILES= lib/moc/decoder_plugins/libsidplay2_decoder.so
+SIDPLAY2_CONFIGURE_OFF= --without-sidplay2
SNDFILE_LIB_DEPENDS= libsndfile.so:${PORTSDIR}/audio/libsndfile
-SNDFILE_PLIST_FILES= lib/moc/decoder_plugins/libsndfile_formats_decoder.a \
- lib/moc/decoder_plugins/libsndfile_formats_decoder.so
+SNDFILE_PLIST_FILES= lib/moc/decoder_plugins/libsndfile_decoder.so
SNDFILE_CONFIGURE_OFF= --without-sndfile
SPEEX_LIB_DEPENDS= libspeex.so:${PORTSDIR}/audio/speex
-SPEEX_PLIST_FILES= lib/moc/decoder_plugins/libspeex_decoder.a \
- lib/moc/decoder_plugins/libspeex_decoder.so
+SPEEX_PLIST_FILES= lib/moc/decoder_plugins/libspeex_decoder.so
SPEEX_CONFIGURE_OFF= --without-speex
-SAMPLERATE_LIB_DEPENDS= libsamplerate.so:${PORTSDIR}/audio/libsamplerate
-SAMPLERATE_CONFIGURE_OFF= --without-samplerate
-
-CURL_LIB_DEPENDS= libcurl.so:${PORTSDIR}/ftp/curl
-CURL_CONFIGURE_OFF= --without-curl
+VORBIS_LIB_DEPENDS= libvorbis.so:${PORTSDIR}/audio/libvorbis
+VORBIS_PLIST_FILES= lib/moc/decoder_plugins/libvorbis_decoder.so
+VORBIS_CONFIGURE_OFF= --without-ogg
-RCC_LIB_DEPENDS= librcc.so:${PORTSDIR}/devel/librcc \
- librcd.so:${PORTSDIR}/devel/librcd
-RCC_CONFIGURE_OFF= --without-rcc
+WAVPACK_LIB_DEPENDS= libwavpack.so:${PORTSDIR}/audio/wavpack
+WAVPACK_PLIST_FILES= lib/moc/decoder_plugins/libwavpack_decoder.so
+WAVPACK_CONFIGURE_OFF= --without-wavpack
post-patch:
@${REINPLACE_CMD} -e '/PKG_CONFIG/ s|alsa|no-&|g' ${WRKSRC}/configure
diff --git a/audio/moc/distinfo b/audio/moc/distinfo
index 2cbf5fedd5bf..3539ff507750 100644
--- a/audio/moc/distinfo
+++ b/audio/moc/distinfo
@@ -1,2 +1,2 @@
-SHA256 (moc-2.4.4.tar.bz2) = 26bf5707128def20d8b69c0f0c3624a82b7f72c36280bcf86b9b5e8bf8d08b05
-SIZE (moc-2.4.4.tar.bz2) = 699724
+SHA256 (moc-2.5.0.tar.bz2) = d29ea52240af76c4aa56fa293553da9d66675823e689249cee5f8a60657a6091
+SIZE (moc-2.5.0.tar.bz2) = 594532
diff --git a/audio/moc/pkg-plist b/audio/moc/pkg-plist
index a8c25e1dd20c..fd25285d9092 100644
--- a/audio/moc/pkg-plist
+++ b/audio/moc/pkg-plist
@@ -1,16 +1,16 @@
bin/mocp
man/man1/mocp.1.gz
-share/doc/moc/config.example
-share/doc/moc/THANKS
-share/doc/moc/README
-share/doc/moc/keymap.example
-share/moc/themes/black_theme
-share/moc/themes/darkdot_theme
-share/moc/themes/example_theme
-share/moc/themes/green_theme
-share/moc/themes/moca_theme
-share/moc/themes/nightly_theme
-share/moc/themes/red_theme
-share/moc/themes/transparent-background
-share/moc/themes/yellow_red_theme
-@dir lib/moc/decoder_plugins
+%%DOCSDIR%%/README
+%%DOCSDIR%%/README_equalizer
+%%DOCSDIR%%/THANKS
+%%DOCSDIR%%/config.example
+%%DOCSDIR%%/keymap.example
+%%DATADIR%%/themes/black_theme
+%%DATADIR%%/themes/darkdot_theme
+%%DATADIR%%/themes/example_theme
+%%DATADIR%%/themes/green_theme
+%%DATADIR%%/themes/moca_theme
+%%DATADIR%%/themes/nightly_theme
+%%DATADIR%%/themes/red_theme
+%%DATADIR%%/themes/transparent-background
+%%DATADIR%%/themes/yellow_red_theme