aboutsummaryrefslogtreecommitdiffstats
path: root/audio/mp3gain
diff options
context:
space:
mode:
authoredwin <edwin@FreeBSD.org>2003-01-20 15:08:27 +0800
committeredwin <edwin@FreeBSD.org>2003-01-20 15:08:27 +0800
commit4c1cc43bc8c553d1affb284a12c2624436bace70 (patch)
treea0b15db4700de7ba873990de79c87c0852ce8975 /audio/mp3gain
parente860d49adf869a4bec31e08c5f87527435cd1ac6 (diff)
downloadfreebsd-ports-gnome-4c1cc43bc8c553d1affb284a12c2624436bace70.tar.gz
freebsd-ports-gnome-4c1cc43bc8c553d1affb284a12c2624436bace70.tar.zst
freebsd-ports-gnome-4c1cc43bc8c553d1affb284a12c2624436bace70.zip
new port: audio/mp3gain (A tool to normalize the gain of mp3 files)
Tired of reaching for your volume knob every time your mp3 player changes to a new song? MP3Gain analyzes and adjusts mp3 files so that they have the same volume. PR: ports/46625 Submitted by: Simon 'corecode' Schubert <corecode@corecode.ath.cx>
Diffstat (limited to 'audio/mp3gain')
-rw-r--r--audio/mp3gain/Makefile33
-rw-r--r--audio/mp3gain/distinfo1
-rw-r--r--audio/mp3gain/files/Makefile.lib7
-rw-r--r--audio/mp3gain/files/Makefile.main18
-rw-r--r--audio/mp3gain/pkg-comment1
-rw-r--r--audio/mp3gain/pkg-descr13
-rw-r--r--audio/mp3gain/pkg-plist1
7 files changed, 74 insertions, 0 deletions
diff --git a/audio/mp3gain/Makefile b/audio/mp3gain/Makefile
new file mode 100644
index 000000000000..04d5abe39a8e
--- /dev/null
+++ b/audio/mp3gain/Makefile
@@ -0,0 +1,33 @@
+# New ports collection makefile for: mp3gain
+# Date created: 5 September 2002
+# Whom: Simon 'corecode' Schubert <corecode@corecode.ath.cx>
+#
+# $FreeBSD$
+#
+
+PORTNAME= mp3gain
+PORTVERSION= 1.3.2
+CATEGORIES= audio
+MASTER_SITES= http://www.mpex.net/software/mirror/ \
+ http://www.speakeasy.net/~djkarmad/mp3gain/
+DISTNAME= ${PORTNAME}${PORTVERSION:C/\.//g}_src${EXTSUFFIX}
+
+MAINTAINER= corecode@corecode.ath.cx
+
+USE_REINPLACE= yes
+USE_ZIP= yes
+
+NO_WRKSUBDIR= yes
+
+MAKE_ENV= PREFIX="${PREFIX}"
+
+pre-patch:
+ @${FIND} ${WRKSRC} -type f | ${XARGS} ${REINPLACE_CMD} -e "s/`/usr/bin/printf '\r'`//"
+
+post-patch:
+ @${REINPLACE_CMD} -e '906,943s,/?,-h,;921,945s,/,-,g' ${WRKSRC}/mp3gain.c
+ @${REINPLACE_CMD} -e 's,\\,/,' ${WRKSRC}/mpglibDBL/interface.h
+ @${CP} ${FILESDIR}/Makefile.main ${WRKSRC}/Makefile
+ @${CP} ${FILESDIR}/Makefile.lib ${WRKSRC}/mpglibDBL/Makefile
+
+.include <bsd.port.mk>
diff --git a/audio/mp3gain/distinfo b/audio/mp3gain/distinfo
new file mode 100644
index 000000000000..a6ef4f6e27af
--- /dev/null
+++ b/audio/mp3gain/distinfo
@@ -0,0 +1 @@
+MD5 (mp3gain132_src.zip) = 6d0c8a5d04afeb27927c2b49587cc3f1
diff --git a/audio/mp3gain/files/Makefile.lib b/audio/mp3gain/files/Makefile.lib
new file mode 100644
index 000000000000..b35f292928d7
--- /dev/null
+++ b/audio/mp3gain/files/Makefile.lib
@@ -0,0 +1,7 @@
+CFLAGS+= -DNOANALYSIS
+
+SRCS= common.c dct64_i386.c decode_i386.c interface.c layer3.c tabinit.c
+
+LIB= mpglibDBL
+
+.include <bsd.lib.mk>
diff --git a/audio/mp3gain/files/Makefile.main b/audio/mp3gain/files/Makefile.main
new file mode 100644
index 000000000000..1d575872a223
--- /dev/null
+++ b/audio/mp3gain/files/Makefile.main
@@ -0,0 +1,18 @@
+SRCS= gain_analysis.c mp3gain.c rg_error.c
+PROG= mp3gain
+
+LDADD= -LmpglibDBL -lm -lmpglibDBL
+DPADD= mpglibDBL/libmpglibDBL.a
+OBJS= libmpglibDBL.a
+
+PREFIX?= /usr/local
+DESTDIR?= ${PREFIX}
+BINDIR= /bin
+
+NOMAN= yes
+
+libmpglibDBL.a:
+ cd mpglibDBL && ${MAKE} ${.TARGET}
+ ln -s mpglibDBL/${.TARGET} ${.TARGET}
+
+.include <bsd.prog.mk>
diff --git a/audio/mp3gain/pkg-comment b/audio/mp3gain/pkg-comment
new file mode 100644
index 000000000000..3bc409178425
--- /dev/null
+++ b/audio/mp3gain/pkg-comment
@@ -0,0 +1 @@
+A tool to normalize the gain of mp3 files
diff --git a/audio/mp3gain/pkg-descr b/audio/mp3gain/pkg-descr
new file mode 100644
index 000000000000..7a440243dbff
--- /dev/null
+++ b/audio/mp3gain/pkg-descr
@@ -0,0 +1,13 @@
+Tired of reaching for your volume knob every time your mp3 player changes to a
+new song? MP3Gain analyzes and adjusts mp3 files so that they have the same
+volume.
+
+MP3Gain does not just do peak normalization, as many normalizers do. Instead,
+it does some statistical analysis to determine how loud the file actually
+sounds to the human ear. Also, the changes MP3Gain makes are completely
+lossless. There is no quality lost in the change because the program adjusts
+the mp3 file directly, without decoding and re-encoding.
+
+WWW: http://www.geocities.com/mp3gain/
+
+- Simon 'corecode' Schubert
diff --git a/audio/mp3gain/pkg-plist b/audio/mp3gain/pkg-plist
new file mode 100644
index 000000000000..d6b7de0c350d
--- /dev/null
+++ b/audio/mp3gain/pkg-plist
@@ -0,0 +1 @@
+bin/mp3gain