aboutsummaryrefslogtreecommitdiffstats
path: root/audio/muine
diff options
context:
space:
mode:
authormezz <mezz@FreeBSD.org>2005-05-17 06:42:55 +0800
committermezz <mezz@FreeBSD.org>2005-05-17 06:42:55 +0800
commit038fdc3070c987c930f11a895d5d1038bf4212d7 (patch)
treee9167390199313fa9ba4397d2bcc5e745bfdfea8 /audio/muine
parent6a9694cbf8111fd4b11b0c597af7ff607edf6840 (diff)
downloadfreebsd-ports-gnome-038fdc3070c987c930f11a895d5d1038bf4212d7.tar.gz
freebsd-ports-gnome-038fdc3070c987c930f11a895d5d1038bf4212d7.tar.zst
freebsd-ports-gnome-038fdc3070c987c930f11a895d5d1038bf4212d7.zip
Update to 0.8.3.
BSD# - Project by: http://www.mono-project.com/Mono:FreeBSD
Diffstat (limited to 'audio/muine')
-rw-r--r--audio/muine/Makefile26
-rw-r--r--audio/muine/distinfo4
-rw-r--r--audio/muine/files/patch-src_muine.exe.config.in13
-rw-r--r--audio/muine/pkg-plist24
4 files changed, 45 insertions, 22 deletions
diff --git a/audio/muine/Makefile b/audio/muine/Makefile
index f204dfbec8da..6c5888f25a1a 100644
--- a/audio/muine/Makefile
+++ b/audio/muine/Makefile
@@ -3,11 +3,10 @@
# Whom: Tom McLaughlin <tmclaugh@sdf.lonestar.org>
#
# $FreeBSD$
-#
+# $Id: Makefile,v 1.17 2005/05/12 21:44:41 tmclau02 Exp $
PORTNAME= muine
-PORTVERSION= 0.6.3
-PORTREVISION= 6
+PORTVERSION= 0.8.3
CATEGORIES= audio gnome
MASTER_SITES= http://muine.gooeylinux.org/
@@ -17,30 +16,31 @@ COMMENT= Mono based Gnome audio player
LIB_DEPENDS= FLAC.7:${PORTSDIR}/audio/flac \
id3tag.2:${PORTSDIR}/audio/libid3tag \
gdbm:${PORTSDIR}/databases/gdbm
-BUILD_DEPENDS= gapi-fixup:${PORTSDIR}/x11-toolkits/gtk-sharp
+BUILD_DEPENDS= gapi2-fixup:${PORTSDIR}/x11-toolkits/gtk-sharp-devel \
+ ${LOCALBASE}/lib/mono/dbus-sharp/dbus-sharp.dll:${PORTSDIR}/devel/dbus-sharp
RUN_DEPENDS= ${BUILD_DEPENDS}
+USE_GMAKE= yes
USE_GNOME= gnomeprefix gnomehack intltool libgnomeui
-WANT_GSTREAMER= yes
-USE_X_PREFIX= yes
+USE_X_PREFIX= yes
USE_LIBTOOL_VER=15
USE_REINPLACE= yes
CONFIGURE_ENV+= CPPFLAGS="-I${LOCALBASE}/include" \
- LDFLAGS="-L${LOCALBASE}/lib"
+ LDFLAGS="-L${LOCALBASE}/lib" \
+ GACUTIL_FLAGS="/package muine /gacdir $(DESTDIR)$(libdir) /root $(DESTDIR)$(libdir)"
GCONF_SCHEMAS= muine.schemas
-OPTIONS= GSTREAMER "Enable Gstreamer backend" off
+OPTIONS= XINE "Enable Xine backend" off
.include <bsd.port.pre.mk>
-.if defined (WITH_GSTREAMER)
-IGNORE= Doesn't run with recent gstreamer.
-CONFIGURE_ARGS+=--enable-gstreamer=yes
-USE_GSTREAMER+= mad vorbis flac gconf
+.if defined (WITH_XINE)
+CONFIGURE_ARGS+= --enable-xine=yes
+LIB_DEPENDS+= xine.12:${PORTSDIR}/multimedia/libxine
.else
-LIB_DEPENDS+= xine.13:${PORTSDIR}/multimedia/libxine
+USE_GNOME+= gstreamerplugins
.endif
.include <bsd.port.post.mk>
diff --git a/audio/muine/distinfo b/audio/muine/distinfo
index aaa35942c30f..d5d1e391c690 100644
--- a/audio/muine/distinfo
+++ b/audio/muine/distinfo
@@ -1,2 +1,2 @@
-MD5 (muine-0.6.3.tar.gz) = dc7923e1e0ba87f0303bc30f14f604e3
-SIZE (muine-0.6.3.tar.gz) = 624566
+MD5 (muine-0.8.3.tar.gz) = 4e21eeb8e809bebf1e13540e44a6259d
+SIZE (muine-0.8.3.tar.gz) = 769686
diff --git a/audio/muine/files/patch-src_muine.exe.config.in b/audio/muine/files/patch-src_muine.exe.config.in
index 6eb9c6d7cb81..ab3c83de51e2 100644
--- a/audio/muine/files/patch-src_muine.exe.config.in
+++ b/audio/muine/files/patch-src_muine.exe.config.in
@@ -1,11 +1,14 @@
---- src/muine.exe.config.in.orig Sat Jun 5 12:48:33 2004
-+++ src/muine.exe.config.in Thu Jul 15 21:59:47 2004
-@@ -1,6 +1,6 @@
+--- src/muine.exe.config.in.orig Mon Jan 24 06:58:11 2005
++++ src/muine.exe.config.in Thu May 12 16:57:20 2005
+@@ -1,7 +1,7 @@
<configuration>
- <dllmap dll="libglib-2.0-0.dll" target="libglib-2.0.so.0"/>
+- <dllmap dll="libgtk-2.0-0.dll" target="libgtk-x11-2.0.so.0"/>
- <dllmap dll="libgobject-2.0-0.dll" target="libgobject-2.0.so.0"/>
+- <dllmap dll="libgnomevfs-2-0.dll" target="libgnomevfs-2.so.0"/>
+ <dllmap dll="libglib-2.0-0.dll" target="libglib-2.0.so"/>
++ <dllmap dll="libgtk-2.0-0.dll" target="libgtk-x11-2.0.so"/>
+ <dllmap dll="libgobject-2.0-0.dll" target="libgobject-2.0.so"/>
- <dllmap dll="libgnomevfs-2.dll" target="libgnomevfs-2.so"/>
- <dllmap dll="libmuine" target="@prefix@/lib/muine/libmuine.so"/>
++ <dllmap dll="libgnomevfs-2-0.dll" target="libgnomevfs-2.so"/>
+ <dllmap dll="libmuine" target="@pkglibdir@/libmuine.so"/>
</configuration>
diff --git a/audio/muine/pkg-plist b/audio/muine/pkg-plist
index 50064d960b9c..c5c7ceb1f68d 100644
--- a/audio/muine/pkg-plist
+++ b/audio/muine/pkg-plist
@@ -1,13 +1,19 @@
bin/muine
-lib/muine/AmazonSearchService.dll
+lib/dbus-1.0/services/org.gnome.Muine.service
+lib/mono/gac/muine-dbus/1.0.0.0__e6bf890338fa2913/muine-dbus.dll
+lib/mono/gac/muine-plugin/1.0.0.0__e6bf890338fa2913/muine-plugin.dll
+lib/mono/muine/muine-dbus.dll
+lib/mono/muine/muine-plugin.dll
lib/muine/libmuine.a
lib/muine/libmuine.so
lib/muine/libmuine.so.0
lib/muine/muine.exe
lib/muine/muine.exe.config
-share/gnome/application-registry/muine.applications
+libdata/pkgconfig/muine-dbus.pc
+libdata/pkgconfig/muine-plugin.pc
share/gnome/applications/muine.desktop
share/gnome/pixmaps/muine.png
+share/locale/az/LC_MESSAGES/muine.mo
share/locale/bg/LC_MESSAGES/muine.mo
share/locale/ca/LC_MESSAGES/muine.mo
share/locale/cs/LC_MESSAGES/muine.mo
@@ -16,19 +22,33 @@ share/locale/de/LC_MESSAGES/muine.mo
share/locale/en_CA/LC_MESSAGES/muine.mo
share/locale/en_GB/LC_MESSAGES/muine.mo
share/locale/es/LC_MESSAGES/muine.mo
+share/locale/et/LC_MESSAGES/muine.mo
share/locale/eu/LC_MESSAGES/muine.mo
+share/locale/fi/LC_MESSAGES/muine.mo
share/locale/fr/LC_MESSAGES/muine.mo
share/locale/hr/LC_MESSAGES/muine.mo
share/locale/hu/LC_MESSAGES/muine.mo
share/locale/is/LC_MESSAGES/muine.mo
share/locale/ja/LC_MESSAGES/muine.mo
share/locale/ko/LC_MESSAGES/muine.mo
+share/locale/lt/LC_MESSAGES/muine.mo
+share/locale/ms/LC_MESSAGES/muine.mo
+share/locale/nb/LC_MESSAGES/muine.mo
share/locale/nl/LC_MESSAGES/muine.mo
share/locale/no/LC_MESSAGES/muine.mo
share/locale/pl/LC_MESSAGES/muine.mo
share/locale/pt/LC_MESSAGES/muine.mo
share/locale/pt_BR/LC_MESSAGES/muine.mo
+share/locale/ro/LC_MESSAGES/muine.mo
+share/locale/ru/LC_MESSAGES/muine.mo
+share/locale/rw/LC_MESSAGES/muine.mo
share/locale/sr/LC_MESSAGES/muine.mo
share/locale/sr@Latn/LC_MESSAGES/muine.mo
share/locale/sv/LC_MESSAGES/muine.mo
+share/locale/zh_CN/LC_MESSAGES/muine.mo
@dirrm lib/muine
+@dirrm lib/mono/muine
+@dirrm lib/mono/gac/muine-plugin/1.0.0.0__e6bf890338fa2913
+@dirrm lib/mono/gac/muine-plugin
+@dirrm lib/mono/gac/muine-dbus/1.0.0.0__e6bf890338fa2913
+@dirrm lib/mono/gac/muine-dbus