aboutsummaryrefslogtreecommitdiffstats
path: root/audio/mumble
diff options
context:
space:
mode:
authoramdmi3 <amdmi3@FreeBSD.org>2009-03-19 08:22:01 +0800
committeramdmi3 <amdmi3@FreeBSD.org>2009-03-19 08:22:01 +0800
commitfb6a31245d1483b63c08ae98a309d823d60b5f4b (patch)
treeeb5506ac24a235c9fe76cb3bf997ab895865a0b5 /audio/mumble
parentbc1804f41722fc71df58b3038d7fee999681b90f (diff)
downloadfreebsd-ports-gnome-fb6a31245d1483b63c08ae98a309d823d60b5f4b.tar.gz
freebsd-ports-gnome-fb6a31245d1483b63c08ae98a309d823d60b5f4b.tar.zst
freebsd-ports-gnome-fb6a31245d1483b63c08ae98a309d823d60b5f4b.zip
Mumble is an open source, low-latency, high quality voice chat software
primarily intended for use while gaming. WWW: http://mumble.sourceforge.net/ PR: 131298 Submitted by: Marius Nuennerich <marius at nuenneri dot ch>
Diffstat (limited to 'audio/mumble')
-rw-r--r--audio/mumble/Makefile60
-rw-r--r--audio/mumble/distinfo3
-rw-r--r--audio/mumble/files/patch-src-mumble-mumble.pro16
-rw-r--r--audio/mumble/pkg-descr4
-rw-r--r--audio/mumble/pkg-message6
-rw-r--r--audio/mumble/pkg-plist22
6 files changed, 111 insertions, 0 deletions
diff --git a/audio/mumble/Makefile b/audio/mumble/Makefile
new file mode 100644
index 000000000000..9c87c9b46b16
--- /dev/null
+++ b/audio/mumble/Makefile
@@ -0,0 +1,60 @@
+# New ports collection makefile for: mumble
+# Date created: 1 February 2009
+# Whom: marius nuennerich
+#
+# $FreeBSD$
+#
+
+PORTNAME= mumble
+PORTVERSION= 1.1.7
+CATEGORIES= audio
+MASTER_SITES= SF
+
+MAINTAINER= marius@nuenneri.ch
+COMMENT= A voice chat software primarily intended for use while gaming
+
+LIB_DEPENDS+= speex.1:${PORTSDIR}/audio/speex \
+ boost_iostreams:${PORTSDIR}/devel/boost
+
+USE_GMAKE= yes
+USE_QT_VER= 4
+QT_COMPONENTS= gui opengl dbus xml sql network linguist l10n \
+ moc_build qmake_build rcc_build uic_build
+
+USE_XORG= ice
+HAS_CONFIGURE= yes
+INSTALLS_ICONS= yes
+
+CONFIG= no-server no-alsa no-speechd no-bundled-speex no-update no-g15 \
+ no-portaudio no-pulseaudio no-xevie
+
+MAN1= mumble.1 mumble-overlay.1
+
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} < 700000
+BROKEN= Does not compile on FreeBSD < 7.0
+.endif
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|-ldl||' ${WRKSRC}/overlay_gl/overlay_gl.pro
+
+do-configure:
+ cd ${WRKSRC} && ${SETENV} QMAKESPEC=${QMAKESPEC} ${QMAKE} PREFIX=${PREFIX} main.pro "CONFIG+=${CONFIG}"
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/release/mumble ${PREFIX}/bin
+ ${INSTALL_SCRIPT} ${WRKSRC}/scripts/mumble-overlay ${PREFIX}/bin
+ ${MKDIR} ${PREFIX}/share/services
+ ${INSTALL_DATA} ${WRKSRC}/scripts/mumble.protocol ${PREFIX}/share/services
+ ${MKDIR} ${PREFIX}/share/applications
+ ${INSTALL_DATA} ${WRKSRC}/scripts/mumble.desktop ${PREFIX}/share/applications
+ ${INSTALL_DATA} ${WRKSRC}/icons/mumble.xpm ${PREFIX}/share/pixmaps
+ for f in 16 32 48 64; do \
+ ${MKDIR} ${PREFIX}/share/icons/hicolor/$${f}x$${f}/apps; \
+ ${INSTALL_DATA} ${WRKSRC}/icons/mumble.$${f}x$${f}.png ${PREFIX}/share/icons/hicolor/$${f}x$${f}/apps; \
+ done
+ ${INSTALL_MAN} ${WRKSRC}/man/mumble.1 ${MANPREFIX}/man/man1/mumble.1
+ ${INSTALL_MAN} ${WRKSRC}/man/mumble-overlay.1 ${MANPREFIX}/man/man1/mumble-overlay.1
+
+.include <bsd.port.post.mk>
diff --git a/audio/mumble/distinfo b/audio/mumble/distinfo
new file mode 100644
index 000000000000..4cebe39b26c3
--- /dev/null
+++ b/audio/mumble/distinfo
@@ -0,0 +1,3 @@
+MD5 (mumble-1.1.7.tar.gz) = 5a382d5c065bb264abfe240ca6f03ddc
+SHA256 (mumble-1.1.7.tar.gz) = e30e41cfb5d8b7596211b8c4530ee1b79b3bcd5cccac7aebb06122275d5eeedd
+SIZE (mumble-1.1.7.tar.gz) = 1169344
diff --git a/audio/mumble/files/patch-src-mumble-mumble.pro b/audio/mumble/files/patch-src-mumble-mumble.pro
new file mode 100644
index 000000000000..795ede39fb2c
--- /dev/null
+++ b/audio/mumble/files/patch-src-mumble-mumble.pro
@@ -0,0 +1,16 @@
+--- src/mumble/mumble.pro.orig 2009-03-16 16:21:13.038835100 +0100
++++ src/mumble/mumble.pro 2009-03-16 16:22:07.155100994 +0100
+@@ -107,6 +107,13 @@
+ SOURCES *= GlobalShortcut_unix.cpp TextToSpeech_unix.cpp Overlay_unix.cpp
+ }
+
++ contains(UNAME, FreeBSD) {
++ CONFIG *= oss
++ HEADERS *= GlobalShortcut_unix.h
++ SOURCES *= GlobalShortcut_unix.cpp TextToSpeech_unix.cpp Overlay_unix.cpp
++ LIBS *= -lssl
++ }
++
+ macx {
+ TARGET = Mumble
+ ICON = ../../icons/mumble.icns
diff --git a/audio/mumble/pkg-descr b/audio/mumble/pkg-descr
new file mode 100644
index 000000000000..5855658b0ca2
--- /dev/null
+++ b/audio/mumble/pkg-descr
@@ -0,0 +1,4 @@
+Mumble is an open source, low-latency, high quality voice chat software
+primarily intended for use while gaming.
+
+WWW: http://mumble.sourceforge.net/
diff --git a/audio/mumble/pkg-message b/audio/mumble/pkg-message
new file mode 100644
index 000000000000..6a5ad6aca4dc
--- /dev/null
+++ b/audio/mumble/pkg-message
@@ -0,0 +1,6 @@
+You need to load sem.ko into your kernel otherwise mumble
+won't start and you will get an error message about an invalid system call.
+
+To make this persistent over a reboot add
+ sem_load="YES"
+to your /boot/loader.conf
diff --git a/audio/mumble/pkg-plist b/audio/mumble/pkg-plist
new file mode 100644
index 000000000000..a8334db724a7
--- /dev/null
+++ b/audio/mumble/pkg-plist
@@ -0,0 +1,22 @@
+@comment $FreeBSD$
+bin/mumble
+bin/mumble-overlay
+share/applications/mumble.desktop
+share/services/mumble.protocol
+share/icons/hicolor/16x16/apps/mumble.16x16.png
+share/icons/hicolor/32x32/apps/mumble.32x32.png
+share/icons/hicolor/48x48/apps/mumble.48x48.png
+share/icons/hicolor/64x64/apps/mumble.64x64.png
+share/pixmaps/mumble.xpm
+@dirrmtry share/applications
+@dirrmtry share/services
+@dirrmtry share/icons/hicolor/64x64/apps
+@dirrmtry share/icons/hicolor/64x64
+@dirrmtry share/icons/hicolor/48x48/apps
+@dirrmtry share/icons/hicolor/48x48
+@dirrmtry share/icons/hicolor/32x32/apps
+@dirrmtry share/icons/hicolor/32x32
+@dirrmtry share/icons/hicolor/16x16/apps
+@dirrmtry share/icons/hicolor/16x16
+@dirrmtry share/icons/hicolor
+@dirrmtry share/icons