aboutsummaryrefslogtreecommitdiffstats
path: root/audio/musescore
diff options
context:
space:
mode:
authornemysis <nemysis@FreeBSD.org>2013-10-28 11:03:46 +0800
committernemysis <nemysis@FreeBSD.org>2013-10-28 11:03:46 +0800
commit720a2f2360499a9f597bc10f3d5faa10a11dc43f (patch)
tree264de3d975c1835a884aa3b7d69cb6433f2880a9 /audio/musescore
parent6f791c318663a0db787a05af5a57570214e3560c (diff)
downloadfreebsd-ports-gnome-720a2f2360499a9f597bc10f3d5faa10a11dc43f.tar.gz
freebsd-ports-gnome-720a2f2360499a9f597bc10f3d5faa10a11dc43f.tar.zst
freebsd-ports-gnome-720a2f2360499a9f597bc10f3d5faa10a11dc43f.zip
audio/musescore
- Bump PORTREVISION for dependency change - Fix portaudio2 dependency due to recent commit - Use the new format for LIB_DEPENDS - Support STAGEDIR and add OPTIONS_SUB - Add DOCS and Option audio/zynaddsubfx - Bump PORTREVISION for dependency change - Fix portaudio2 dependency due to recent commit - Use the new format for LIB_DEPENDS - Add DOCS and EXAMPLES Options - Change DOCS - Support STAGEDIR and add OPTIONS_SUB - Change pkg-plist, remove DOCS and EXAMPLES games/glob2 - Simplify master sites - Bump PORTREVISION for dependency change - Fix portaudio2 dependency due to recent commit - Change comment - Use the new format for LIB_DEPENDS - Add DOCS and Option - Change icons - Use REINPLACE_CMD instead of files/patch-src_VoiceRecorder.cpp - Adjust patches - Change pkg-message Approved by: pawel / wg (mentors, implicit)
Diffstat (limited to 'audio/musescore')
-rw-r--r--audio/musescore/Makefile40
1 files changed, 20 insertions, 20 deletions
diff --git a/audio/musescore/Makefile b/audio/musescore/Makefile
index 8259ca246e70..e1e7915a2369 100644
--- a/audio/musescore/Makefile
+++ b/audio/musescore/Makefile
@@ -3,8 +3,9 @@
PORTNAME= musescore
PORTVERSION= 1.3
+PORTREVISION= 1
CATEGORIES= audio
-MASTER_SITES= SF/mscore/mscore/MuseScore-${PORTVERSION}
+MASTER_SITES= SF/mscore/mscore/MuseScore-${PORTVERSION}/
DISTNAME= mscore-${PORTVERSION}
MAINTAINER= ports@FreeBSD.org
@@ -13,14 +14,10 @@ COMMENT= Free music composition & notation software
LICENSE= GPLv2
BUILD_DEPENDS= qtscriptgenerator>0:${PORTSDIR}/devel/qtscriptgenerator
-LIB_DEPENDS= sndfile:${PORTSDIR}/audio/libsndfile
+LIB_DEPENDS= libsndfile.so:${PORTSDIR}/audio/libsndfile
RUN_DEPENDS= qtscriptgenerator>0:${PORTSDIR}/devel/qtscriptgenerator
-OPTIONS_DEFINE= JACK PORTAUDIO
-OPTIONS_DEFAULT=PORTAUDIO
-
USE_BZIP2= yes
-NO_STAGE= yes
USES= cmake:outsource
USE_QT4= corelib designer gui network script scripttools svg webkit xml \
linguist_build moc_build qmake_build rcc_build uic_build
@@ -31,22 +28,21 @@ MAKE_JOBS_UNSAFE= yes
DATADIR= ${PREFIX}/share/mscore-${PORTVERSION}
-.include <bsd.port.options.mk>
+PORTDOCS= ChangeLog NEWS README README.scripts
+
+OPTIONS_DEFINE= DOCS JACK PORTAUDIO
+OPTIONS_DEFAULT=PORTAUDIO
+
+OPTIONS_SUB= yes
-.if ${PORT_OPTIONS:MJACK}
-LIB_DEPENDS+= jack:${PORTSDIR}/audio/jack
-CMAKE_ARGS+= -DBUILD_JACK:BOOL=ON
-.else
-CMAKE_ARGS+= -DBUILD_JACK:BOOL=OFF
-.endif
+JACK_LIB_DEPENDS= libjack.so:${PORTSDIR}/audio/jack
+JACK_CMAKE_ON= -DBUILD_JACK:BOOL=ON
+JACK_CMAKE_OFF= -DBUILD_JACK:BOOL=OFF
-.if ${PORT_OPTIONS:MPORTAUDIO}
-BUILD_DEPENDS+= portaudio>=19:${PORTSDIR}/audio/portaudio2
-RUN_DEPENDS+= portaudio>=19:${PORTSDIR}/audio/portaudio2
-CMAKE_ARGS+= -DBUILD_PORTAUDIO:BOOL=ON
-.else
-CMAKE_ARGS+= -DBUILD_PORTAUDIO:BOOL=OFF
-.endif
+PORTAUDIO_BUILD_DEPENDS=portaudio2>=0:${PORTSDIR}/audio/portaudio2
+PORTAUDIO_RUN_DEPENDS= portaudio2>=0:${PORTSDIR}/audio/portaudio2
+PORTAUDIO_CMAKE_ON= -DBUILD_PORTAUDIO:BOOL=ON
+PORTAUDIO_CMAKE_OFF= -DBUILD_PORTAUDIO:BOOL=OFF
post-patch:
@${FIND} ${WRKSRC} -name "CMakeLists.txt" -print0 | ${XARGS} -0 \
@@ -58,4 +54,8 @@ post-patch:
@${ECHO_CMD} >> ${WRKSRC}/mscore/mscore/${file}
.endfor
+post-install:
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_DATA} ${PORTDOCS:S|^|${WRKSRC}/mscore/|} ${STAGEDIR}${DOCSDIR}
+
.include <bsd.port.mk>