aboutsummaryrefslogtreecommitdiffstats
path: root/audio/musicpd
diff options
context:
space:
mode:
authordanfe <danfe@FreeBSD.org>2008-12-06 05:18:03 +0800
committerdanfe <danfe@FreeBSD.org>2008-12-06 05:18:03 +0800
commit2e76de49acafd492dacde51682608169bf53c0c4 (patch)
tree45e12f9bb5c43de0e7b93c390fc3c1df9f31cb34 /audio/musicpd
parent8577e58a2d4905835643833bb155c3ec035e9c72 (diff)
downloadfreebsd-ports-gnome-2e76de49acafd492dacde51682608169bf53c0c4.tar.gz
freebsd-ports-gnome-2e76de49acafd492dacde51682608169bf53c0c4.tar.zst
freebsd-ports-gnome-2e76de49acafd492dacde51682608169bf53c0c4.zip
- Allow to build with Tremor support
- Actually add dependency on libshout2 mentioned in previous commit Approved by: maintainer timeout (one month)
Diffstat (limited to 'audio/musicpd')
-rw-r--r--audio/musicpd/Makefile12
1 files changed, 11 insertions, 1 deletions
diff --git a/audio/musicpd/Makefile b/audio/musicpd/Makefile
index d09d75f7c194..502402be149e 100644
--- a/audio/musicpd/Makefile
+++ b/audio/musicpd/Makefile
@@ -35,6 +35,7 @@ SUB_FILES= pkg-message
OPTIONS= FLAC "Support FLAC audio format" on \
VORBIS "Support OGG Vorbis audio format" on \
+ TREMOR "Support Tremor (integer-only Vorbis)" off \
WAV "Support WAV audio format" on \
AAC "Support MP4/AAC audio format" off \
MUSEPACK "Support MPC audio format" off \
@@ -63,6 +64,11 @@ CONFIGURE_ARGS+=--disable-ogg
LIB_DEPENDS+= vorbis.4:${PORTSDIR}/audio/libvorbis
.endif
+.if defined(WITH_TREMOR)
+CONFIGURE_ARGS+=--with-tremor
+LIB_DEPENDS+= vorbisidec.1:${PORTSDIR}/audio/libtremor
+.endif
+
.if defined(WITHOUT_WAV)
CONFIGURE_ARGS+=--disable-audiofile
.else
@@ -119,7 +125,11 @@ LIB_DEPENDS+= jack.0:${PORTSDIR}/audio/jack
CONFIGURE_ARGS+=--disable-jack
.endif
-.if defined(WITHOUT_SHOUTCAST)
+# libshout streaming support will be disabled by configure script when built
+# also with tremor since the latter does not support vorbis encoding
+.if defined(WITH_SHOUTCAST) && !defined(WITH_TREMOR)
+LIB_DEPENDS+= shout.5:${PORTSDIR}/audio/libshout2
+.else
CONFIGURE_ARGS+=--disable-shout
.endif