aboutsummaryrefslogtreecommitdiffstats
path: root/audio/musicpd
diff options
context:
space:
mode:
authorcrees <crees@FreeBSD.org>2012-02-04 07:20:50 +0800
committercrees <crees@FreeBSD.org>2012-02-04 07:20:50 +0800
commit7952d67b3bf016413d45e7b3782f9dcf5360c323 (patch)
tree6beefee96e49274b12c98e34658c56fc552326f1 /audio/musicpd
parent44d9dd2767b7d91547d7c7f1cbbe6e9cbc62f86a (diff)
downloadfreebsd-ports-gnome-7952d67b3bf016413d45e7b3782f9dcf5360c323.tar.gz
freebsd-ports-gnome-7952d67b3bf016413d45e7b3782f9dcf5360c323.tar.zst
freebsd-ports-gnome-7952d67b3bf016413d45e7b3782f9dcf5360c323.zip
Add OPTION to link with libcue, off by default
PR: ports/155593
Diffstat (limited to 'audio/musicpd')
-rw-r--r--audio/musicpd/Makefile10
1 files changed, 9 insertions, 1 deletions
diff --git a/audio/musicpd/Makefile b/audio/musicpd/Makefile
index e7c24c07b807..2c6495b03137 100644
--- a/audio/musicpd/Makefile
+++ b/audio/musicpd/Makefile
@@ -61,7 +61,8 @@ OPTIONS= ID3TAG "Support ID3 v1/v2 tags" on \
SNDFILE "Adds support for libsndfile" on \
LAME "Support for MP3 Icecast Streams" off \
HTTPD "Support for httpd output streaming" off \
- SAMPLERATE "Support sample rate conversion" off
+ SAMPLERATE "Support sample rate conversion" off \
+ CUE "Support embedded cue sheets" off
MPDDIR?= /var/mpd
MPDUSER?= mpd
@@ -229,6 +230,13 @@ LIB_DEPENDS+= samplerate.1:${PORTSDIR}/audio/libsamplerate
CONFIGURE_ARGS+=--enable-lsr
.endif
+.if defined(WITH_CUE)
+CONFIGURE_ARGS+=--enable-cue
+LIB_DEPENDS+= cue:${PORTSDIR}/textproc/libcue
+.else
+CONFIGURE_ARGS+=--disable-cue
+.endif
+
post-patch:
# Replace ~/ with MPDDIR and make musicpd run as mpd by default
@${REINPLACE_CMD} -e 's,^#\([^"]*"\)~/,\1${MPDDIR}/,g' \