aboutsummaryrefslogtreecommitdiffstats
path: root/audio/musicpd
diff options
context:
space:
mode:
authorwxs <wxs@FreeBSD.org>2011-03-02 03:49:36 +0800
committerwxs <wxs@FreeBSD.org>2011-03-02 03:49:36 +0800
commit864b7828b93235b75be615d79ddb8928e8931322 (patch)
tree63e81b2b4546e596d642dac504e251aa4199c01c /audio/musicpd
parente4d0267b5d5399a4f70f113526afa59529d1e547 (diff)
downloadfreebsd-ports-gnome-864b7828b93235b75be615d79ddb8928e8931322.tar.gz
freebsd-ports-gnome-864b7828b93235b75be615d79ddb8928e8931322.tar.zst
freebsd-ports-gnome-864b7828b93235b75be615d79ddb8928e8931322.zip
Include upstream fix for 24-bit audio (disable it).
Silence a REINPLACE_CMD while we are here. PR: ports/155168 Submitted by: Chris Rees <utisoft@gmail.com> (maintainer)
Diffstat (limited to 'audio/musicpd')
-rw-r--r--audio/musicpd/Makefile8
1 files changed, 6 insertions, 2 deletions
diff --git a/audio/musicpd/Makefile b/audio/musicpd/Makefile
index 8632bed2aa61..5a2dedaf549f 100644
--- a/audio/musicpd/Makefile
+++ b/audio/musicpd/Makefile
@@ -7,7 +7,7 @@
PORTNAME= musicpd
PORTVERSION= 0.16.1
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= audio ipv6
MASTER_SITES= SF/${PORTNAME}/mpd/${PORTVERSION}
DISTNAME= mpd-${PORTVERSION}
@@ -226,9 +226,13 @@ CONFIGURE_ARGS+=--enable-lsr
.endif
post-patch:
+# Fix issues with garbled sound for 24-bit on FreeBSD. This is fixed in git,
+# so should be removed with next update.
+ @${REINPLACE_CMD} -e '383,395d;421,430d' \
+ ${WRKSRC}/src/output/oss_plugin.c
@${REINPLACE_CMD} -e "s/%%MPDDIR%%/${PREFIX:C/\//\\\//g}\/${MPDDIR:C/\//\\\//g}/g" -e "s/%%MPDUSER%%/${MPDUSER}/g" \
${WRKSRC}/doc/mpdconf.example
- ${REINPLACE_CMD} -e 's/tremor == xno/tremor = xno/' \
+ @${REINPLACE_CMD} -e 's/tremor == xno/tremor = xno/' \
${WRKSRC}/configure
.if (${OSVERSION} < 800000)
${REINPLACE_CMD} -e 's/nan[f]\{0,1\}(\"\")/NAN/g' \