aboutsummaryrefslogtreecommitdiffstats
path: root/audio/nas
diff options
context:
space:
mode:
authorBaptiste Daroussin <bapt@FreeBSD.org>2013-06-28 19:51:05 +0800
committerBaptiste Daroussin <bapt@FreeBSD.org>2013-06-28 19:51:05 +0800
commit932db7c46c9a269808dfa67ea02746b350c194d8 (patch)
tree5182ef394eeef9bff78abf27f4a3a05f7fb8ff43 /audio/nas
parentb9b5e71f19dfde1a969d42e0660cc786432b3500 (diff)
downloadfreebsd-ports-gnome-932db7c46c9a269808dfa67ea02746b350c194d8.tar.gz
freebsd-ports-gnome-932db7c46c9a269808dfa67ea02746b350c194d8.tar.zst
freebsd-ports-gnome-932db7c46c9a269808dfa67ea02746b350c194d8.zip
New USES imake to handle the dependency on imake.
This uses accept 'env' as an argument for ports that do use their own or a different do-configure target. Modify xmkmf so it accept IMAKECPPFLAGS as default flags for imake and pass it to the called imake. Modify xorg-cf-files (the FreeBSD.cf configuration file) to allow CppCmd to be overwritten. Pass CppCmd CcCmd and CplusplusCmd via command line to each call of imake via IMAKECPPFLAGS Pass IMAKE_DEFINE with the above arguments to MAKE_ARGS so that imake spawned from Makefile generated by a previous imake also inherit the defined CppCmd CcCmd and CplusplusCmd. Make imake use devel/tradcpp all the time, so that when buidling with clang we do not depend on gcc's cpp. Make imake respect CC and CXX Make imake respect USE_GCC (if set imake will use gcc's cpp). While here: - Remove a couple of indefinite articles from comments - Trim headers - Fix a couple of ports to build with clang or use: USE_GCC=any - Fix a now useless redefinition of the extraction chain - Fix a typo in japanese/Wnn7-lib bundled imake template definitions - Fix some XMKMF execution with no env specified - Use options helper in x11/xautolock to simplify the port
Diffstat (limited to 'audio/nas')
-rw-r--r--audio/nas/Makefile8
1 files changed, 2 insertions, 6 deletions
diff --git a/audio/nas/Makefile b/audio/nas/Makefile
index 387ad958765b..6bf9dc881649 100644
--- a/audio/nas/Makefile
+++ b/audio/nas/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: nas (formerly netaudio)
-# Date created: 03 Nov 1994
-# Whom: jkh
-#
+# Created by: jkh
# $FreeBSD$
-#
PORTNAME= nas
PORTVERSION= 1.9.3
@@ -14,8 +10,8 @@ EXTRACT_SUFX= .src.tar.gz
MAINTAINER= multimedia@FreeBSD.org
COMMENT= Network Audio System
+USES= imake
USE_GCC= any
-USE_IMAKE= yes
USE_XORG= x11 xext xt xau sm ice xp xpm xmu xaw
USE_LDCONFIG= yes
MAKE_ENV+= COMPRESS_CMD="${COMPRESS_CMD:S/c//}"