aboutsummaryrefslogtreecommitdiffstats
path: root/audio/openal/Makefile
diff options
context:
space:
mode:
authoroliver <oliver@FreeBSD.org>2006-04-23 18:14:30 +0800
committeroliver <oliver@FreeBSD.org>2006-04-23 18:14:30 +0800
commita1afb15bc3ca23d864c38bb5aa46770398e443e0 (patch)
tree61d0b5cff39b644111399fd6d81cc02dadc4b0ed /audio/openal/Makefile
parentf85495f88f996a09638af8e00a215073a46b55ad (diff)
downloadfreebsd-ports-gnome-a1afb15bc3ca23d864c38bb5aa46770398e443e0.tar.gz
freebsd-ports-gnome-a1afb15bc3ca23d864c38bb5aa46770398e443e0.tar.zst
freebsd-ports-gnome-a1afb15bc3ca23d864c38bb5aa46770398e443e0.zip
update to openal 20060211 [1]
fix dependant ports [2] PR: ports/96172 [1] ports/95192 [2] Submitted by: maintainer [1] oliver [2] Approved by: maintainer
Diffstat (limited to 'audio/openal/Makefile')
-rw-r--r--audio/openal/Makefile25
1 files changed, 14 insertions, 11 deletions
diff --git a/audio/openal/Makefile b/audio/openal/Makefile
index a2c4fb2706e5..586ea1a36da9 100644
--- a/audio/openal/Makefile
+++ b/audio/openal/Makefile
@@ -6,24 +6,20 @@
#
PORTNAME= openal
-PORTVERSION= 20050401
-PORTREVISION= 1
+PORTVERSION= 20060211
CATEGORIES= audio
-MASTER_SITES= http://math.missouristate.edu/~erik/files/fbsd/\
- http://www.smluc.org/~erik/files/fbsd/
+MASTER_SITES= http://openal.org/openal_webstf/downloads/
+DISTVERSION= 0.0.8
MAINTAINER= erik@smluc.org
COMMENT= A 3D positional spatialized sound library
-INFO= openal
-
-WRKSRC= ${WRKDIR}/${DISTNAME}/linux
GNU_CONFIGURE= yes
CONFIGURE_TARGET=--build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" LDFLAGS="-L${LOCALBASE}/lib"
CONFIGURE_ARGS= --enable-capture
USE_GMAKE= yes
-USE_GNOME= pkgconfig
+USE_GNOME= pkgconfig gnomehack
WANT_SDL= yes
INSTALLS_SHLIB= yes
USE_REINPLACE= yes
@@ -43,27 +39,37 @@ WITH_SDL= yes # smpeg requires SDL
.if defined(WITH_ARTS)
LIB_DEPENDS+= artsc.0:${PORTSDIR}/audio/arts
CONFIGURE_ARGS+=--enable-arts
+.else
+CONFIGURE_ARGS+=--disable-arts
.endif
.if defined(WITH_ESD)
USE_GNOME+= esound
CONFIGURE_ARGS+=--enable-esd
+.else
+CONFIGURE_ARGS+=--disable-esd
.endif
.if defined(WITH_SDL)
USE_SDL+= sdl
CONFIGURE_ENV+= HAVESDL="${SDL_CONFIG}"
CONFIGURE_ARGS+=--enable-sdl
+.else
+CONFIGURE_ARGS+=--disable-sdl
.endif
.if defined(WITH_VORBIS)
LIB_DEPENDS+= vorbisfile.4:${PORTSDIR}/audio/libvorbis
CONFIGURE_ARGS+=--enable-vorbis
+.else
+CONFIGURE_ARGS+=--disable-vorbis
.endif
.if defined(WITH_SMPEG)
LIB_DEPENDS+= smpeg.1:${PORTSDIR}/multimedia/smpeg
CONFIGURE_ARGS+=--enable-smpeg
+.else
+CONFIGURE_ARGS+=--disable-smpeg
.endif
post-patch:
@@ -72,7 +78,4 @@ post-patch:
@${REINPLACE_CMD} -e '/#include/ s|SDL/||' \
${WRKSRC}/src/extensions/al_ext_mp3.c
-post-install:
- ${INSTALL_DATA} ${WRKSRC}/doc/openal.info ${PREFIX}/info
-
.include <bsd.port.post.mk>