aboutsummaryrefslogtreecommitdiffstats
path: root/audio/oss
diff options
context:
space:
mode:
authortijl <tijl@FreeBSD.org>2014-12-09 00:48:38 +0800
committertijl <tijl@FreeBSD.org>2014-12-09 00:48:38 +0800
commite2300845f96fc1f90e03af0a746423bff0b0e770 (patch)
treefd2d9471767ad6e92fff12ef08f1cb015017f9f8 /audio/oss
parentb0b474e0ac449202a591c50a796cb0435cbf54fb (diff)
downloadfreebsd-ports-gnome-e2300845f96fc1f90e03af0a746423bff0b0e770.tar.gz
freebsd-ports-gnome-e2300845f96fc1f90e03af0a746423bff0b0e770.tar.zst
freebsd-ports-gnome-e2300845f96fc1f90e03af0a746423bff0b0e770.zip
Replace USES=libtool:oldver with USES=libtool or USES=libtool:keepla in
the 32 ports that still use it. Bump PORTREVISION on their dependent ports except the ones that depend on these: audio/libogg audio/libvorbis devel/pcre ftp/curl graphics/jpeg graphics/libart_lgpl graphics/tiff textproc/expat2 textproc/libxslt In these cases the same trick as in the recent gettext update is used. The ports install a symlink with the old library version. When enough of their dependent ports have had regular updates the remaining ones can get a PORTREVISION bump and the links can be removed. Also remove the devel/pcre dependency from USE_GNOME=glib20. It causes over 2200 packages to depend on devel/pcre while less than 200 actually link with it. The glib20 package still depends on devel/pcre so this should not make a difference for ports with USE_GNOME=glib20. Also, libdata/pkgconfig/glib-2.0.pc lists pcre as a private library so USE_GNOME=glib20 should not propagate it. PR: 195724 Exp-run by: antoine Approved by: portmgr (antoine)
Diffstat (limited to 'audio/oss')
-rw-r--r--audio/oss/Makefile1
-rw-r--r--audio/oss/files/patch-cmd-ossplay-ossplay_parser.c11
2 files changed, 1 insertions, 11 deletions
diff --git a/audio/oss/Makefile b/audio/oss/Makefile
index 01e4921e587a..04beb1f06638 100644
--- a/audio/oss/Makefile
+++ b/audio/oss/Makefile
@@ -3,6 +3,7 @@
PORTNAME= oss
DISTVERSION= 4.2-build2009
+PORTREVISION= 1
CATEGORIES= audio
MASTER_SITES= http://www.opensound.com/developer/sources/stable/bsd/
DISTNAME= ${PORTNAME}-v${DISTVERSION}-src-bsd
diff --git a/audio/oss/files/patch-cmd-ossplay-ossplay_parser.c b/audio/oss/files/patch-cmd-ossplay-ossplay_parser.c
deleted file mode 100644
index 97e8579ec43f..000000000000
--- a/audio/oss/files/patch-cmd-ossplay-ossplay_parser.c
+++ /dev/null
@@ -1,11 +0,0 @@
---- cmd/ossplay/ossplay_parser.c.bak 2009-09-03 06:14:34.000000000 -0400
-+++ cmd/ossplay/ossplay_parser.c 2009-09-22 15:17:49.000000000 -0400
-@@ -91,7 +91,7 @@
- {
- *vft = (dlopen_funcs_t *)ossplay_malloc (sizeof (dlopen_funcs_t));
-
-- (*vft)->vorbisfile_handle = ossplay_dlopen ("libvorbisfile.so.3");
-+ (*vft)->vorbisfile_handle = ossplay_dlopen ("libvorbisfile.so.6");
-
- if ((*vft)->vorbisfile_handle == NULL)
- {