aboutsummaryrefslogtreecommitdiffstats
path: root/audio/pd/Makefile
diff options
context:
space:
mode:
authordanfe <danfe@FreeBSD.org>2007-07-02 12:54:59 +0800
committerdanfe <danfe@FreeBSD.org>2007-07-02 12:54:59 +0800
commitd7a4277dc68bf7f352cd1dcb414dd62fdad55018 (patch)
tree29140787e02278ce94be4f273a1465e421b1c5c5 /audio/pd/Makefile
parent966da657df70c029c0c7b88d2cce0c666a8a246c (diff)
downloadfreebsd-ports-gnome-d7a4277dc68bf7f352cd1dcb414dd62fdad55018.tar.gz
freebsd-ports-gnome-d7a4277dc68bf7f352cd1dcb414dd62fdad55018.tar.zst
freebsd-ports-gnome-d7a4277dc68bf7f352cd1dcb414dd62fdad55018.zip
- Fix the build with recent GCC [1]
- Improve upon port description - Clean up Makefile, pet portlint(1) Reported by: pointyhat (logs) [1]
Diffstat (limited to 'audio/pd/Makefile')
-rw-r--r--audio/pd/Makefile15
1 files changed, 8 insertions, 7 deletions
diff --git a/audio/pd/Makefile b/audio/pd/Makefile
index c2f846af76e0..6d8c1773a60c 100644
--- a/audio/pd/Makefile
+++ b/audio/pd/Makefile
@@ -1,23 +1,24 @@
-# New ports collection makefile for: pd
+# New ports collection makefile for: Pd
# Date created: 2002-05-24
-# Whom: trevor
+# Whom: Trevor Johnson <trevor@FreeBSD.org>
#
# $FreeBSD$
#
PORTNAME= pd
DISTVERSION= 0.40-2
-PORTREVISION= 1
DISTVERSIONSUFFIX= .src
+PORTREVISION= 1
CATEGORIES= audio
MASTER_SITES= http://www-crca.ucsd.edu/~msp/Software/
MAINTAINER= ports@FreeBSD.org
-COMMENT= Pure Data, a MIDI-capable real-time audio processor/synthesizer
+COMMENT= MIDI-capable real-time audio processor/synthesizer
WRKSRC= ${WRKDIR}/${DISTNAME:S;.src;/src;}
GNU_CONFIGURE= yes
-CONFIGURE_ENV= CFLAGS="${CFLAGS} ${PTHREAD_CFLAGS} -I${X11BASE}/include -I${TCL_INCLUDEDIR} -I${TK_INCLUDEDIR}" \
+CONFIGURE_ENV= CFLAGS="${CFLAGS} ${PTHREAD_CFLAGS} -I${X11BASE}/include \
+ -I${TCL_INCLUDEDIR} -I${TK_INCLUDEDIR}" \
LIBS="${PTHREAD_LIBS} -L${LOCALBASE}/lib"
MAKEFILE= makefile
MAN1= pd.1 pdreceive.1 pdsend.1
@@ -77,7 +78,7 @@ do-install:
${INSTALL_DATA} ${WRKSRC}/../bin/pd.tk ${PREFIX}/bin
${INSTALL_DATA} ${WRKSRC}/m_pd.h ${PREFIX}/include
.if !defined(NOPORTDOCS)
- ${MKDIR} ${DOCSDIR}
+ @${MKDIR} ${DOCSDIR}
.for ii in LICENSE README
${INSTALL_DATA} ${WRKSRC}/../${ii}.txt ${DOCSDIR}
.endfor
@@ -86,7 +87,7 @@ do-install:
.for ii in pd pdreceive pdsend
${INSTALL_MAN} ${WRKSRC}/../man/${ii}.1 ${PREFIX}/man/man1/
.endfor
- ${MKDIR} ${DATADIR}
+ @${MKDIR} ${DATADIR}
cd ${WRKSRC}/../extra && ${PAX} -r -w * ${DATADIR}
.include <bsd.port.post.mk>