aboutsummaryrefslogtreecommitdiffstats
path: root/audio/phatbeat/Makefile
diff options
context:
space:
mode:
authorkrion <krion@FreeBSD.org>2004-06-22 22:34:15 +0800
committerkrion <krion@FreeBSD.org>2004-06-22 22:34:15 +0800
commitbbcdb48213adb5b3e2a3405527124c6f01ce318d (patch)
treef320d7bd71ec0c264ad8f23ebfdd343d3bed7625 /audio/phatbeat/Makefile
parent438fc51140419138f184a7a2983582f41dc230f6 (diff)
downloadfreebsd-ports-gnome-bbcdb48213adb5b3e2a3405527124c6f01ce318d.tar.gz
freebsd-ports-gnome-bbcdb48213adb5b3e2a3405527124c6f01ce318d.tar.zst
freebsd-ports-gnome-bbcdb48213adb5b3e2a3405527124c6f01ce318d.zip
Add phatbeat 1.1,
In a nutshell, PhatBeat is a cross-platform (Linux and Windows) beat counter for use by collectors, producers, DJs, and others interested in beat-oriented music. For now it requires users to tap in the beat during listening, after which it calculates and displays the track's BPM and the size of a measure in seconds. PR: ports/68198 Submitted by: Jean-Yves Lefort <jylefort@brutele.be>
Diffstat (limited to 'audio/phatbeat/Makefile')
-rw-r--r--audio/phatbeat/Makefile26
1 files changed, 26 insertions, 0 deletions
diff --git a/audio/phatbeat/Makefile b/audio/phatbeat/Makefile
new file mode 100644
index 000000000000..afec02684815
--- /dev/null
+++ b/audio/phatbeat/Makefile
@@ -0,0 +1,26 @@
+# New ports collection makefile for: PhatBeat
+# Date created: 22 Jun 2004
+# Whom: Jean-Yves Lefort <jylefort@brutele.be>
+#
+# $FreeBSD$
+#
+
+PORTNAME= phatbeat
+PORTVERSION= 1.1
+CATEGORIES= audio
+MASTER_SITES= http://www.postreal.org/files/
+DISTNAME= PhatBeat-${PORTVERSION}
+
+MAINTAINER= jylefort@brutele.be
+COMMENT= A beat counter
+
+USE_X_PREFIX= yes
+USE_SDL= sdl image
+MAN1= phatbeat.1
+
+MAKE_ENV= MKDIR="${MKDIR}" \
+ INSTALL_PROGRAM="${INSTALL_PROGRAM}" \
+ INSTALL_MAN="${INSTALL_MAN}" \
+ INSTALL_DATA="${INSTALL_DATA}"
+
+.include <bsd.port.mk>