aboutsummaryrefslogtreecommitdiffstats
path: root/audio/pianobar
diff options
context:
space:
mode:
authoramdmi3 <amdmi3@FreeBSD.org>2013-09-25 12:18:08 +0800
committeramdmi3 <amdmi3@FreeBSD.org>2013-09-25 12:18:08 +0800
commit841085d71c8d63d793a0d03a6b6b8689fa34f5f6 (patch)
treea5cb168f9bb14d78e0d6ed69febd11faf2969e6c /audio/pianobar
parentf17ecef52ad878e3414c0426de81f42b68329f38 (diff)
downloadfreebsd-ports-gnome-841085d71c8d63d793a0d03a6b6b8689fa34f5f6.tar.gz
freebsd-ports-gnome-841085d71c8d63d793a0d03a6b6b8689fa34f5f6.tar.zst
freebsd-ports-gnome-841085d71c8d63d793a0d03a6b6b8689fa34f5f6.zip
- Update to 2013.09.15 [1]
- While here, use new LIB_DEPENDS syntax and respect PREFIX PR: 182331 [1] Submitted by: John Hixson <john@ixsystems.com> (maintainer) [1]
Diffstat (limited to 'audio/pianobar')
-rw-r--r--audio/pianobar/Makefile16
-rw-r--r--audio/pianobar/distinfo4
-rw-r--r--audio/pianobar/files/patch-Makefile5
-rw-r--r--audio/pianobar/files/patch-crypt.c10
-rw-r--r--audio/pianobar/files/patch-crypt.h10
-rw-r--r--audio/pianobar/files/patch-piano.h10
6 files changed, 13 insertions, 42 deletions
diff --git a/audio/pianobar/Makefile b/audio/pianobar/Makefile
index 27baf7599bd2..2f8714040489 100644
--- a/audio/pianobar/Makefile
+++ b/audio/pianobar/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= pianobar
-PORTVERSION= 2013.05.19
+PORTVERSION= 2013.09.15
CATEGORIES= audio
MASTER_SITES= http://6xq.net/projects/${PORTNAME}/
@@ -11,12 +11,12 @@ COMMENT= Command line Pandora player
LICENSE= MIT
-LIB_DEPENDS= ao:${PORTSDIR}/audio/libao \
- faad:${PORTSDIR}/audio/faad \
- mad:${PORTSDIR}/audio/libmad \
- gnutls:${PORTSDIR}/security/gnutls \
- json:${PORTSDIR}/devel/json-c \
- gcrypt:${PORTSDIR}/security/libgcrypt
+LIB_DEPENDS= libao.so:${PORTSDIR}/audio/libao \
+ libfaad.so:${PORTSDIR}/audio/faad \
+ libmad.so:${PORTSDIR}/audio/libmad \
+ libgnutls.so:${PORTSDIR}/security/gnutls \
+ libjson.so:${PORTSDIR}/devel/json-c \
+ libgcrypt.so:${PORTSDIR}/security/libgcrypt
MAN1= pianobar.1
MAN_COMPRESSED= no
@@ -26,7 +26,7 @@ PLIST_FILES= bin/pianobar
USES= gmake pkgconfig
NO_STAGE= yes
USE_BZIP2= yes
-MAKE_ARGS+= CC="${CC}"
+MAKE_ARGS+= CC="${CC}" PREFIX="${PREFIX}"
CFLAGS+= -I${LOCALBASE}/include -std=c99
LDFLAGS+= -L${LOCALBASE}/lib
diff --git a/audio/pianobar/distinfo b/audio/pianobar/distinfo
index 3cabb893db37..70ac3dde177c 100644
--- a/audio/pianobar/distinfo
+++ b/audio/pianobar/distinfo
@@ -1,2 +1,2 @@
-SHA256 (pianobar-2013.05.19.tar.bz2) = cf88e82663d2b0aa4d73e761506eac4f3e7bc789b57d92377acd994d785e1046
-SIZE (pianobar-2013.05.19.tar.bz2) = 50942
+SHA256 (pianobar-2013.09.15.tar.bz2) = 3f8cf25ef054acf46e519d02453a6e214cfa09661b3adc03da99ace1c6f10066
+SIZE (pianobar-2013.09.15.tar.bz2) = 52553
diff --git a/audio/pianobar/files/patch-Makefile b/audio/pianobar/files/patch-Makefile
index b2685e288e3c..bd162ce3fa6b 100644
--- a/audio/pianobar/files/patch-Makefile
+++ b/audio/pianobar/files/patch-Makefile
@@ -1,5 +1,6 @@
---- Makefile.orig 2013-06-06 11:12:53.077684094 -0700
-+++ Makefile 2013-06-06 11:25:07.697666849 -0700
+diff -urN pianobar-2013.09.15.orig/Makefile pianobar-2013.09.15/Makefile
+--- Makefile 2013-09-15 06:54:04.000000000 -0700
++++ Makefile 2013-09-23 12:20:05.869414665 -0700
@@ -4,7 +4,7 @@
BINDIR:=${PREFIX}/bin
LIBDIR:=${PREFIX}/lib
diff --git a/audio/pianobar/files/patch-crypt.c b/audio/pianobar/files/patch-crypt.c
deleted file mode 100644
index 4fc444a1dac6..000000000000
--- a/audio/pianobar/files/patch-crypt.c
+++ /dev/null
@@ -1,10 +0,0 @@
---- src/libpiano/crypt.c.orig 2012-05-06 07:33:54.000000000 -0700
-+++ src/libpiano/crypt.c 2012-05-12 19:42:13.000000000 -0700
-@@ -23,6 +23,7 @@
-
- #include <string.h>
- #include <assert.h>
-+#define _GCRYPT_IN_LIBGCRYPT
- #include <gcrypt.h>
- #include <stdio.h>
- #include <stdlib.h>
diff --git a/audio/pianobar/files/patch-crypt.h b/audio/pianobar/files/patch-crypt.h
deleted file mode 100644
index a93b21e53b69..000000000000
--- a/audio/pianobar/files/patch-crypt.h
+++ /dev/null
@@ -1,10 +0,0 @@
---- src/libpiano/crypt.h.orig 2012-05-06 07:33:54.000000000 -0700
-+++ src/libpiano/crypt.h 2012-05-12 19:42:29.000000000 -0700
-@@ -24,6 +24,7 @@
- #ifndef _CRYPH_H
- #define _CRYPT_H
-
-+#define _GCRYPT_IN_LIBGCRYPT
- #include <gcrypt.h>
-
- char *PianoDecryptString (gcry_cipher_hd_t, const char * const,
diff --git a/audio/pianobar/files/patch-piano.h b/audio/pianobar/files/patch-piano.h
deleted file mode 100644
index 260526d1a970..000000000000
--- a/audio/pianobar/files/patch-piano.h
+++ /dev/null
@@ -1,10 +0,0 @@
---- src/libpiano/piano.h.orig 2012-05-06 07:33:54.000000000 -0700
-+++ src/libpiano/piano.h 2012-05-12 19:42:41.000000000 -0700
-@@ -25,6 +25,7 @@
- #define _PIANO_H
-
- #include <stdbool.h>
-+#define _GCRYPT_IN_LIBGCRYPT
- #include <gcrypt.h>
-
- /* this is our public API; don't expect this api to be stable as long as