aboutsummaryrefslogtreecommitdiffstats
path: root/audio/picard
diff options
context:
space:
mode:
authorwg <wg@FreeBSD.org>2013-12-16 00:22:17 +0800
committerwg <wg@FreeBSD.org>2013-12-16 00:22:17 +0800
commit781e42a27d143c9dd7bb035b0e0230c7c1b12e88 (patch)
tree528f950c491cb30f26166e5e23d4b77ad233a5ee /audio/picard
parent2a2657433c0cd564b2a2da9e60eb35d412a019f2 (diff)
downloadfreebsd-ports-gnome-781e42a27d143c9dd7bb035b0e0230c7c1b12e88.tar.gz
freebsd-ports-gnome-781e42a27d143c9dd7bb035b0e0230c7c1b12e88.tar.zst
freebsd-ports-gnome-781e42a27d143c9dd7bb035b0e0230c7c1b12e88.zip
Use setuptools for all Python ports.
Setuptools is the preferred method to manage Python distributions after many changes to the packaging ecosystem over the past couple of years. Only ports using USE_PYDISTUTILS= yes are affected by this commit, ports using USE_PYDISTUTILS= easy_install remains the same however this usage is now deprecated and should be converted to USE_PYDISTUTILS= yes. Some Python distributions do not work with setuptools out of the box because they extend the install command from distutils and not setuptools, and so they need to be patched accordingly. pip (which leverages setuptools) works around the issue by using eggs, however we want to get rid of those as well, as support for "flat" installation is unavailable or has other issues associated with it. This work allows us to unify how python packages are built, ensure that Python distributions are installed consistently, reduces complexity for Python port maintainers and paves the way for simplifying the Python ports framework in the future. With hat on: python Reviewed by: koobs, antoine Exp-run: bdrewery Approved by: bdrewery (portmgr)
Diffstat (limited to 'audio/picard')
-rw-r--r--audio/picard/Makefile1
1 files changed, 1 insertions, 0 deletions
diff --git a/audio/picard/Makefile b/audio/picard/Makefile
index c8f89738dfb2..e9f22428c258 100644
--- a/audio/picard/Makefile
+++ b/audio/picard/Makefile
@@ -45,6 +45,7 @@ RUN_DEPENDS+= metaflac:${PORTSDIR}/audio/flac \
post-patch:
@${REINPLACE_CMD} -e "s|'picard.plugins',|'picard.plugins', 'picard.plugins.lastfm', 'picard.plugins.lastfmplus', 'picard.plugins.replaygain',|" \
+ -e 's,distutils\.command\.install ,setuptools\.command\.install ,' \
${WRKSRC}/setup.py
@${CP} -R ${WRKSRC}/contrib/plugins/ ${WRKSRC}/picard/plugins