aboutsummaryrefslogtreecommitdiffstats
path: root/audio/playgsf/Makefile
diff options
context:
space:
mode:
authorpav <pav@FreeBSD.org>2005-07-28 20:15:12 +0800
committerpav <pav@FreeBSD.org>2005-07-28 20:15:12 +0800
commit9181dd5fd648bd98595e937dc4fde5bd3cef1cb2 (patch)
treec0381388800281238038f6e5799449b74c604b2d /audio/playgsf/Makefile
parent019ec7b1508dd96e740d6e212d90ba142870bdce (diff)
downloadfreebsd-ports-gnome-9181dd5fd648bd98595e937dc4fde5bd3cef1cb2.tar.gz
freebsd-ports-gnome-9181dd5fd648bd98595e937dc4fde5bd3cef1cb2.tar.zst
freebsd-ports-gnome-9181dd5fd648bd98595e937dc4fde5bd3cef1cb2.zip
Playgsf is a simple command line player for gsf files based on a winamp plugin
called 'Highly Advanced'. The gsf file format is a music format similar to the psf format for playstation(TM). PR: ports/84025 Submitted by: Emanuel Haupt <ehaupt@critical.ch>
Diffstat (limited to 'audio/playgsf/Makefile')
-rw-r--r--audio/playgsf/Makefile38
1 files changed, 38 insertions, 0 deletions
diff --git a/audio/playgsf/Makefile b/audio/playgsf/Makefile
new file mode 100644
index 000000000000..0974a4564bc9
--- /dev/null
+++ b/audio/playgsf/Makefile
@@ -0,0 +1,38 @@
+# New ports collection makefile for: playgsf
+# Date created: 10 Jul 2005
+# Whom: Emanuel Haupt <ehaupt@critical.ch>
+#
+# $FreeBSD$
+#
+
+PORTNAME= playgsf
+PORTVERSION= 0.6
+CATEGORIES= audio
+MASTER_SITES= http://projects.raphnet.net/playgsf/
+
+MAINTAINER= ehaupt@critical.ch
+COMMENT= A command line player for gsf audio files
+
+USE_GMAKE= yes
+USE_REINPLACE= yes
+USE_LIBTOOL_VER=15
+USE_GCC= 3.4+
+
+# avoid a "of memory error" gcc bug
+CFLAGS+= -O0
+
+PLIST_FILES= bin/playgsf
+
+ONLY_FOR_ARCHS= i386 # contains x86 assembler
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|^\(CFLAGS="\)\(-DLINUX\)|\1${CFLAGS} \2|' \
+ ${WRKSRC}/configure
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${PREFIX}/bin
+
+post-install:
+ ${CAT} ${PKGMESSAGE}
+
+.include <bsd.port.mk>