aboutsummaryrefslogtreecommitdiffstats
path: root/audio/pragha
diff options
context:
space:
mode:
authorolivierd <olivierd@FreeBSD.org>2015-07-21 00:31:06 +0800
committerolivierd <olivierd@FreeBSD.org>2015-07-21 00:31:06 +0800
commit1ad39e419f2c8ecd8992226c77c0239638bbd765 (patch)
tree50380979d84e5d068f5ed9a95a3bfb2d9a131694 /audio/pragha
parent64eb70cef43f98abdb65d40b5424cab357473e7b (diff)
downloadfreebsd-ports-gnome-1ad39e419f2c8ecd8992226c77c0239638bbd765.tar.gz
freebsd-ports-gnome-1ad39e419f2c8ecd8992226c77c0239638bbd765.tar.zst
freebsd-ports-gnome-1ad39e419f2c8ecd8992226c77c0239638bbd765.zip
Pragha is a Lightweight Music Player, based on GTK, and SQLite.
Main features: * Full integration with GTK+3 * Library with multiple views, according tags or folder structure * Search, filtering and queue songs on current playlist * Playing and edit tag of mp3, m4a, ogg, flac, asf, wma, and ape files * Playlist management: Exporting M3U and read M3U, PLS, XSPF and WAX playlists. * Playback control with command line Extensible by plugins: * AcoustID: Get metadata on AcoustID service * Global Hotkeys: Control Pragha with multimedia keys * Notification: Show notification when change songs * Get radios: Search radios on TuneIn service WWW: http://pragha-music-player.github.io/
Diffstat (limited to 'audio/pragha')
-rw-r--r--audio/pragha/Makefile48
-rw-r--r--audio/pragha/distinfo2
-rw-r--r--audio/pragha/files/patch-configure11
-rw-r--r--audio/pragha/files/patch-plugins_Makefile.in22
-rw-r--r--audio/pragha/pkg-descr18
-rw-r--r--audio/pragha/pkg-plist52
6 files changed, 153 insertions, 0 deletions
diff --git a/audio/pragha/Makefile b/audio/pragha/Makefile
new file mode 100644
index 000000000000..9598cf968d91
--- /dev/null
+++ b/audio/pragha/Makefile
@@ -0,0 +1,48 @@
+# Created by: Olivier Duchateau
+# $FreeBSD$
+
+PORTNAME= pragha
+PORTVERSION= 1.3.2.2
+CATEGORIES= audio
+MASTER_SITES= https://github.com/pragha-music-player/${PORTNAME}/releases/download/v${PORTVERSION}/
+
+MAINTAINER= olivierd@FreeBSD.org
+COMMENT= Lightweight music player
+
+LICENSE= GPLv3
+
+LIB_DEPENDS= libtag.so:${PORTSDIR}/audio/taglib \
+ libpeas-1.0.so:${PORTSDIR}/devel/libpeas \
+ libnotify.so:${PORTSDIR}/devel/libnotify \
+ libkeybinder-3.0.so:${PORTSDIR}/x11/keybinder-gtk3 \
+ libsoup-2.4.so:${PORTSDIR}/devel/libsoup \
+ libtotem-plparser.so:${PORTSDIR}/multimedia/totem-pl-parser
+
+USES= compiler:c11 desktop-file-utils gettext-tools gmake libtool \
+ pkgconfig tar:bz2
+GNU_CONFIGURE= yes
+USE_GNOME= glib20 gtk30 intltool intlhack
+USE_SQLITE= yes
+USE_GSTREAMER1= yes faad flac libav mad ogg speex
+INSTALLS_ICONS= yes
+USE_LDCONFIG= yes
+INSTALL_TARGET= install-strip
+
+CFLAGS+= -Wno-typedef-redefinition
+
+CONFIGURE_ARGS=--disable-libglyr \
+ --disable-gudev-1.0 \
+ --disable-libmtp \
+ --disable-rygel-server-2.2 \
+ --disable-grilo-0.2 \
+ --disable-libclastfm \
+ --enable-taglib \
+ --enable-totem-plparser \
+ --disable-libxfce4ui
+
+OPTIONS_DEFINE= NLS
+NLS_USES= gettext-runtime
+NLS_CONFIGURE_ENABLE= nls
+OPTIONS_SUB= yes
+
+.include <bsd.port.mk>
diff --git a/audio/pragha/distinfo b/audio/pragha/distinfo
new file mode 100644
index 000000000000..b3a7cb55b498
--- /dev/null
+++ b/audio/pragha/distinfo
@@ -0,0 +1,2 @@
+SHA256 (pragha-1.3.2.2.tar.bz2) = a3f9f08fbe7a5384885494e167d1d5066aa295fc489ecaebeb137aab82416242
+SIZE (pragha-1.3.2.2.tar.bz2) = 672610
diff --git a/audio/pragha/files/patch-configure b/audio/pragha/files/patch-configure
new file mode 100644
index 000000000000..3d7e8027390c
--- /dev/null
+++ b/audio/pragha/files/patch-configure
@@ -0,0 +1,11 @@
+--- configure.orig 2015-02-21 22:12:00 UTC
++++ configure
+@@ -12595,7 +12595,7 @@ $as_echo "#define HAVE_LC_MESSAGES 1" >>
+
+ fi
+ fi
+- USE_NLS=yes
++ #USE_NLS=yes
+
+
+ gt_cv_have_gettext=no
diff --git a/audio/pragha/files/patch-plugins_Makefile.in b/audio/pragha/files/patch-plugins_Makefile.in
new file mode 100644
index 000000000000..39ee7974c32f
--- /dev/null
+++ b/audio/pragha/files/patch-plugins_Makefile.in
@@ -0,0 +1,22 @@
+Remove 'gnome-media-keys' plugin, it requires sysutils/gnome-settings-daemon.
+
+--- plugins/Makefile.in.orig 2015-02-21 22:11:57 UTC
++++ plugins/Makefile.in
+@@ -182,7 +182,7 @@ am__define_uniq_tagged_files = \
+ done | $(am__uniquify_input)`
+ ETAGS = etags
+ CTAGS = ctags
+-DIST_SUBDIRS = mpris2 gnome-media-keys song-info keybinder notify \
++DIST_SUBDIRS = mpris2 song-info keybinder notify \
+ devices removable-media mtp acoustid tunein dlna dlna-renderer \
+ cdrom lastfm
+ DISTFILES = $(DIST_COMMON) $(DIST_SOURCES) $(TEXINFOS) $(EXTRA_DIST)
+@@ -467,7 +467,7 @@ AM_CPPFLAGS = \
+
+ pluginincludedir = $(includedir)/pragha/plugins
+ plugininclude_HEADERS = pragha-plugin-macros.h
+-SUBDIRS = mpris2 gnome-media-keys $(am__append_1) $(am__append_2) \
++SUBDIRS = mpris2 $(am__append_1) $(am__append_2) \
+ $(am__append_3) $(am__append_4) $(am__append_5) \
+ $(am__append_6) $(am__append_7) $(am__append_8) \
+ $(am__append_9) $(am__append_10)
diff --git a/audio/pragha/pkg-descr b/audio/pragha/pkg-descr
new file mode 100644
index 000000000000..22ba09eb9968
--- /dev/null
+++ b/audio/pragha/pkg-descr
@@ -0,0 +1,18 @@
+Pragha is a Lightweight Music Player, based on GTK, and SQLite.
+
+Main features:
+* Full integration with GTK+3
+* Library with multiple views, according tags or folder structure
+* Search, filtering and queue songs on current playlist
+* Playing and edit tag of mp3, m4a, ogg, flac, asf, wma, and ape files
+* Playlist management: Exporting M3U and read M3U, PLS, XSPF and WAX
+ playlists.
+* Playback control with command line
+
+Extensible by plugins:
+* AcoustID: Get metadata on AcoustID service
+* Global Hotkeys: Control Pragha with multimedia keys
+* Notification: Show notification when change songs
+* Get radios: Search radios on TuneIn service
+
+WWW: http://pragha-music-player.github.io/
diff --git a/audio/pragha/pkg-plist b/audio/pragha/pkg-plist
new file mode 100644
index 000000000000..292a531f750f
--- /dev/null
+++ b/audio/pragha/pkg-plist
@@ -0,0 +1,52 @@
+bin/pragha
+include/pragha/plugins/pragha-plugin-macros.h
+lib/pragha/plugins/acoustid/acoustid.plugin
+lib/pragha/plugins/acoustid/libacoustid.so
+lib/pragha/plugins/keybinder/keybinder.plugin
+lib/pragha/plugins/keybinder/libkeybinder.so
+lib/pragha/plugins/mpris2/libmpris2.so
+lib/pragha/plugins/mpris2/mpris2.plugin
+lib/pragha/plugins/notify/libnotify.so
+lib/pragha/plugins/notify/notify.plugin
+lib/pragha/plugins/tunein/libtunein.so
+lib/pragha/plugins/tunein/tunein.plugin
+man/man1/pragha.1.gz
+share/appdata/pragha.appdata.xml
+share/applications/pragha.desktop
+%%DOCSDIR%%/ChangeLog
+%%DOCSDIR%%/FAQ
+%%DOCSDIR%%/NEWS
+%%DOCSDIR%%/README
+share/icons/hicolor/128x128/apps/pragha.png
+share/icons/hicolor/16x16/apps/pragha.png
+share/icons/hicolor/24x24/apps/pragha.png
+share/icons/hicolor/32x32/apps/pragha.png
+share/icons/hicolor/48x48/apps/pragha.png
+share/icons/hicolor/64x64/apps/pragha.png
+%%NLS%%share/locale/bg/LC_MESSAGES/pragha.mo
+%%NLS%%share/locale/ca_ES/LC_MESSAGES/pragha.mo
+%%NLS%%share/locale/cs/LC_MESSAGES/pragha.mo
+%%NLS%%share/locale/de/LC_MESSAGES/pragha.mo
+%%NLS%%share/locale/el/LC_MESSAGES/pragha.mo
+%%NLS%%share/locale/es/LC_MESSAGES/pragha.mo
+%%NLS%%share/locale/fr/LC_MESSAGES/pragha.mo
+%%NLS%%share/locale/hu/LC_MESSAGES/pragha.mo
+%%NLS%%share/locale/it/LC_MESSAGES/pragha.mo
+%%NLS%%share/locale/ja/LC_MESSAGES/pragha.mo
+%%NLS%%share/locale/ko_KR/LC_MESSAGES/pragha.mo
+%%NLS%%share/locale/nl/LC_MESSAGES/pragha.mo
+%%NLS%%share/locale/no/LC_MESSAGES/pragha.mo
+%%NLS%%share/locale/pl/LC_MESSAGES/pragha.mo
+%%NLS%%share/locale/pt/LC_MESSAGES/pragha.mo
+%%NLS%%share/locale/pt_BR/LC_MESSAGES/pragha.mo
+%%NLS%%share/locale/ru/LC_MESSAGES/pragha.mo
+%%NLS%%share/locale/sv/LC_MESSAGES/pragha.mo
+%%NLS%%share/locale/tr/LC_MESSAGES/pragha.mo
+%%NLS%%share/locale/uk/LC_MESSAGES/pragha.mo
+%%NLS%%share/locale/vi/LC_MESSAGES/pragha.mo
+%%NLS%%share/locale/zh_CN/LC_MESSAGES/pragha.mo
+share/pixmaps/pragha/album.png
+share/pixmaps/pragha/artist.png
+share/pixmaps/pragha/cover.png
+share/pixmaps/pragha/genre.png
+share/pixmaps/pragha/track.png