aboutsummaryrefslogtreecommitdiffstats
path: root/audio/py-mad/Makefile
diff options
context:
space:
mode:
authorperky <perky@FreeBSD.org>2002-10-08 15:14:39 +0800
committerperky <perky@FreeBSD.org>2002-10-08 15:14:39 +0800
commitf802def6275e5237a4c814b23cb1f304c4da2957 (patch)
tree9031bd305ce6c86f05352d6b8837a6ed4799d7ed /audio/py-mad/Makefile
parent7473eb02bcc4b4059ae1a64a9813d8e1b345973c (diff)
downloadfreebsd-ports-gnome-f802def6275e5237a4c814b23cb1f304c4da2957.tar.gz
freebsd-ports-gnome-f802def6275e5237a4c814b23cb1f304c4da2957.tar.zst
freebsd-ports-gnome-f802def6275e5237a4c814b23cb1f304c4da2957.zip
Add py-mad 0.3, a Python module that provides the MPEG Audio Decoder interface
Diffstat (limited to 'audio/py-mad/Makefile')
-rw-r--r--audio/py-mad/Makefile30
1 files changed, 30 insertions, 0 deletions
diff --git a/audio/py-mad/Makefile b/audio/py-mad/Makefile
new file mode 100644
index 000000000000..d7cd16f2286e
--- /dev/null
+++ b/audio/py-mad/Makefile
@@ -0,0 +1,30 @@
+# New ports collection makefile for: py-mad
+# Date created: 8 October 2002
+# Whom: Hye-Shik Chang
+#
+# $FreeBSD$
+
+PORTNAME= mad
+PORTVERSION= 0.3
+CATEGORIES= audio python
+MASTER_SITES= http://spacepants.org/src/pymad/download/
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+DISTNAME= pymad-${PORTVERSION}
+
+MAINTAINER= perky@FreeBSD.org
+
+LIB_DEPENDS= mad.1:${PORTSDIR}/audio/mad
+
+USE_REINPLACE= yes
+USE_PYTHON= yes
+USE_PYDISTUTILS= yes
+USE_PYTHON_PREFIX= yes
+
+post-patch:
+ @${REINPLACE_CMD} 's/^\(.*compile.*\)\?\(.*\)\?\(.*\)$$/\1\2\3/' \
+ ${WRKSRC}/setup.py
+
+do-configure:
+ @cd ${WRKSRC} && ${PYTHON_CMD} config_unix.py --prefix ${PREFIX}
+
+.include <bsd.port.mk>