aboutsummaryrefslogtreecommitdiffstats
path: root/audio/qsampler
diff options
context:
space:
mode:
authortcberner <tcberner@FreeBSD.org>2018-06-29 01:39:53 +0800
committertcberner <tcberner@FreeBSD.org>2018-06-29 01:39:53 +0800
commit2a8bcfc8ea71d4438b926a8adc477de360863145 (patch)
tree7b9785f1f0c244da1f5b69a2a610e3f37eb786a8 /audio/qsampler
parent62341874a942de5989d54a3ba471cb8719d251ee (diff)
downloadfreebsd-ports-gnome-2a8bcfc8ea71d4438b926a8adc477de360863145.tar.gz
freebsd-ports-gnome-2a8bcfc8ea71d4438b926a8adc477de360863145.tar.zst
freebsd-ports-gnome-2a8bcfc8ea71d4438b926a8adc477de360863145.zip
Replace bsd.qt.mk by Uses/qt.mk and Uses/qt-dist.mk
From now on, ports that depend on Qt4 will have to set USES= qt:4 USE_QT= foo bar ports depending on Qt5 will use USES= qt:5 USE_QT= foo bar PR: 229225 Exp-run by: antoine Reviewed by: mat Approved by: portmgr (antoine) Differential Revision: →https://reviews.freebsd.org/D15540
Diffstat (limited to 'audio/qsampler')
-rw-r--r--audio/qsampler/Makefile13
1 files changed, 7 insertions, 6 deletions
diff --git a/audio/qsampler/Makefile b/audio/qsampler/Makefile
index 740765c8273f..b3b0109e7740 100644
--- a/audio/qsampler/Makefile
+++ b/audio/qsampler/Makefile
@@ -19,7 +19,6 @@ RUN_DEPENDS= linuxsampler:audio/linuxsampler
LDFLAGS+= -L${LOCALBASE}/lib
USES= autoreconf gmake pkgconfig shared-mime-info
-QT_NONSTANDARD= yes
GNU_CONFIGURE= yes
CONFIGURE_ENV= ac_cv_path_ac_cv_qmake=${QMAKE} \
ac_cv_path_ac_moc=${MOC} \
@@ -38,13 +37,15 @@ OPTIONS_DEFAULT= QT5
TOOLKIT_DESC= Qt toolkit
-QT4_USE= qt4=corelib,gui \
- qt4=linguisttools_build \
- qt4=moc_build,qmake_build,rcc_build,uic_build
+QT4_USES= qmake:no_env qt:4
+QT4_USE= qt=corelib,gui \
+ qt=linguisttools_build \
+ qt=moc_build,qmake_build,rcc_build,uic_build
QT4_CONFIGURE_ENABLE= qt4
-QT5_USE= qt5=core,gui,widgets,x11extras \
- qt5=buildtools_build,linguisttools_build,qmake_build
+QT5_USES= qmake:no_env qt:5
+QT5_USE= qt=core,gui,widgets,x11extras \
+ qt=buildtools_build,linguisttools_build,qmake_build
QT5_CONFIGURE_ENABLE= qt5
post-configure: