aboutsummaryrefslogtreecommitdiffstats
path: root/audio/qsynth
diff options
context:
space:
mode:
authormakc <makc@FreeBSD.org>2010-01-26 17:25:07 +0800
committermakc <makc@FreeBSD.org>2010-01-26 17:25:07 +0800
commitf4b5b2e5e7148775788f2f2564ac71995aa28abf (patch)
treef5db6a9d5ebb3560a24dd61b869f999ebf2fe1a5 /audio/qsynth
parent0656a59a6876aad5a49c08149c5f906b85e70614 (diff)
downloadfreebsd-ports-gnome-f4b5b2e5e7148775788f2f2564ac71995aa28abf.tar.gz
freebsd-ports-gnome-f4b5b2e5e7148775788f2f2564ac71995aa28abf.tar.zst
freebsd-ports-gnome-f4b5b2e5e7148775788f2f2564ac71995aa28abf.zip
Update to 0.3.4, change default MIDI input from ALSA to JACK.
PR: ports/138242 Submitted by: trasz@ Approved by: maintainer
Diffstat (limited to 'audio/qsynth')
-rw-r--r--audio/qsynth/Makefile13
-rw-r--r--audio/qsynth/distinfo6
-rw-r--r--audio/qsynth/files/patch-src-qsynthOptions.cpp25
-rw-r--r--audio/qsynth/pkg-plist3
4 files changed, 38 insertions, 9 deletions
diff --git a/audio/qsynth/Makefile b/audio/qsynth/Makefile
index 36938f8c38a8..da1c85711232 100644
--- a/audio/qsynth/Makefile
+++ b/audio/qsynth/Makefile
@@ -6,10 +6,9 @@
#
PORTNAME= qsynth
-DISTVERSION= 0.3.2
-PORTREVISION= 3
+PORTVERSION= 0.3.4
CATEGORIES= audio
-MASTER_SITES= SF/${PORTNAME}/OldFiles
+MASTER_SITES= SF/${PORTNAME}/${PORTNAME}%20%28stable%29/${PORTVERSION}
MAINTAINER= lazyklimm@gmail.com
COMMENT= Qt fluidsynth front-end application
@@ -19,11 +18,13 @@ LIB_DEPENDS= fluidsynth:${PORTSDIR}/audio/fluidsynth
GNU_CONFIGURE= yes
USE_GMAKE= yes
USE_QT_VER= 4
-QT_COMPONENTS= qmake_build moc_build uic_build rcc_build gui xml
+QT_COMPONENTS= gui qmake_build moc_build uic_build rcc_build linguist_build
CFLAGS+= -I${QT_INCDIR} ${PTHREAD_CFLAGS} ${PTHREAD_LIBS}
LDFLAGS+= -L${QT_LIBDIR}
-CONFIGURE_ARGS+=ac_cv_path_ac_moc=${LOCALBASE}/bin/moc-qt4 ac_cv_path_ac_uic=${LOCALBASE}/bin/uic-qt4 \
- ac_cv_path_ac_qmake=${LOCALBASE}/bin/qmake-qt4
+CONFIGURE_ARGS+=ac_cv_path_ac_moc=${MOC} ac_cv_path_ac_uic=${UIC} \
+ ac_cv_path_ac_qmake=${QMAKE} \
+ ac_cv_path_ac_lupdate=${LOCALBASE}/bin/lupdate-qt4 \
+ ac_cv_path_ac_lrelease=${LOCALBASE}/bin/lrelease-qt4
MAKE_JOBS_UNSAFE= yes
.include <bsd.port.mk>
diff --git a/audio/qsynth/distinfo b/audio/qsynth/distinfo
index 017577c27786..ee8dd29ef9b0 100644
--- a/audio/qsynth/distinfo
+++ b/audio/qsynth/distinfo
@@ -1,3 +1,3 @@
-MD5 (qsynth-0.3.2.tar.gz) = be744e4898d05d1b2db89875abac10ba
-SHA256 (qsynth-0.3.2.tar.gz) = d747e6a3a1437580416a218df213624c2020a82bb261ac59d7bcfb821146d236
-SIZE (qsynth-0.3.2.tar.gz) = 139129
+MD5 (qsynth-0.3.4.tar.gz) = 800ab77b59c947bd8f1c8bb10545a59d
+SHA256 (qsynth-0.3.4.tar.gz) = 87542acdd2d238d60d1fd26a61157fcdd34c1ce667543f564f31fd027ced8b07
+SIZE (qsynth-0.3.4.tar.gz) = 190655
diff --git a/audio/qsynth/files/patch-src-qsynthOptions.cpp b/audio/qsynth/files/patch-src-qsynthOptions.cpp
new file mode 100644
index 000000000000..90e3fac954a8
--- /dev/null
+++ b/audio/qsynth/files/patch-src-qsynthOptions.cpp
@@ -0,0 +1,25 @@
+--- src/qsynthOptions.cpp.orig 2009-08-27 18:35:48.000000000 +0200
++++ src/qsynthOptions.cpp 2009-08-27 18:36:39.000000000 +0200
+@@ -155,11 +155,11 @@ void qsynthOptions::print_usage ( const
+ out << " -n, --no-midi-in" + sEot +
+ QObject::tr("Don't create a midi driver to read MIDI input events [default = yes]") + sEol;
+ out << " -m, --midi-driver=[label]" + sEot +
+- QObject::tr("The name of the midi driver to use [oss,alsa,alsa_seq,...]") + sEol;
++ QObject::tr("The name of the midi driver to use [jack,oss,...]") + sEol;
+ out << " -K, --midi-channels=[num]" + sEot +
+ QObject::tr("The number of midi channels [default = 16]") + sEol;
+ out << " -a, --audio-driver=[label]" + sEot +
+- QObject::tr("The audio driver [alsa,jack,oss,dsound,...]") + sEol;
++ QObject::tr("The audio driver [jack,oss,dsound,...]") + sEol;
+ out << " -j, --connect-jack-outputs" + sEot +
+ QObject::tr("Attempt to connect the jack outputs to the physical ports") + sEol;
+ out << " -L, --audio-channels=[num]" + sEot +
+@@ -459,7 +459,7 @@ void qsynthOptions::loadSetup ( qsynthSe
+ pSetup->iAudioBufSize = m_settings.value("/AudioBufSize", 512).toInt();
+ pSetup->iAudioBufCount = m_settings.value("/AudioBufCount", 8).toInt();
+ #else
+- pSetup->sMidiDriver = m_settings.value("/MidiDriver", "alsa_seq").toString();
++ pSetup->sMidiDriver = m_settings.value("/MidiDriver", "jack").toString();
+ pSetup->sAudioDriver = m_settings.value("/AudioDriver", "jack").toString();
+ pSetup->iAudioBufSize = m_settings.value("/AudioBufSize", 64).toInt();
+ pSetup->iAudioBufCount = m_settings.value("/AudioBufCount", 2).toInt();
diff --git a/audio/qsynth/pkg-plist b/audio/qsynth/pkg-plist
index ef65ecdae79e..0dd5ee6ce06a 100644
--- a/audio/qsynth/pkg-plist
+++ b/audio/qsynth/pkg-plist
@@ -1,4 +1,7 @@
bin/qsynth
share/pixmaps/qsynth.png
share/applications/qsynth.desktop
+share/locale/qsynth_de.qm
+share/locale/qsynth_es.qm
+share/locale/qsynth_ru.qm
@dirrmtry share/applications