aboutsummaryrefslogtreecommitdiffstats
path: root/audio/rawrec
diff options
context:
space:
mode:
authorriggs <riggs@FreeBSD.org>2014-12-08 03:25:52 +0800
committerriggs <riggs@FreeBSD.org>2014-12-08 03:25:52 +0800
commitba40e53af59039da85d2eef7aacdd4ee3bd8ce66 (patch)
tree3fd64743f65c40ec5e679c58c2e1508abcbc13ba /audio/rawrec
parentf58c96b1447edb5d6fd3aba476c6718eeb6cefa8 (diff)
downloadfreebsd-ports-gnome-ba40e53af59039da85d2eef7aacdd4ee3bd8ce66.tar.gz
freebsd-ports-gnome-ba40e53af59039da85d2eef7aacdd4ee3bd8ce66.tar.zst
freebsd-ports-gnome-ba40e53af59039da85d2eef7aacdd4ee3bd8ce66.zip
Fix signal handling (runtime exit with invalid argument) on 10.1
- Add missing sa_flags in main.c - Bump PORTREVISION While on it: - Add LICENSE* PR: 195284 Submitted by: antonfb@hesiod.org MFH: 2014Q4
Diffstat (limited to 'audio/rawrec')
-rw-r--r--audio/rawrec/Makefile4
-rw-r--r--audio/rawrec/files/patch-main.c12
2 files changed, 14 insertions, 2 deletions
diff --git a/audio/rawrec/Makefile b/audio/rawrec/Makefile
index f0f6223f4684..2db545484abc 100644
--- a/audio/rawrec/Makefile
+++ b/audio/rawrec/Makefile
@@ -3,6 +3,7 @@
PORTNAME= rawrec
PORTVERSION= 0.9.991
+PORTREVISION= 1
CATEGORIES= audio
MASTER_SITES= ${MASTER_SITE_SUNSITE:S/%SUBDIR%/apps\/sound\/recorders/} \
SF/${PORTNAME}/${PORTNAME}/${PORTNAME}-${PORTVERSION}
@@ -10,6 +11,9 @@ MASTER_SITES= ${MASTER_SITE_SUNSITE:S/%SUBDIR%/apps\/sound\/recorders/} \
MAINTAINER= ports@FreeBSD.org
COMMENT= Utility to record and playback raw audio data
+LICENSE= GPLv2 # or later
+LICENSE_FILE= ${WRKDIR}/${DISTNAME}/copyright
+
WRKSRC= ${WRKDIR}/${DISTNAME}/src
USES= gmake
diff --git a/audio/rawrec/files/patch-main.c b/audio/rawrec/files/patch-main.c
index d0d41aeed4c5..f6db5853685a 100644
--- a/audio/rawrec/files/patch-main.c
+++ b/audio/rawrec/files/patch-main.c
@@ -1,5 +1,5 @@
---- main.c.orig Wed May 10 17:27:08 2006
-+++ main.c Wed May 10 17:30:21 2006
+--- main.c.orig 2006-01-22 03:40:17.000000000 +0100
++++ main.c 2014-12-07 19:14:39.778784753 +0100
@@ -14,6 +14,12 @@
#include "rawrec.h"
@@ -13,3 +13,11 @@
int main(int argc, char *argv[])
{
/* Action for ignoring signals we don't want to deal with. */
+@@ -118,6 +124,7 @@
+ strncpy(cnst_dflt_format, "s16_le", (size_t) (MAX_FORMAT_STRING_LENGTH + 1));
+
+ /* at the moment, this application goes with the default for most signals */
++ ignorer_act.sa_flags = 0;
+ ignorer_act.sa_handler = SIG_IGN;
+ /* because I'm unclear on how SIGIO is supposed to work, it's not
+ applicable here, and I'm paranoid */