aboutsummaryrefslogtreecommitdiffstats
path: root/audio/rezound/Makefile
diff options
context:
space:
mode:
authordanfe <danfe@FreeBSD.org>2006-10-04 00:39:13 +0800
committerdanfe <danfe@FreeBSD.org>2006-10-04 00:39:13 +0800
commit53d789791f8a2520949508ceabccfeb83781314c (patch)
treeb90f0db763ee1a09aa802e3cec1039cb7b19b101 /audio/rezound/Makefile
parent1c6bf9edd3383c445d4ce77fd8b3225cc642308f (diff)
downloadfreebsd-ports-gnome-53d789791f8a2520949508ceabccfeb83781314c.tar.gz
freebsd-ports-gnome-53d789791f8a2520949508ceabccfeb83781314c.tar.zst
freebsd-ports-gnome-53d789791f8a2520949508ceabccfeb83781314c.zip
Try to fix the build on 4.X.
Reported by: krismail
Diffstat (limited to 'audio/rezound/Makefile')
-rw-r--r--audio/rezound/Makefile14
1 files changed, 14 insertions, 0 deletions
diff --git a/audio/rezound/Makefile b/audio/rezound/Makefile
index 17415e069b32..866a581a49e3 100644
--- a/audio/rezound/Makefile
+++ b/audio/rezound/Makefile
@@ -99,6 +99,16 @@ CONFIGURE_ARGS+= --disable-nls
PLIST_SUB+= NLS="@comment "
.endif
+.if defined(GCCVERSION)
+. if ${GCCVERSION} < 030000
+EXTRA_PATCHES+= ${FILESDIR}/extra-patch-fbsd4
+. endif
+.else
+. if ${OSVERSION} < 500035
+EXTRA_PATCHES+= ${FILESDIR}/extra-patch-fbsd4
+. endif
+.endif
+
post-patch: .SILENT
.if ${OSVERSION} > 500027
${REINPLACE_CMD} -e '/atoll/d' ${WRKSRC}/config/platform/bsd.h
@@ -109,6 +119,10 @@ post-patch: .SILENT
.if ${OSVERSION} > 502120
${REINPLACE_CMD} -e '/nearbyint/d' ${WRKSRC}/config/platform/bsd.h
.endif
+.if ${OSVERSION} < 500028
+ ${REINPLACE_CMD} -e '22586,$$s/stdint/inttypes/' \
+ -e '21693s/$$srcdir/..\/../' ${WRKSRC}/configure
+.endif
${REINPLACE_CMD} -E 's,(_nl_expand_alias \()\),\1...),' ${WRKSRC}/configure
${REINPLACE_CMD} -e 's,$$(prefix)/doc,$$(datadir)/doc,' \
${WRKSRC}/config/am_include.mk ${WRKSRC}/Makefile.in \