aboutsummaryrefslogtreecommitdiffstats
path: root/audio/sdl_mixer/Makefile
diff options
context:
space:
mode:
authorwill <will@FreeBSD.org>2000-04-26 05:19:17 +0800
committerwill <will@FreeBSD.org>2000-04-26 05:19:17 +0800
commitd0df8d7b89a94906d37acb549e108ca6e9fdf707 (patch)
tree9a0bbeee123e5942a159f68da97061e520cf8bd1 /audio/sdl_mixer/Makefile
parent4c3c4d8a7d65826e705a830676647994d364ca8b (diff)
downloadfreebsd-ports-gnome-d0df8d7b89a94906d37acb549e108ca6e9fdf707.tar.gz
freebsd-ports-gnome-d0df8d7b89a94906d37acb549e108ca6e9fdf707.tar.zst
freebsd-ports-gnome-d0df8d7b89a94906d37acb549e108ca6e9fdf707.zip
Add SDL_mixer, an audio library based on SDL 1.1.
PR: 18190 Submitted by: Maxim Sobolev <sobomax@altavista.net>
Diffstat (limited to 'audio/sdl_mixer/Makefile')
-rw-r--r--audio/sdl_mixer/Makefile26
1 files changed, 26 insertions, 0 deletions
diff --git a/audio/sdl_mixer/Makefile b/audio/sdl_mixer/Makefile
new file mode 100644
index 000000000000..468558df60e0
--- /dev/null
+++ b/audio/sdl_mixer/Makefile
@@ -0,0 +1,26 @@
+# New ports collection makefile for: sdl_mixer
+# Date created: 24 Aprim 2000
+# Whom: Maxim Sobolev <sobomax@altavista.net>
+#
+# $FreeBSD$
+#
+
+PORTNAME= sdl_mixer
+PORTVERSION= 1.0.5
+CATEGORIES= audio
+MASTER_SITES= http://www.devolution.com/~slouken/SDL/projects/SDL_mixer/src/
+DISTNAME= SDL_mixer-${PORTVERSION}
+
+MAINTAINER= sobomax@altavista.net
+
+LIB_DEPENDS= SDL-1.1.2:${PORTSDIR}/devel/sdl-devel \
+ smpeg-0.3.0:${PORTSDIR}/graphics/smpeg \
+ mikmod.2:${PORTSDIR}/audio/libmikmod
+
+SDL_CONFIG= ${LOCALBASE}/bin/sdl11-config
+GNU_CONFIGURE= yes
+USE_GMAKE= yes
+CONFIGURE_ENV= SDL_CONFIG="${SDL_CONFIG}" \
+ CPPFLAGS="-I${X11BASE}/include"
+
+.include <bsd.port.mk>