aboutsummaryrefslogtreecommitdiffstats
path: root/audio/shntool
diff options
context:
space:
mode:
authorBaptiste Daroussin <bapt@FreeBSD.org>2012-12-17 10:15:13 +0800
committerBaptiste Daroussin <bapt@FreeBSD.org>2012-12-17 10:15:13 +0800
commit3bdf701a5c55426eb679205359bb384d7019a1a2 (patch)
tree2462f02d26b3d6c876b0b158f0a6aa557f06a219 /audio/shntool
parent87b9f8cbd167accbbbbcf020b1dfed71e5f93278 (diff)
downloadfreebsd-ports-gnome-3bdf701a5c55426eb679205359bb384d7019a1a2.tar.gz
freebsd-ports-gnome-3bdf701a5c55426eb679205359bb384d7019a1a2.tar.zst
freebsd-ports-gnome-3bdf701a5c55426eb679205359bb384d7019a1a2.zip
Convert miwi's ports to new Options framework
While here fix some consistency in PEAR options name bumped revision of net/icpld and net/ipsumdump because IPV6 is now on Approved by: miwi (maintainer)
Diffstat (limited to 'audio/shntool')
-rw-r--r--audio/shntool/Makefile38
1 files changed, 17 insertions, 21 deletions
diff --git a/audio/shntool/Makefile b/audio/shntool/Makefile
index 9e676b1885cd..c02659746f6f 100644
--- a/audio/shntool/Makefile
+++ b/audio/shntool/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: shntool
-# Date created: 2 November 2000
-# Whom: Bill Fenner <fenner@FreeBSD.org>
-#
+# Created by: Bill Fenner <fenner@FreeBSD.org>
# $FreeBSD$
-#
PORTNAME= shntool
PORTVERSION= 3.0.10
@@ -19,27 +15,27 @@ SHN_ALIASES= tool len fix hash pad join split cat cmp cue conv info strip gen tr
PLIST_FILES= ${SHN_ALIASES:S|^|bin/shn|}
MAN1= shntool.1
-OPTIONS= AIFF "AIFF support via sox" off \
- SHN "Shorten support" off \
- FLAC "FLAC support" off \
- APE "Monkey's Audio support" off \
- OFR "OptimFROG support" off \
- LPAC "LPAC support" off \
- WV "WavPack support" off \
- ALAC "Apple Lossless Audio support" off \
- LA "Laudio support" off \
- TTA "TTA Lossless Audio support" off \
- BONK "Bonk lossy/lossless audio support" off \
- KXS "Kexis support" off
-# ALS "MPEG-4 Audio Lossless Coding support" off \
+OPTIONS_DEFINE= AIFF SHN FLAC APE OFR LPAC WV ALAC LA TTA BONK KXS
+AIFF_DESC= AIFF support via sox
+SHN_DESC= Shorten support
+OFR_DESC= OptimFROG support
+LPAC_DESC= LPAC support
+WV_DESC= WavPack support
+ALAC_DESC= Apple Lossless Audio support
+LA_DESC= Laudio support
+TTA_DESC= TTA Lossless Audio support
+BONK_DESC= Bonk lossy/lossless audio support
+KXS_DESC= Kexis support
+ALS_DESC= MPEG-4 Audio Lossless Coding support
+
RDEP= AIFF:sox SHN:shorten FLAC APE:mac OFR:ofr:optimfrog LPAC WV:wavpack \
ALAC:alac LA:laudio TTA:ttaenc:tta ALS:mp4als BONK KXS:kexis
-.include <bsd.port.pre.mk>
+.include <bsd.port.options.mk>
.for i in ${RDEP}
o= ${i:C/:.*//}
-. ifdef WITH_${o}
+. if ${PORT_OPTIONS:M${o}}
b= ${i:C/^[A-Z]*://:C/:.*//:L}
p= ${i:C/^[A-Z]*://:C/.*://:L}
RUN_DEPENDS+= ${b}:${PORTSDIR}/audio/${p}
@@ -47,4 +43,4 @@ RUN_DEPENDS:= ${RUN_DEPENDS}
. endif
.endfor
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>